summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-03-04 21:15:15 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-03-04 21:15:31 +1100
commit264551bbcaaefeeaf6e057bc1cd9f2d8c32a5f44 (patch)
treed83a2cf267074deca593cebf9baccf179e461854 /media-sound/qtgain/qtgain-1.0.0.ebuild
parentapp-emacs/rudel: Remove old. (diff)
downloadgentoo-264551bbcaaefeeaf6e057bc1cd9f2d8c32a5f44.tar.gz
gentoo-264551bbcaaefeeaf6e057bc1cd9f2d8c32a5f44.tar.bz2
gentoo-264551bbcaaefeeaf6e057bc1cd9f2d8c32a5f44.zip
media-sound/qtgain: version bump 1.0.0
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'media-sound/qtgain/qtgain-1.0.0.ebuild')
-rw-r--r--media-sound/qtgain/qtgain-1.0.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/qtgain/qtgain-1.0.0.ebuild b/media-sound/qtgain/qtgain-1.0.0.ebuild
new file mode 100644
index 000000000000..4a3cab46acb7
--- /dev/null
+++ b/media-sound/qtgain/qtgain-1.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="QtGain"
+inherit eutils qmake-utils
+
+DESCRIPTION="A simple frontend to mp3gain, vorbisgain and metaflac"
+HOMEPAGE="https://www.linux-apps.com/content/show.php/QtGain?content=56842"
+SRC_URI="https://dl.opendesktop.org/api/files/download/id/1466640864/56842-${MY_PN}_${PV}.zip"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flac mp3 mp4 vorbis"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+"
+DEPEND="dev-qt/qtgui:4"
+
+S="${WORKDIR}/${PN}"
+
+src_configure() {
+ eqmake5 ${MY_PN}.pro
+}
+
+src_install() {
+ dobin bin/${PN}
+ newicon Icons/lsongs.png ${PN}.png
+ make_desktop_entry ${PN} ${MY_PN}
+}
+
+pkg_postinst() {
+ elog "Additional features can be enabled by installing optional packages:"
+ elog ""
+ elog "media-libs/flac - flac support"
+ elog "media-sound/aacgain - aac support"
+ elog "media-sound/mp3gain - mp3 support"
+ elog "media-sound/vorbisgain - vorbis support"
+ elog "media-sound/id3v2 - mass renamer and cover downloader"
+}