summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-05 15:47:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-06 18:45:39 +0200
commit416389103a4f6b42295b9975b6fc82278cc7b3d4 (patch)
tree8c080faa7d5cd4ee990f45cf24df9764a117d4b1 /media-sound
parentmedia-libs/webvfx: Drop 1.1.0 (diff)
downloadgentoo-416389103a4f6b42295b9975b6fc82278cc7b3d4.tar.gz
gentoo-416389103a4f6b42295b9975b6fc82278cc7b3d4.tar.bz2
gentoo-416389103a4f6b42295b9975b6fc82278cc7b3d4.zip
media-sound/yarock: Fix .desktop file and appdata install location
Also raising to >=media-libs/phonon-4.11.0, first version to drop Qt4. Closes: https://bugs.gentoo.org/740524 Closes: https://bugs.gentoo.org/740506 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/yarock/yarock-1.4.0-r1.ebuild (renamed from media-sound/yarock/yarock-1.4.0.ebuild)12
1 files changed, 10 insertions, 2 deletions
diff --git a/media-sound/yarock/yarock-1.4.0.ebuild b/media-sound/yarock/yarock-1.4.0-r1.ebuild
index 27284bd85984..39414485b05d 100644
--- a/media-sound/yarock/yarock-1.4.0.ebuild
+++ b/media-sound/yarock/yarock-1.4.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,7 +29,7 @@ RDEPEND="
dev-qt/qtxml:5
media-libs/taglib
x11-libs/libX11
- phonon? ( >=media-libs/phonon-4.10.1 )
+ phonon? ( >=media-libs/phonon-4.11.0 )
vlc? ( media-video/vlc:= )
"
DEPEND="${RDEPEND}
@@ -41,6 +41,14 @@ DOCS=( CHANGES.md README.md )
S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ cmake_src_prepare
+ sed -e "/^install.*org.yarock.appdata.xml/s:share/appdata:share/metadata:" \
+ -i CMakeLists.txt || die
+ sed -e "/^Version/d" \
+ -i data/org.yarock.desktop || die
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_QT5=ON