summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-19 13:49:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-19 13:49:36 +0200
commit8d85ad34bad5eb35697a8d554eb4484fb5f92b62 (patch)
treec07bafdffd22e923a2b5cbc744e12e34c1036e2f /media-sound
parentnet-proxy/haproxy: Version bumps (diff)
downloadgentoo-8d85ad34bad5eb35697a8d554eb4484fb5f92b62.tar.gz
gentoo-8d85ad34bad5eb35697a8d554eb4484fb5f92b62.tar.bz2
gentoo-8d85ad34bad5eb35697a8d554eb4484fb5f92b62.zip
media-sound/twolame: Fix tests with recent perl, bug #605726.
Patch by Kent Fredric. Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/twolame/files/0.3.13-perl-tests.patch32
-rw-r--r--media-sound/twolame/twolame-0.3.13-r2.ebuild4
2 files changed, 35 insertions, 1 deletions
diff --git a/media-sound/twolame/files/0.3.13-perl-tests.patch b/media-sound/twolame/files/0.3.13-perl-tests.patch
new file mode 100644
index 000000000000..5ec5b6601770
--- /dev/null
+++ b/media-sound/twolame/files/0.3.13-perl-tests.patch
@@ -0,0 +1,32 @@
+From 11a5ecb89de1e61b016f3d7f358b09a4e611f1ad Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Tue, 17 Jan 2017 12:18:10 +1300
+Subject: [PATCH] tests/test.pl: stat the right file
+
+stat(@_) is effectively stat scalar @_
+
+becasue "stat" has a signature of "$" which coerces arrays to
+scalars, which here, returns the length of the array.
+
+This is going to be number 1, instead of the desired argument,
+ the filename.
+---
+ tests/test.pl | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test.pl b/tests/test.pl
+index 658eadf..5513d6e 100755
+--- a/tests/test.pl
++++ b/tests/test.pl
+@@ -185,7 +185,7 @@ sub input_filepath {
+ }
+
+ sub filesize {
+- return (stat(@_))[7];
++ return (stat($_[0]))[7];
+ }
+
+ sub md5_file {
+--
+2.11.0
+
diff --git a/media-sound/twolame/twolame-0.3.13-r2.ebuild b/media-sound/twolame/twolame-0.3.13-r2.ebuild
index 31fcf8be8d30..6ce14c44ee50 100644
--- a/media-sound/twolame/twolame-0.3.13-r2.ebuild
+++ b/media-sound/twolame/twolame-0.3.13-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,6 +20,8 @@ RDEPEND=">=media-libs/libsndfile-1.0.25[${MULTILIB_USEDEP}]
DEPEND="${RDEPEND}
virtual/pkgconfig"
+PATCHES=( "${FILESDIR}/${PV}-perl-tests.patch" )
+
src_prepare() {
sed -i -e '/CFLAGS/s:-O3::' configure || die
# remove -Werror, bug 493940