summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2019-04-08 22:08:11 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-04-08 22:08:11 -0400
commit988c0ffb4c868eb82efc0a37169b96c3548dbd5e (patch)
tree5eb7e449c699d6f5691ebbf8db5b5449d33b5576 /media-sound
parentx11-libs/cairo: drop vulnerable wrt bug #672908 (diff)
downloadgentoo-988c0ffb4c868eb82efc0a37169b96c3548dbd5e.tar.gz
gentoo-988c0ffb4c868eb82efc0a37169b96c3548dbd5e.tar.bz2
gentoo-988c0ffb4c868eb82efc0a37169b96c3548dbd5e.zip
media-sound/playerctl: fix gdbus-codegen handling in configure.ac
In configure.ac, the **absolute** path of gdbus-codegen (as obtained by pkg-config) is passed to AC_PATH_PROG. The macro then appends this path to the directories in PATH and tests if the result is executable. This internally results in checking for '/usr/bin/usr/bin/gdbus-codegen'. The macro is redundant because the value returned by pkg-config is sufficient. Closes: https://bugs.gentoo.org/682788 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/playerctl/files/playerctl-gdbus-codegen-fix.patch15
-rw-r--r--media-sound/playerctl/playerctl-0.5.0.ebuild4
-rw-r--r--media-sound/playerctl/playerctl-0.6.0.ebuild4
3 files changed, 21 insertions, 2 deletions
diff --git a/media-sound/playerctl/files/playerctl-gdbus-codegen-fix.patch b/media-sound/playerctl/files/playerctl-gdbus-codegen-fix.patch
new file mode 100644
index 000000000000..06c073aa2761
--- /dev/null
+++ b/media-sound/playerctl/files/playerctl-gdbus-codegen-fix.patch
@@ -0,0 +1,15 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -21,10 +21,11 @@
+ PKG_CHECK_MODULES([GOBJECT], [gobject-2.0 >= 2.38])
+ PKG_CHECK_MODULES([GIO], [gio-unix-2.0])
+
+-AC_PATH_PROG([GDBUS_CODEGEN], [`$PKG_CONFIG --variable=gdbus_codegen gio-2.0`])
++GDBUS_CODEGEN=`$PKG_CONFIG --variable=gdbus_codegen gio-2.0`
+ if test -z "$GDBUS_CODEGEN"; then
+ AC_MSG_ERROR([*** gdbus-codegen is required to build playerctl])
+ fi
++AC_SUBST(GDBUS_CODEGEN)
+
+ # Checks for typedefs, structures, and compiler characteristics
+ AC_PROG_CC_STDC
diff --git a/media-sound/playerctl/playerctl-0.5.0.ebuild b/media-sound/playerctl/playerctl-0.5.0.ebuild
index a06816f38bd9..0a05e650f208 100644
--- a/media-sound/playerctl/playerctl-0.5.0.ebuild
+++ b/media-sound/playerctl/playerctl-0.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -29,6 +29,8 @@ src_prepare() {
echo 'EXTRA_DIST = ' > gtk-doc.make || die
fi
+ eapply "${FILESDIR}"/"${PN}"-gdbus-codegen-fix.patch
+
default
eautoreconf
}
diff --git a/media-sound/playerctl/playerctl-0.6.0.ebuild b/media-sound/playerctl/playerctl-0.6.0.ebuild
index 8741ea6e29e6..4effb5f74a60 100644
--- a/media-sound/playerctl/playerctl-0.6.0.ebuild
+++ b/media-sound/playerctl/playerctl-0.6.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -29,6 +29,8 @@ src_prepare() {
echo 'EXTRA_DIST = ' > gtk-doc.make || die
fi
+ eapply "${FILESDIR}"/"${PN}"-gdbus-codegen-fix.patch
+
default
eautoreconf
}