summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2018-07-16 18:44:11 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2018-07-16 18:45:19 -0400
commitdc1e82a8b5e4c7aaa04bcb005f17fc3dd1d8618e (patch)
tree28b9ab0130d62b2f86d4d346d3eb5535fd829f18 /media-sound
parentnet-libs/zmqpp: EAPI-6 bump (diff)
downloadgentoo-dc1e82a8b5e4c7aaa04bcb005f17fc3dd1d8618e.tar.gz
gentoo-dc1e82a8b5e4c7aaa04bcb005f17fc3dd1d8618e.tar.bz2
gentoo-dc1e82a8b5e4c7aaa04bcb005f17fc3dd1d8618e.zip
media-sound/playerctl: bump to 0.6.1
This version switches from autotools to meson. Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/playerctl/Manifest1
-rw-r--r--media-sound/playerctl/files/playerctl-0.6.1-doc-typesfile-path-fix.patch28
-rw-r--r--media-sound/playerctl/playerctl-0.6.1.ebuild41
3 files changed, 70 insertions, 0 deletions
diff --git a/media-sound/playerctl/Manifest b/media-sound/playerctl/Manifest
index 8abb779fa237..7f6cf729b539 100644
--- a/media-sound/playerctl/Manifest
+++ b/media-sound/playerctl/Manifest
@@ -1,2 +1,3 @@
DIST playerctl-0.5.0.tar.gz 17015 BLAKE2B 5da1d0fd4e442ac5f124bd693ae14222624c5239c9fad72e57d43977467339522344bc8d8c37b0f2bfda51c61861dc33d7e35e4a730ce59a87b691b5657ec729 SHA512 307cad5eeea7efa0c97c885660f49468f442fe907ef2495b56ac512e0551c7248750897b6d00934cbfcfcb35f486a101a238b276ef71d2ef866132ca3cc0932c
DIST playerctl-0.6.0.tar.gz 22124 BLAKE2B 6bb90586c56e21a00b5e6e1769248b9782a8211b01dacf590857fe4fe199d6d3fa7aa46a36cba9a8e198a1aad0bf17973fc15140db11c484edfb0275971d3d08 SHA512 8023b5704ca2a428510df6228850b616061289764cc3c4190c0c46f79d6a20e499495f2d773bd821357653ba63bca40eac70f7cc3a11251da3c6a4f7781db739
+DIST playerctl-0.6.1.tar.gz 22921 BLAKE2B d2f5874280e1a99b318bc83c40a38ee31d9c68426cb63e1e16e8ded26bac1a894d78a929f46d45d631af70e37476a4151c520eb69c94e80026689a12c682f0ad SHA512 07c302eb06a96bf3b8aa180e68e85ef6f9fdb5933b80fbce8ee5f9a36c1d961eaf5638e319ff0b26475984acc57a447a4aa8e705667f77e4bd393364cdbfb284
diff --git a/media-sound/playerctl/files/playerctl-0.6.1-doc-typesfile-path-fix.patch b/media-sound/playerctl/files/playerctl-0.6.1-doc-typesfile-path-fix.patch
new file mode 100644
index 000000000000..75ba5b61f9f1
--- /dev/null
+++ b/media-sound/playerctl/files/playerctl-0.6.1-doc-typesfile-path-fix.patch
@@ -0,0 +1,28 @@
+From f5fefa32f1ac59d2a9c00221281fe3541845d6d2 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?G=C3=B6kt=C3=BCrk=20Y=C3=BCksek?= <gokturk@gentoo.org>
+Date: Mon, 16 Jul 2018 18:21:21 -0400
+Subject: [PATCH] doc: look for gobject_typesfile in build dir
+
+Looking for playerctl.types file in the source directory is a mistake
+because it's generated during build and placed in build dir. Look for
+the types file in build dir instead.
+---
+ doc/reference/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/doc/reference/meson.build b/doc/reference/meson.build
+index 100d561..b5a16a7 100644
+--- a/doc/reference/meson.build
++++ b/doc/reference/meson.build
+@@ -19,7 +19,7 @@ gnome.gtkdoc(
+ '--name-space=meson.project_name()',
+ ],
+ scan_args: '--deprecated-guards="PLAYERCTL_DISABLE_DEPRECATED"',
+- gobject_typesfile: meson.project_name() + '.types',
++ gobject_typesfile: join_paths(meson.current_build_dir(), meson.project_name() + '.types'),
+ fixxref_args: [
+ '--extra-dir=@0@'.format(join_paths(glib_docpath, 'gobject')),
+ '--extra-dir=@0@'.format(join_paths(glib_docpath, 'gio')),
+--
+2.17.0
+
diff --git a/media-sound/playerctl/playerctl-0.6.1.ebuild b/media-sound/playerctl/playerctl-0.6.1.ebuild
new file mode 100644
index 000000000000..262d4ae14ff6
--- /dev/null
+++ b/media-sound/playerctl/playerctl-0.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson xdg-utils
+
+DESCRIPTION="A CLI utility to control media players over MPRIS"
+HOMEPAGE="https://github.com/acrisci/playerctl"
+SRC_URI="https://github.com/acrisci/playerctl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc introspection"
+
+RDEPEND="
+ dev-libs/glib:2
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+# Override the meson dependency in MESON_DEPEND of meson.eclass
+# The eclass depends on '>=dev-util/meson-0.40.0' as of writing this
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ >=dev-util/meson-0.46.0
+ doc? ( dev-util/gtk-doc )
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.1-doc-typesfile-path-fix.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use doc gtk-doc)
+ $(meson_use introspection)
+ )
+
+ xdg_environment_reset # 596166
+ meson_src_configure
+}