summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-05-02 15:26:20 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-05-02 15:26:20 +0300
commita6edfaa9a8f21f953112b01436bbda5166f29c2e (patch)
treeaa4f659652aaba493e75c42f8afb43a4f9a0eeb6 /media-tv/kodi
parentnet-misc/websocat: remove libressl support (diff)
downloadgentoo-a6edfaa9a8f21f953112b01436bbda5166f29c2e.tar.gz
gentoo-a6edfaa9a8f21f953112b01436bbda5166f29c2e.tar.bz2
gentoo-a6edfaa9a8f21f953112b01436bbda5166f29c2e.zip
media-tv/kodi: remove libressl support
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'media-tv/kodi')
-rw-r--r--media-tv/kodi/kodi-19.0.ebuild10
-rw-r--r--media-tv/kodi/kodi-19.9999.ebuild10
-rw-r--r--media-tv/kodi/kodi-9999.ebuild10
3 files changed, 12 insertions, 18 deletions
diff --git a/media-tv/kodi/kodi-19.0.ebuild b/media-tv/kodi/kodi-19.0.ebuild
index a39d3ca1acd0..aae8e4ae5e6e 100644
--- a/media-tv/kodi/kodi-19.0.ebuild
+++ b/media-tv/kodi/kodi-19.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_REQ_USE="libressl?,sqlite,ssl"
+PYTHON_REQ_USE="sqlite,ssl"
LIBDVDCSS_VERSION="1.4.2-Leia-Beta-5"
LIBDVDREAD_VERSION="6.0.0-Leia-Alpha-3"
LIBDVDNAV_VERSION="6.0.0-Leia-Alpha-3"
@@ -40,7 +40,7 @@ SLOT="0"
# use flag is called libusb so that it doesn't fool people in thinking that
# it is _required_ for USB support. Otherwise they'll disable udev and
# that's going to be worse.
-IUSE="airplay alsa bluetooth bluray caps cec +css dav1d dbus eventclients gbm gles lcms libressl libusb lirc mariadb mysql nfs +optical power-control pulseaudio raspberry-pi samba +system-ffmpeg test udf udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
+IUSE="airplay alsa bluetooth bluray caps cec +css dav1d dbus eventclients gbm gles lcms libusb lirc mariadb mysql nfs +optical power-control pulseaudio raspberry-pi samba +system-ffmpeg test udf udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
IUSE="${IUSE} cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_arm_neon"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
@@ -108,8 +108,7 @@ COMMON_TARGET_DEPEND="${PYTHON_DEPS}
>=media-libs/taglib-1.11.1
system-ffmpeg? (
>=media-video/ffmpeg-${FFMPEG_VERSION}:=[dav1d?,encode,postproc]
- libressl? ( media-video/ffmpeg[libressl,-openssl] )
- !libressl? ( media-video/ffmpeg[-libressl,openssl] )
+ media-video/ffmpeg[openssl]
)
!system-ffmpeg? (
app-arch/bzip2
@@ -120,8 +119,7 @@ COMMON_TARGET_DEPEND="${PYTHON_DEPS}
>=net-misc/curl-7.68.0[http2]
nfs? ( >=net-fs/libnfs-2.0.0:= )
!gles? ( media-libs/glu )
- !libressl? ( >=dev-libs/openssl-1.0.2l:0= )
- libressl? ( dev-libs/libressl:0= )
+ >=dev-libs/openssl-1.0.2l:0=
raspberry-pi? (
|| ( media-libs/raspberrypi-userland media-libs/raspberrypi-userland-bin media-libs/mesa[egl,gles2,video_cards_vc4] )
)
diff --git a/media-tv/kodi/kodi-19.9999.ebuild b/media-tv/kodi/kodi-19.9999.ebuild
index e644af36dbdb..ef65967b6723 100644
--- a/media-tv/kodi/kodi-19.9999.ebuild
+++ b/media-tv/kodi/kodi-19.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_REQ_USE="libressl?,sqlite,ssl"
+PYTHON_REQ_USE="sqlite,ssl"
LIBDVDCSS_VERSION="1.4.2-Leia-Beta-5"
LIBDVDREAD_VERSION="6.0.0-Leia-Alpha-3"
LIBDVDNAV_VERSION="6.0.0-Leia-Alpha-3"
@@ -40,7 +40,7 @@ SLOT="0"
# use flag is called libusb so that it doesn't fool people in thinking that
# it is _required_ for USB support. Otherwise they'll disable udev and
# that's going to be worse.
-IUSE="airplay alsa bluetooth bluray caps cec +css dav1d dbus eventclients gbm gles lcms libressl libusb lirc mariadb mysql nfs +optical power-control pulseaudio raspberry-pi samba +system-ffmpeg test udf udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
+IUSE="airplay alsa bluetooth bluray caps cec +css dav1d dbus eventclients gbm gles lcms libusb lirc mariadb mysql nfs +optical power-control pulseaudio raspberry-pi samba +system-ffmpeg test udf udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
IUSE="${IUSE} cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_arm_neon"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
@@ -108,8 +108,7 @@ COMMON_TARGET_DEPEND="${PYTHON_DEPS}
>=media-libs/taglib-1.11.1
system-ffmpeg? (
>=media-video/ffmpeg-${FFMPEG_VERSION}:=[dav1d?,encode,postproc]
- libressl? ( media-video/ffmpeg[libressl,-openssl] )
- !libressl? ( media-video/ffmpeg[-libressl,openssl] )
+ media-video/ffmpeg[openssl]
)
!system-ffmpeg? (
app-arch/bzip2
@@ -120,8 +119,7 @@ COMMON_TARGET_DEPEND="${PYTHON_DEPS}
>=net-misc/curl-7.68.0[http2]
nfs? ( >=net-fs/libnfs-2.0.0:= )
!gles? ( media-libs/glu )
- !libressl? ( >=dev-libs/openssl-1.0.2l:0= )
- libressl? ( dev-libs/libressl:0= )
+ >=dev-libs/openssl-1.0.2l:0=
raspberry-pi? (
|| ( media-libs/raspberrypi-userland media-libs/raspberrypi-userland-bin media-libs/mesa[egl,gles2,video_cards_vc4] )
)
diff --git a/media-tv/kodi/kodi-9999.ebuild b/media-tv/kodi/kodi-9999.ebuild
index ed3088186095..e60c2a97fb5f 100644
--- a/media-tv/kodi/kodi-9999.ebuild
+++ b/media-tv/kodi/kodi-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_REQ_USE="libressl?,sqlite,ssl"
+PYTHON_REQ_USE="sqlite,ssl"
LIBDVDCSS_VERSION="1.4.2-Leia-Beta-5"
LIBDVDREAD_VERSION="6.0.0-Leia-Alpha-3"
LIBDVDNAV_VERSION="6.0.0-Leia-Alpha-3"
@@ -39,7 +39,7 @@ SLOT="0"
# use flag is called libusb so that it doesn't fool people in thinking that
# it is _required_ for USB support. Otherwise they'll disable udev and
# that's going to be worse.
-IUSE="airplay alsa bluetooth bluray caps cec +css dav1d dbus eventclients gbm gles lcms libressl libusb lirc mariadb mysql nfs +optical power-control pulseaudio raspberry-pi samba +system-ffmpeg test udf udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
+IUSE="airplay alsa bluetooth bluray caps cec +css dav1d dbus eventclients gbm gles lcms libusb lirc mariadb mysql nfs +optical power-control pulseaudio raspberry-pi samba +system-ffmpeg test udf udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
IUSE="${IUSE} cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_arm_neon"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
@@ -107,8 +107,7 @@ COMMON_TARGET_DEPEND="${PYTHON_DEPS}
>=media-libs/taglib-1.11.1
system-ffmpeg? (
>=media-video/ffmpeg-${FFMPEG_VERSION}:=[dav1d?,encode,postproc]
- libressl? ( media-video/ffmpeg[libressl,-openssl] )
- !libressl? ( media-video/ffmpeg[-libressl,openssl] )
+ media-video/ffmpeg[openssl]
)
!system-ffmpeg? (
app-arch/bzip2
@@ -119,8 +118,7 @@ COMMON_TARGET_DEPEND="${PYTHON_DEPS}
>=net-misc/curl-7.68.0[http2]
nfs? ( >=net-fs/libnfs-2.0.0:= )
!gles? ( media-libs/glu )
- !libressl? ( >=dev-libs/openssl-1.0.2l:0= )
- libressl? ( dev-libs/libressl:0= )
+ >=dev-libs/openssl-1.0.2l:0=
raspberry-pi? (
|| ( media-libs/raspberrypi-userland media-libs/raspberrypi-userland-bin media-libs/mesa[egl,gles2,video_cards_vc4] )
)