summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/chaplin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/chaplin')
-rw-r--r--media-video/chaplin/Manifest1
-rw-r--r--media-video/chaplin/chaplin-1.10-r1.ebuild37
-rw-r--r--media-video/chaplin/files/chaplin-1.10-asneeded.patch15
-rw-r--r--media-video/chaplin/files/chaplin-1.10-libdvdread-0.9.6.patch11
-rw-r--r--media-video/chaplin/metadata.xml11
5 files changed, 75 insertions, 0 deletions
diff --git a/media-video/chaplin/Manifest b/media-video/chaplin/Manifest
new file mode 100644
index 000000000000..e68e2e5cc17d
--- /dev/null
+++ b/media-video/chaplin/Manifest
@@ -0,0 +1 @@
+DIST chaplin-1.10.tgz 23843 RMD160 2a24075486edd52b5ed24254b5ff9a8d845bf4fc SHA1 864fe0942998f79044f3cb3ce8decc8831edbcfe SHA256 064d3226d003477ae81273cee3870b5797f647623f67eb05e5c1e2e910d89228
diff --git a/media-video/chaplin/chaplin-1.10-r1.ebuild b/media-video/chaplin/chaplin-1.10-r1.ebuild
new file mode 100644
index 000000000000..fed2d9681c7b
--- /dev/null
+++ b/media-video/chaplin/chaplin-1.10-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="This is a program to raw copy chapters from a dvd using libdvdread"
+HOMEPAGE="http://www.lallafa.de/bp/chaplin.html"
+SRC_URI="http://www.lallafa.de/bp/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="transcode vcd"
+
+DEPEND=">=media-libs/libdvdread-0.9.4"
+RDEPEND="${DEPEND}
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ media-video/mjpegtools
+ transcode? ( >=media-video/transcode-0.6.2 )
+ vcd? ( >=media-video/vcdimager-0.7.2 )"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libdvdread-0.9.6.patch \
+ "${FILESDIR}"/${P}-asneeded.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin chaplin chaplin-genmenu
+}
diff --git a/media-video/chaplin/files/chaplin-1.10-asneeded.patch b/media-video/chaplin/files/chaplin-1.10-asneeded.patch
new file mode 100644
index 000000000000..f7cb499407a8
--- /dev/null
+++ b/media-video/chaplin/files/chaplin-1.10-asneeded.patch
@@ -0,0 +1,15 @@
+--- chaplin.orig/Makefile 2004-03-21 18:44:18.000000000 +0100
++++ chaplin/Makefile 2009-10-25 18:34:26.082229887 +0100
+@@ -6,10 +6,10 @@
+ all: build
+
+ build:
+- gcc -DNDEBUG -Wall -I$(LIBDVDREAD)/include -L$(LIBDVDREAD)/lib -ldvdread -Wl,-rpath,$(LIBDVDREAD)/lib -o chaplin chaplin.c -lm
++ $(CC) $(CFLAGS) $(LDFLAGS) -DNDEBUG -Wall -I$(LIBDVDREAD)/include -Wl,-rpath,$(LIBDVDREAD)/lib -o chaplin chaplin.c -L$(LIBDVDREAD)/lib -ldvdread -lm
+
+ debug:
+- gcc -Wall -I$(LIBDVDREAD)/include -L$(LIBDVDREAD)/lib -ldvdread -Wl,-rpath,$(LIBDVDREAD)/lib -o chaplin chaplin.c -lm
++ $(CC) $(CFLAGS) $(LDFLAGS) -Wall -I$(LIBDVDREAD)/include -Wl,-rpath,$(LIBDVDREAD)/lib -o chaplin chaplin.c -L$(LIBDVDREAD)/lib -ldvdread -lm
+
+ dist:
+ cd .. ; tar cvfz chaplin.tgz chaplin/Makefile chaplin/chaplin.c chaplin/chaplin-genmenu chaplin/chaplin
diff --git a/media-video/chaplin/files/chaplin-1.10-libdvdread-0.9.6.patch b/media-video/chaplin/files/chaplin-1.10-libdvdread-0.9.6.patch
new file mode 100644
index 000000000000..7e68dd67a692
--- /dev/null
+++ b/media-video/chaplin/files/chaplin-1.10-libdvdread-0.9.6.patch
@@ -0,0 +1,11 @@
+diff -N -u -r chaplin/chaplin.c chaplin-new/chaplin.c
+--- chaplin/chaplin.c 2004-03-21 18:45:44.000000000 +0100
++++ chaplin-new/chaplin.c 2006-06-29 22:36:54.457745979 +0200
+@@ -18,6 +18,7 @@
+ #include <ctype.h>
+ #include <string.h>
+ #include <math.h>
++#include <inttypes.h>
+
+ /* libdvdread stuff */
+ #include <dvdread/dvd_reader.h>
diff --git a/media-video/chaplin/metadata.xml b/media-video/chaplin/metadata.xml
new file mode 100644
index 000000000000..6cd197348689
--- /dev/null
+++ b/media-video/chaplin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="transcode">Enable DVD ripping and transcoding</flag>
+ </use>
+</pkgmetadata>