summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-11-14 16:59:10 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-17 19:42:34 +0100
commitcc8db3d0228d444a5bf9917c3038c0b2227f22b6 (patch)
treeb0b4f1cc4bcc570df09292866fdc0666d0c9bf1b /media-video/gaupol
parentnet-p2p/go-ipfs-bin: version bump to 0.4.12 (diff)
downloadgentoo-cc8db3d0228d444a5bf9917c3038c0b2227f22b6.tar.gz
gentoo-cc8db3d0228d444a5bf9917c3038c0b2227f22b6.tar.bz2
gentoo-cc8db3d0228d444a5bf9917c3038c0b2227f22b6.zip
media-video/gaupol: bump to 1.3.1, fix dependencies
Runtime dependencies are not required at install time, except if tests are enabled. dev-util/intltool is not required any more. Package-Manager: Portage-2.3.13, Repoman-2.3.4 Closes: https://github.com/gentoo/gentoo/pull/6188
Diffstat (limited to 'media-video/gaupol')
-rw-r--r--media-video/gaupol/Manifest1
-rw-r--r--media-video/gaupol/gaupol-1.3.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/media-video/gaupol/Manifest b/media-video/gaupol/Manifest
index cf1f890c791..35d841e54a3 100644
--- a/media-video/gaupol/Manifest
+++ b/media-video/gaupol/Manifest
@@ -1,3 +1,4 @@
DIST gaupol-0.91.tar.gz 518493 SHA256 cb7d2d3fa4dfd321802eb6c3dd0a2f9582a9195a70b153d0ce65f2dfa9048add SHA512 92459ec0a7d77c8e4a34f44489ae8fc01feeb2d34f6fd152c8bfeaf72b8235c680155698c55e7f9d46ce82bee8274b14313b6a43167f65f784511e583d4858fb WHIRLPOOL 7d46d9bb20d104355f16a966a46e25eb76e8cb72fa5082b9526a6ee3b012312dc1e5a6a74d6fe850cce40d9ce993b4a06471ec93ac907bb1f3de30409217ff43
DIST gaupol-1.0.tar.gz 520620 SHA256 bc407489855eb0a7a8bda6f6fcc7fcbe6136582cc588ec081750b8546f311e3b SHA512 1f6a9ff1bf6722473aa53c9c8e787ce9d25669bbafe19b4c117965bf281307365cb4cd31241af92b0623ead8a9627d38c5811d5b361c8707ac3467d520c1d89c WHIRLPOOL 50cd2546cc48538c8095ad9fbb9eb71efb6ea8cd038fa9ad217cf5a502c6cfee9530e94a8da9f69e60fbd9c511c112c9fbebc62a24edec10049e80b135c7232d
DIST gaupol-1.2.tar.gz 504222 SHA256 a6749d1ee77b36dfb0b80f41f11f63fbba3b9e638552a566f973dc9216d6f97c SHA512 03738c9ad3f22deaa5588bbd272a6ad7a837ad5fffe72afea0ad0580be8288c956993b6986a74754c3ede70a9465a569fe4c1b95f4f7b35d6356bddf914285bb WHIRLPOOL 365ceedcbda9c87c6047dec6a10d9f03c98e6825e09d9b323c1a7163958ef6504331dadb4f43c6edd3033d5259f13330874483580f048d5c322f0d19b7d7f4ce
+DIST gaupol-1.3.1.tar.gz 506676 SHA256 fb683970c3a96591c9754fac025c5d20deb35bae8f51be2212ed7f3618ee5abd SHA512 942c019f8943c888cd20c01ce3aa26d6d54a05ddfe4b5be37e35d41e9e24a5bc2cb995a768663c42933eb889f2167dc4408101d31c117c58d6f49d76abca52af WHIRLPOOL 743900f53d0ab99b04172955c01e07d734e9849099d1830e062dc52f4d57fcd7cf6532b5539a9b67c67c6540a1ba359acde64be7e8991c2d4a042e72fb35a6b8
diff --git a/media-video/gaupol/gaupol-1.3.1.ebuild b/media-video/gaupol/gaupol-1.3.1.ebuild
new file mode 100644
index 00000000000..0330c5cb2ed
--- /dev/null
+++ b/media-video/gaupol/gaupol-1.3.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 gnome2-utils virtualx xdg-utils
+
+DESCRIPTION="A subtitle editor for text-based subtitles"
+HOMEPAGE="https://otsaloma.io/gaupol/"
+SRC_URI="https://github.com/otsaloma/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="spell test"
+
+RDEPEND="app-text/iso-codes
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ spell? (
+ app-text/gtkspell:3
+ >=dev-python/pyenchant-1.4[${PYTHON_USEDEP}]
+ )"
+DEPEND="
+ sys-devel/gettext
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( AUTHORS.md NEWS.md TODO.md README.md README.aeidon.md )
+
+python_test() {
+ virtx py.test
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Previewing support needs MPV, MPlayer or VLC."
+
+ if use spell; then
+ elog "Additionally, spell-checking requires a dictionary, any of"
+ elog "Aspell/Pspell, Ispell, MySpell, Uspell, Hspell or AppleSpell."
+ fi
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}