summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2018-08-25 00:05:38 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-04 16:31:04 +0200
commitd12e263cd113157e5080fd72c727e9754c71539a (patch)
tree09ca6c8531fe689e5f897b629aa60536abc50cbd /media-video/obs-studio
parentmedia-video/obs-studio: rename USE="speexdsp" to "speex" (diff)
downloadgentoo-d12e263cd113157e5080fd72c727e9754c71539a.tar.gz
gentoo-d12e263cd113157e5080fd72c727e9754c71539a.tar.bz2
gentoo-d12e263cd113157e5080fd72c727e9754c71539a.zip
media-video/obs-studio: version bump to 22.0.3
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-2.3.48, Repoman-2.3.10 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video/obs-studio')
-rw-r--r--media-video/obs-studio/Manifest1
-rw-r--r--media-video/obs-studio/obs-studio-22.0.3.ebuild122
2 files changed, 123 insertions, 0 deletions
diff --git a/media-video/obs-studio/Manifest b/media-video/obs-studio/Manifest
index c905f7fa7b37..13ae8036f7c3 100644
--- a/media-video/obs-studio/Manifest
+++ b/media-video/obs-studio/Manifest
@@ -1,2 +1,3 @@
DIST obs-studio-21.0.2.tar.gz 5904469 BLAKE2B e4e7c1f2b445f1db6b76df0c7a12dd41ffd95e7ea5669d7efc3387cc0fd15e268d864b5da3da5c07d04bc57692a88a53a67351a370621b1a6ca648405d030454 SHA512 a22597ac3a85d4c72b9b1ff886367b158498b6b0141acfd2bdb096a2bd9d29cdfad900dfc00f870eaf0aad66836093579f37b278fa90ccd7b49022e849c1c590
DIST obs-studio-21.1.2.tar.gz 5959232 BLAKE2B 12ae6f5e76093df52f44e7f45c06fe5486c8cea875438b8c78ae429fa82ccd0a6ff9d7ab15139877eca26713ab204158b7f92fb7cbefa52a3950814d28962fe7 SHA512 5143d3a87b3a54d2a06d236fc6f6d5945ab337004c30eda0438026f4b7607776b82771636d55fcc2c8ab34e041d8ecad99dc843b6b3f4371303d1b7dc349d938
+DIST obs-studio-22.0.3.tar.gz 6015365 BLAKE2B e2c3aec7f97bbad2ec70a46d59035335d605a478ab1e4ff10a077d81c9ade5deef1ca56cf3ffc46d4d2ab89339d98a68aa5ca8c6ca240ed82939b59803af151c SHA512 491f7ce44c741d144c621eb645fe00604e1eb98ff7dac03dffe51ba78a742e6015e1f96f21aad69e16a22d9546b6cdb51b5c1a4defd96e7c64f099de83a31f04
diff --git a/media-video/obs-studio/obs-studio-22.0.3.ebuild b/media-video/obs-studio/obs-studio-22.0.3.ebuild
new file mode 100644
index 000000000000..987d58bb89bf
--- /dev/null
+++ b/media-video/obs-studio/obs-studio-22.0.3.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit cmake-utils gnome2-utils python-single-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/obsproject/obs-studio.git"
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/obsproject/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Software for Recording and Streaming Live Video Content"
+HOMEPAGE="https://obsproject.com"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa fdk imagemagick jack luajit nvenc pulseaudio python speex truetype v4l"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPEND="
+ >=dev-libs/jansson-2.5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtsql:5
+ dev-qt/qttest:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-video/ffmpeg:=[x264]
+ net-misc/curl
+ x11-libs/libXcomposite
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ alsa? ( media-libs/alsa-lib )
+ fdk? ( media-libs/fdk-aac:= )
+ imagemagick? ( media-gfx/imagemagick:= )
+ jack? ( virtual/jack )
+ luajit? ( dev-lang/luajit:2 )
+ nvenc? ( media-video/ffmpeg:=[nvenc] )
+ pulseaudio? ( media-sound/pulseaudio )
+ python? ( ${PYTHON_DEPS} )
+ speex? ( media-libs/speexdsp )
+ truetype? (
+ media-libs/fontconfig
+ media-libs/freetype
+ )
+ v4l? ( media-libs/libv4l )
+"
+DEPEND="${COMMON_DEPEND}
+ luajit? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-21.1.2-use-less-automagic.patch" )
+
+CMAKE_REMOVE_MODULES_LIST=( FindFreetype )
+
+src_configure() {
+ local libdir=$(get_libdir)
+ local mycmakeargs=(
+ -DDISABLE_ALSA=$(usex !alsa)
+ -DDISABLE_FREETYPE=$(usex !truetype)
+ -DDISABLE_JACK=$(usex !jack)
+ -DDISABLE_LIBFDK=$(usex !fdk)
+ -DDISABLE_PULSEAUDIO=$(usex !pulseaudio)
+ -DDISABLE_SPEEXDSP=$(usex !speex)
+ -DDISABLE_V4L2=$(usex !v4l)
+ -DLIBOBS_PREFER_IMAGEMAGICK=$(usex imagemagick)
+ -DOBS_MULTIARCH_SUFFIX=${libdir#lib}
+ -DOBS_VERSION_OVERRIDE=${PV}
+ -DUNIX_STRUCTURE=1
+ )
+
+ if use luajit || use python; then
+ mycmakeargs+=(
+ -DDISABLE_LUA=$(usex !luajit)
+ -DDISABLE_PYTHON=$(usex !python)
+ -DENABLE_SCRIPTING=yes
+ )
+ else
+ mycmakeargs+=( -DENABLE_SCRIPTING=no )
+ fi
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ if ! use alsa && ! use pulseaudio; then
+ elog
+ elog "For the audio capture features to be available,"
+ elog "either the 'alsa' or the 'pulseaudio' USE-flag needs to"
+ elog "be enabled."
+ elog
+ fi
+
+ if ! has_version "sys-apps/dbus"; then
+ elog
+ elog "The 'sys-apps/dbus' package is not installed, but"
+ elog "could be used for disabling hibernating, screensaving,"
+ elog "and sleeping. Where it is not installed,"
+ elog "'xdg-screensaver reset' is used instead"
+ elog "(if 'x11-misc/xdg-utils' is installed)."
+ elog
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}