summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-11-04 21:30:32 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-11-04 21:31:12 +0100
commit76c5a69340c4ed448a16724fa070a60b07aad874 (patch)
tree3dd0578eec5e714c8957508fe791a23a88b6742c /media-video/rtmpdump
parentnet-nds/yp-tools: stable 4.2.2-r1 for ia64, bug #635886 (diff)
downloadgentoo-76c5a69340c4ed448a16724fa070a60b07aad874.tar.gz
gentoo-76c5a69340c4ed448a16724fa070a60b07aad874.tar.bz2
gentoo-76c5a69340c4ed448a16724fa070a60b07aad874.zip
media-video/rtmpdump: Drop polarssl support
Closes: https://github.com/gentoo/gentoo/pull/4895 Closes: https://bugs.gentoo.org/618360 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'media-video/rtmpdump')
-rw-r--r--media-video/rtmpdump/metadata.xml1
-rw-r--r--media-video/rtmpdump/rtmpdump-2.4_p20161210-r1.ebuild11
-rw-r--r--media-video/rtmpdump/rtmpdump-2.4_p20161210.ebuild11
-rw-r--r--media-video/rtmpdump/rtmpdump-9999.ebuild11
4 files changed, 12 insertions, 22 deletions
diff --git a/media-video/rtmpdump/metadata.xml b/media-video/rtmpdump/metadata.xml
index 1abcb135fb33..724b1cb49d66 100644
--- a/media-video/rtmpdump/metadata.xml
+++ b/media-video/rtmpdump/metadata.xml
@@ -7,6 +7,5 @@
</maintainer>
<use>
<flag name="gnutls">Use GnuTLS library instead of the default OpenSSL</flag>
- <flag name="polarssl">Use PolarSSL library instead of the default OpenSSL</flag>
</use>
</pkgmetadata>
diff --git a/media-video/rtmpdump/rtmpdump-2.4_p20161210-r1.ebuild b/media-video/rtmpdump/rtmpdump-2.4_p20161210-r1.ebuild
index 13ae3a45a589..5ab69865de61 100644
--- a/media-video/rtmpdump/rtmpdump-2.4_p20161210-r1.ebuild
+++ b/media-video/rtmpdump/rtmpdump-2.4_p20161210-r1.ebuild
@@ -13,19 +13,18 @@ SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="gnutls polarssl ssl libressl"
+IUSE="gnutls ssl libressl"
DEPEND="ssl? (
gnutls? ( >=net-libs/gnutls-2.12.23-r6[${MULTILIB_USEDEP},nettle(+)] )
- polarssl? ( !gnutls? ( >=net-libs/polarssl-1.3.4[${MULTILIB_USEDEP}] ) )
- !gnutls? ( !polarssl? ( !libressl? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] ) libressl? ( dev-libs/libressl ) ) )
+ !gnutls? ( !libressl? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] ) libressl? ( dev-libs/libressl ) )
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
)"
RDEPEND="${DEPEND}"
pkg_setup() {
- if ! use ssl && { use gnutls || use polarssl; }; then
- ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
+ if ! use ssl && use gnutls ; then
+ ewarn "USE='gnutls' is ignored without USE='ssl'."
ewarn "Please review the local USE flags for this package."
fi
}
@@ -54,8 +53,6 @@ multilib_src_compile() {
if use ssl ; then
if use gnutls ; then
crypto="GNUTLS"
- elif use polarssl ; then
- crypto="POLARSSL"
else
crypto="OPENSSL"
fi
diff --git a/media-video/rtmpdump/rtmpdump-2.4_p20161210.ebuild b/media-video/rtmpdump/rtmpdump-2.4_p20161210.ebuild
index 89a24d3c7872..eec4bbc9a07c 100644
--- a/media-video/rtmpdump/rtmpdump-2.4_p20161210.ebuild
+++ b/media-video/rtmpdump/rtmpdump-2.4_p20161210.ebuild
@@ -13,19 +13,18 @@ SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 arm ~arm64 hppa ~mips ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="gnutls polarssl ssl libressl"
+IUSE="gnutls ssl libressl"
DEPEND="ssl? (
gnutls? ( >=net-libs/gnutls-2.12.23-r6[${MULTILIB_USEDEP},nettle(+)] )
- polarssl? ( !gnutls? ( >=net-libs/polarssl-1.3.4[${MULTILIB_USEDEP}] ) )
- !gnutls? ( !polarssl? ( !libressl? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] ) libressl? ( dev-libs/libressl ) ) )
+ !gnutls? ( !libressl? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] ) libressl? ( dev-libs/libressl ) )
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
)"
RDEPEND="${DEPEND}"
pkg_setup() {
- if ! use ssl && { use gnutls || use polarssl; }; then
- ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
+ if ! use ssl && use gnutls ; then
+ ewarn "USE='gnutls' is ignored without USE='ssl'."
ewarn "Please review the local USE flags for this package."
fi
}
@@ -54,8 +53,6 @@ multilib_src_compile() {
if use ssl ; then
if use gnutls ; then
crypto="GNUTLS"
- elif use polarssl ; then
- crypto="POLARSSL"
else
crypto="OPENSSL"
fi
diff --git a/media-video/rtmpdump/rtmpdump-9999.ebuild b/media-video/rtmpdump/rtmpdump-9999.ebuild
index 4d69e6e3a3c4..ccd765a7d625 100644
--- a/media-video/rtmpdump/rtmpdump-9999.ebuild
+++ b/media-video/rtmpdump/rtmpdump-9999.ebuild
@@ -13,19 +13,18 @@ EGIT_REPO_URI="https://git.ffmpeg.org/rtmpdump.git"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS=""
-IUSE="gnutls polarssl ssl libressl"
+IUSE="gnutls ssl libressl"
DEPEND="ssl? (
gnutls? ( >=net-libs/gnutls-2.12.23-r6[${MULTILIB_USEDEP},nettle(+)] )
- polarssl? ( !gnutls? ( >=net-libs/polarssl-1.3.4[${MULTILIB_USEDEP}] ) )
- !gnutls? ( !polarssl? ( !libressl? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] ) libressl? ( dev-libs/libressl ) ) )
+ !gnutls? ( !libressl? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] ) libressl? ( dev-libs/libressl ) )
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
)"
RDEPEND="${DEPEND}"
pkg_setup() {
- if ! use ssl && { use gnutls || use polarssl; }; then
- ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
+ if ! use ssl && use gnutls ; then
+ ewarn "USE='gnutls' is ignored without USE='ssl'."
ewarn "Please review the local USE flags for this package."
fi
}
@@ -48,8 +47,6 @@ multilib_src_compile() {
if use ssl ; then
if use gnutls ; then
crypto="GNUTLS"
- elif use polarssl ; then
- crypto="POLARSSL"
else
crypto="OPENSSL"
fi