summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-14 15:46:21 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-14 16:26:52 +0100
commita1781035aadf74d304bcab91c01731de87d5ac81 (patch)
tree8a34eb7842bd685c44c2b0037df1762d0b81bc20 /media-video/totem
parentkde-base/kcheckpass: Drop old (diff)
downloadgentoo-a1781035aadf74d304bcab91c01731de87d5ac81.tar.gz
gentoo-a1781035aadf74d304bcab91c01731de87d5ac81.tar.bz2
gentoo-a1781035aadf74d304bcab91c01731de87d5ac81.zip
media-video/totem: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'media-video/totem')
-rw-r--r--media-video/totem/Manifest1
-rw-r--r--media-video/totem/totem-3.18.1.ebuild132
2 files changed, 133 insertions, 0 deletions
diff --git a/media-video/totem/Manifest b/media-video/totem/Manifest
index 37e60d59aa3b..760f35199692 100644
--- a/media-video/totem/Manifest
+++ b/media-video/totem/Manifest
@@ -1,2 +1,3 @@
DIST totem-3.16.3.tar.xz 3172104 SHA256 278e6dc66d00a5ae7bedcadba987008139f0b66e534f629febbeb098d4504444 SHA512 424ce3e56ed40d8de5d69ffe8e069d804bcabdd664defeea3cfbcbd2210c5494843727eaf7671d20e6717e105790b60b361f06cccd75ab56dc1b9cbf3f3ef3e9 WHIRLPOOL 7738daba72bd0b5c4d61681af1c3698480865bcf84b7d8d6af2dac8dd0b6ca8922d0d28bbd1dbf76960f6aa54d9b57251d30d24e3e081cbf6ca382a127a81365
DIST totem-3.16.4.tar.xz 3174092 SHA256 47715a53c39089bb9963271c87e7b8390ef90d584dbf0bde2309656b9ff0fd27 SHA512 2f022323f26a3229f1e0082dbc684ca70901dbaca9fb867bb832e80ea1e9633e7026c32f1c6aa72930c58f0e42b881e2fbdf1e20d770e76e8b3f13a95eb23c44 WHIRLPOOL b3f0983155640efccb400b762fd18e6bb08f8a233446dd908fa9da865b941359970254ed10850ec7c47f76e40508e62068e4bb5915e1b6c0facddabeb2a7341e
+DIST totem-3.18.1.tar.xz 3172416 SHA256 d7816eae9606846c44fd508902eae10bdaed28e6d4f621531990d473184107a2 SHA512 cc4dcd81c2473a2c91786d0d329d1426cb23c372fbef9738be21762b00aaf02e50f54ed6d6c81b9325312db02347baf267d73d74be4052ffdb14c899e1f4f069 WHIRLPOOL 195b3d62101edaa33ca27238f200b51073810500b552c5ba3592e17ba51f8a4c451e209611b4ceb2d4827856ac20fecc6bf164547e34ab7bbbc77b702cb0b29a
diff --git a/media-video/totem/totem-3.18.1.ebuild b/media-video/totem/totem-3.18.1.ebuild
new file mode 100644
index 000000000000..af3689da8221
--- /dev/null
+++ b/media-video/totem/totem-3.18.1.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes" # plugins are dlopened
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit autotools eutils gnome2 multilib python-single-r1
+
+DESCRIPTION="Media player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Videos"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="+introspection lirc nautilus +python test zeitgeist"
+# see bug #359379
+REQUIRED_USE="
+ python? ( introspection ${PYTHON_REQUIRED_USE} )
+ zeitgeist? ( introspection )
+"
+
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+# FIXME:
+# Runtime dependency on gnome-session-2.91
+RDEPEND="
+ >=dev-libs/glib-2.35:2[dbus]
+ >=dev-libs/libpeas-1.1[gtk]
+ >=dev-libs/libxml2-2.6:2
+ >=dev-libs/totem-pl-parser-3.10.1:0=[introspection?]
+ >=media-libs/clutter-1.17.3:1.0[gtk]
+ >=media-libs/clutter-gst-2.99.2:3.0
+ >=media-libs/clutter-gtk-1.5.5:1.0
+ >=x11-libs/cairo-1.14
+ >=x11-libs/gdk-pixbuf-2.23.0:2
+ >=x11-libs/gtk+-3.16:3[introspection?]
+
+ >=media-libs/grilo-0.2.12:0.2[playlist]
+ media-plugins/grilo-plugins:0.2
+ >=media-libs/gstreamer-1.3.1:1.0
+ >=media-libs/gst-plugins-base-1.4.2:1.0[X,introspection?,pango]
+ media-libs/gst-plugins-good:1.0
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/gst-plugins-taglib:1.0
+
+ x11-libs/libX11
+
+ gnome-base/gnome-desktop:3=
+ gnome-base/gsettings-desktop-schemas
+ x11-themes/gnome-icon-theme-symbolic
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+ lirc? ( app-misc/lirc )
+ nautilus? ( >=gnome-base/nautilus-2.91.3 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-libs/libpeas-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.5.2:3[introspection] )
+ zeitgeist? ( >=gnome-extra/zeitgeist-0.9.12 )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.5
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xextproto
+ x11-proto/xproto
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+# eautoreconf needs:
+# app-text/yelp-tools
+# dev-libs/gobject-introspection-common
+# gnome-base/gnome-common
+# docbook-xml-dtd is needed for user doc
+# Prevent dev-python/pylint dep, bug #482538
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Prevent pylint usage by tests, bug #482538
+ sed -i -e 's/ check-pylint//' src/plugins/Makefile.plugins || die
+
+ eautoreconf
+ gnome2_src_prepare
+
+ # FIXME: upstream should provide a way to set GST_INSPECT, bug #358755 & co.
+ # gst-inspect causes sandbox violations when a plugin needs write access to
+ # /dev/dri/card* in its init phase.
+ sed -e "s|\(gst10_inspect=\).*|\1$(type -P true)|" \
+ -i configure || die
+}
+
+src_configure() {
+ # Disabled: sample-python, sample-vala
+ local plugins="apple-trailers,autoload-subtitles,brasero-disc-recorder"
+ plugins+=",im-status,gromit,media-player-keys,ontop"
+ plugins+=",properties,recent,rotation,screensaver,screenshot"
+ plugins+=",skipto,vimeo"
+ use lirc && plugins+=",lirc"
+ use nautilus && plugins+=",save-file"
+ use python && plugins+=",dbusservice,pythonconsole,opensubtitles"
+ use zeitgeist && plugins+=",zeitgeist-dp"
+
+ # pylint is checked unconditionally, but is only used for make check
+ # appstream-util overriding necessary until upstream fixes their macro
+ # to respect configure switch
+ gnome2_src_configure \
+ --disable-run-in-source-tree \
+ --disable-static \
+ --enable-easy-codec-installation \
+ --enable-vala \
+ $(use_enable introspection) \
+ $(use_enable nautilus) \
+ $(use_enable python) \
+ PYLINT=$(type -P true) \
+ VALAC=$(type -P true) \
+ APPSTREAM_UTIL=$(type -P true) \
+ --with-plugins=${plugins}
+}