summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetros Siligkounas <petross404@gmail.com>2019-02-17 23:16:59 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-02-19 18:46:54 +0100
commit8a9a636ab45726aac3c466af1f447c02e369d81c (patch)
treede40b98266a8ef7281c4dad2bf21fb96f75a1357 /media-video
parentnet-libs/libtirpc: add musl support for 1.0.2-r1 only (diff)
downloadgentoo-8a9a636ab45726aac3c466af1f447c02e369d81c.tar.gz
gentoo-8a9a636ab45726aac3c466af1f447c02e369d81c.tar.bz2
gentoo-8a9a636ab45726aac3c466af1f447c02e369d81c.zip
media-video/griffith: fixes cannot import name InstrumentationManager
Closes: https://bugs.gentoo.org/665068 Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Πέτρος Σιλιγκούνας <petross404@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/9763 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/griffith/files/griffith-0.13-validators.patch17
-rw-r--r--media-video/griffith/griffith-0.13-r2.ebuild3
2 files changed, 19 insertions, 1 deletions
diff --git a/media-video/griffith/files/griffith-0.13-validators.patch b/media-video/griffith/files/griffith-0.13-validators.patch
new file mode 100644
index 000000000000..f94275f3c172
--- /dev/null
+++ b/media-video/griffith/files/griffith-0.13-validators.patch
@@ -0,0 +1,17 @@
+--- a/griffith-0.13/lib/db/validators.py 2018-09-02 00:37:03.052248916 +0300
++++ b/griffith-0.13/lib/db/validators.py 2018-09-02 00:37:22.462248580 +0300
+@@ -23,7 +23,13 @@
+
+ import logging
+
+-from sqlalchemy.orm.interfaces import AttributeExtension, InstrumentationManager
++from sqlalchemy.orm.interfaces import AttributeExtension
++try:
++ # sql alchemy 0.8 (and above)
++ from sqlalchemy.ext.instrumentation import InstrumentationManager
++except:
++ # sql alchemy 0.7
++ from sqlalchemy.orm.interfaces import InstrumentationManager
+ from sqlalchemy.orm import ColumnProperty
+ from sqlalchemy.types import String
+
diff --git a/media-video/griffith/griffith-0.13-r2.ebuild b/media-video/griffith/griffith-0.13-r2.ebuild
index 66b03bc29c8b..788a9f95c7e1 100644
--- a/media-video/griffith/griffith-0.13-r2.ebuild
+++ b/media-video/griffith/griffith-0.13-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -46,6 +46,7 @@ src_prepare() {
"${S}"/lib/gconsole.py || die "sed failed"
epatch "${FILESDIR}/0.10-fix_lib_path.patch"
+ epatch "${FILESDIR}/griffith-0.13-validators.patch"
}
src_compile() {