summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-26 06:11:02 +0100
committerSam James <sam@gentoo.org>2022-07-26 06:11:02 +0100
commit96916fe72cce91a116f67db7ce00c4fdec143a1a (patch)
tree416cf08bb6a3cb118a8bb664753a34af679524a1 /media-video
parentapp-portage/mgorny-dev-scripts: add 22 (diff)
downloadgentoo-96916fe72cce91a116f67db7ce00c4fdec143a1a.tar.gz
gentoo-96916fe72cce91a116f67db7ce00c4fdec143a1a.tar.bz2
gentoo-96916fe72cce91a116f67db7ce00c4fdec143a1a.zip
media-video/ffmpeg: disable LTO for x86 builds
I can't do better than Matt's analysis in the bug, so just go read that if curious for backstory. Closes: https://bugs.gentoo.org/772854 Thanks-to: Matt Turner <mattst88@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ffmpeg-4.4.2.ebuild6
-rw-r--r--media-video/ffmpeg/ffmpeg-5.0.1.ebuild6
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild6
3 files changed, 9 insertions, 9 deletions
diff --git a/media-video/ffmpeg/ffmpeg-4.4.2.ebuild b/media-video/ffmpeg/ffmpeg-4.4.2.ebuild
index aa24bd41cead..1a4bbf4e4830 100644
--- a/media-video/ffmpeg/ffmpeg-4.4.2.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.4.2.ebuild
@@ -443,9 +443,9 @@ multilib_src_configure() {
break
done
- # LTO support, bug #566282, bug #754654
- is-flagq "-flto*" && myconf+=( "--enable-lto" )
- filter-flags "-flto*"
+ # LTO support, bug #566282, bug #754654, bug #772854
+ [[ ${ABI} != x86 ]] && is-flagq "-flto*" && myconf+=( "--enable-lto" )
+ filter-lto
# Mandatory configuration
myconf=(
diff --git a/media-video/ffmpeg/ffmpeg-5.0.1.ebuild b/media-video/ffmpeg/ffmpeg-5.0.1.ebuild
index e56d6421adff..d3e7c93b04de 100644
--- a/media-video/ffmpeg/ffmpeg-5.0.1.ebuild
+++ b/media-video/ffmpeg/ffmpeg-5.0.1.ebuild
@@ -444,9 +444,9 @@ multilib_src_configure() {
break
done
- # LTO support, bug #566282, bug #754654
- is-flagq "-flto*" && myconf+=( "--enable-lto" )
- filter-flags "-flto*"
+ # LTO support, bug #566282, bug #754654, bug #772854
+ [[ ${ABI} != x86 ]] && is-flagq "-flto*" && myconf+=( "--enable-lto" )
+ filter-lto
# Mandatory configuration
myconf=(
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 5ea93957661b..28afbd6ce4a2 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -441,9 +441,9 @@ multilib_src_configure() {
break
done
- # LTO support, bug #566282, bug #754654
- is-flagq "-flto*" && myconf+=( "--enable-lto" )
- filter-flags "-flto*"
+ # LTO support, bug #566282, bug #754654, bug #772854
+ [[ ${ABI} != x86 ]] && is-flagq "-flto*" && myconf+=( "--enable-lto" )
+ filter-lto
# Mandatory configuration
myconf=(