summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-05 16:14:05 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-05 16:14:29 -0400
commitb13ea5bb2e8462878df54b3e629e215e0741315a (patch)
tree9091c1b76dbb94dcd29fea60fae17eee55213026 /media-video
parentdev-games/cegui: version bump (diff)
downloadgentoo-b13ea5bb2e8462878df54b3e629e215e0741315a.tar.gz
gentoo-b13ea5bb2e8462878df54b3e629e215e0741315a.tar.bz2
gentoo-b13ea5bb2e8462878df54b3e629e215e0741315a.zip
media-video/subliminal: version bump to 1.1.1
Diffstat (limited to 'media-video')
-rw-r--r--media-video/subliminal/Manifest1
-rw-r--r--media-video/subliminal/subliminal-1.1.1.ebuild52
-rw-r--r--media-video/subliminal/subliminal-9999.ebuild41
3 files changed, 80 insertions, 14 deletions
diff --git a/media-video/subliminal/Manifest b/media-video/subliminal/Manifest
index 3d85d36bb377..dadd188c7fb4 100644
--- a/media-video/subliminal/Manifest
+++ b/media-video/subliminal/Manifest
@@ -1 +1,2 @@
DIST subliminal-0.7.4.tar.gz 27913 SHA256 b3ac61e8a915dc089356771637a38e4a155cf45ddd1f96a24adce8cbebc8e522 SHA512 1a7cbade7d895a6decf9abd30dc7c51f4104a91e3e01d3d600a97113dc5c8589c5957fad49e5ff537ea0cdb11d982e77c68a7566bf62455d842ab3afa64d2d47 WHIRLPOOL 72a68e58285e27580c3f19dab1c608de5aa1f3d11e90974602a589d33cd96d90da61ab35c8aa3ea32d418320d7707fb11c2aee3c8d885e4c6f4032918ef6f3e7
+DIST subliminal-1.1.1.tar.gz 37871 SHA256 ab50cff2dcdc4c302f11074d22b2aa8b1c12bbd13e81ee7ad362947a18ad3fca SHA512 00f86944daf1054ac57cf90ea34d5d898fd25f9dbf0cecaf5fba7f3a3f8e63e20edb18d62f7a48403a4478c3df5f344c642e82f7e6bcf49625a867164dc7193a WHIRLPOOL 4d1adb859f32c14bce9ef874dc1cd5fd4981cb2d9379dc2ecab9c5198eda667379aff965b21b2b2c6a69c5a320d687f3345d8f37e41e0524c0b609e175b2a792
diff --git a/media-video/subliminal/subliminal-1.1.1.ebuild b/media-video/subliminal/subliminal-1.1.1.ebuild
new file mode 100644
index 000000000000..1ca71dedbdfb
--- /dev/null
+++ b/media-video/subliminal/subliminal-1.1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Diaoul/subliminal.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to search and download subtitles"
+HOMEPAGE="http://subliminal.readthedocs.org https://github.com/Diaoul/subliminal https://pypi.python.org/pypi/subliminal"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/babelfish-0.5.2[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup-4.2.0:4[${PYTHON_USEDEP}]
+ >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/click-4.0[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/enzyme-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/guessit-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/pysrt-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ >=dev-python/vcrpy-1.6.1[${PYTHON_USEDEP}]
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+# tests need network
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}
diff --git a/media-video/subliminal/subliminal-9999.ebuild b/media-video/subliminal/subliminal-9999.ebuild
index 1d4be1b3549f..1ca71dedbdfb 100644
--- a/media-video/subliminal/subliminal-9999.ebuild
+++ b/media-video/subliminal/subliminal-9999.ebuild
@@ -1,34 +1,47 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit distutils-r1 git-r3
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Diaoul/subliminal.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit distutils-r1
DESCRIPTION="Python library to search and download subtitles"
HOMEPAGE="http://subliminal.readthedocs.org https://github.com/Diaoul/subliminal https://pypi.python.org/pypi/subliminal"
-EGIT_REPO_URI="https://github.com/Diaoul/subliminal.git"
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
-IUSE=""
+IUSE="test"
RDEPEND="
- >=dev-python/beautifulsoup-4.3.2:4[${PYTHON_USEDEP}]
- >=dev-python/guessit-0.7[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0.1[${PYTHON_USEDEP}]
- >=dev-python/enzyme-0.4[${PYTHON_USEDEP}]
- >=dev-python/html5lib-0.99[${PYTHON_USEDEP}]
- >=dev-python/dogpile-cache-0.5.2[${PYTHON_USEDEP}]
- >=dev-python/babelfish-0.5.1[${PYTHON_USEDEP}]
- >=dev-python/chardet-2.2.1[${PYTHON_USEDEP}]
+ >=dev-python/babelfish-0.5.2[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup-4.2.0:4[${PYTHON_USEDEP}]
+ >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/click-4.0[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/enzyme-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/guessit-0.9.1[${PYTHON_USEDEP}]
>=dev-python/pysrt-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/pyxdg-0.25[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.0.0[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ >=dev-python/vcrpy-1.6.1[${PYTHON_USEDEP}]
+ )
dev-python/setuptools[${PYTHON_USEDEP}]
"
# tests need network