summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-22 11:50:25 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-22 12:02:35 +0200
commitda89689ee603baaf7ef1777bd95f59c5403e45d7 (patch)
tree476ee0be2af6193ff88ead0609f7c8bacec0f87f /media-video
parentmedia-video/vidify: import from ::guru (diff)
downloadgentoo-da89689ee603baaf7ef1777bd95f59c5403e45d7.tar.gz
gentoo-da89689ee603baaf7ef1777bd95f59c5403e45d7.tar.bz2
gentoo-da89689ee603baaf7ef1777bd95f59c5403e45d7.zip
media-video/vidify-audiosync: import from ::guru
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vidify-audiosync/Manifest1
-rw-r--r--media-video/vidify-audiosync/metadata.xml17
-rw-r--r--media-video/vidify-audiosync/vidify-audiosync-0.3.0.ebuild46
3 files changed, 64 insertions, 0 deletions
diff --git a/media-video/vidify-audiosync/Manifest b/media-video/vidify-audiosync/Manifest
new file mode 100644
index 000000000000..dfb56ef68319
--- /dev/null
+++ b/media-video/vidify-audiosync/Manifest
@@ -0,0 +1 @@
+DIST vidify-audiosync-0.3.0.tar.gz 61854604 BLAKE2B d6ffb65152044932d1e0a57d573c14d9378815c714d680d7a446e54ba6f4e572346165eb3c0f9b7793eb03fc5d0e1f2a07a8d0a64c76971892ad5c5d0ea4fc50 SHA512 b245dea22353acae94de1f0c0465d5d1040d19f372702eba52790bf6ace861ede497562957178aa40e7a9c30ba47061b9e23761900cc18a6c7b1e3579db6ccd0
diff --git a/media-video/vidify-audiosync/metadata.xml b/media-video/vidify-audiosync/metadata.xml
new file mode 100644
index 000000000000..af6bbe61a887
--- /dev/null
+++ b/media-video/vidify-audiosync/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>marioortizmanero@gmail.com</email>
+ <name>Mario Ortiz Manero</name>
+ </maintainer>
+ <remote-id type="github">vidify/old-audiosync</remote-id>
+ <bugs-to>https://github.com/vidify/old-audiosync/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/vidify-audiosync/vidify-audiosync-0.3.0.ebuild b/media-video/vidify-audiosync/vidify-audiosync-0.3.0.ebuild
new file mode 100644
index 000000000000..e0e3a255570a
--- /dev/null
+++ b/media-video/vidify-audiosync/vidify-audiosync-0.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Audio synchronization feature for vidify"
+HOMEPAGE="https://vidify.org"
+SRC_URI="https://github.com/vidify/old-audiosync/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="debug test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ media-sound/pulseaudio
+ media-video/ffmpeg[openssl]
+ media-video/vidify[${PYTHON_USEDEP}]
+ sci-libs/fftw
+ debug? ( sci-visualization/gnuplot )
+"
+BDEPEND="test? ( dev-util/cmake )"
+
+S="${WORKDIR}/old-audiosync-${PV}"
+
+python_prepare_all() {
+ if use debug; then
+ sed -i -e "/defines.append(('DEBUG', '1'))/s/^# *//" setup.py || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ mkdir "test_build_${EPYTHON}" || die
+ cd "test_build_${EPYTHON}" || die
+ cmake .. -DBUILD_TESTING=YES || die
+ emake
+ emake test
+ cd .. || die
+}