summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Pihl <ahvenas@gmail.com>2020-07-02 21:15:44 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-07-13 15:10:18 +0300
commite7aae28b508aaa30e3871628241519e8f5e08f9c (patch)
tree44803c84998f07f4ebebf0688cc13caa21f50599 /media-video
parentsci-libs/fplll: upstream bump (diff)
downloadgentoo-e7aae28b508aaa30e3871628241519e8f5e08f9c.tar.gz
gentoo-e7aae28b508aaa30e3871628241519e8f5e08f9c.tar.bz2
gentoo-e7aae28b508aaa30e3871628241519e8f5e08f9c.zip
media-video/shotcut: Version bump to 20.06.28.
Fix the desktop link contents via patch. Bug: https://bugs.gentoo.org/717558 Signed-off-by: Henrik Pihl <ahvenas@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16550 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/shotcut/Manifest1
-rw-r--r--media-video/shotcut/files/shotcut-20.06.28-desktop-file-validate.patch16
-rw-r--r--media-video/shotcut/shotcut-20.06.28.ebuild69
3 files changed, 86 insertions, 0 deletions
diff --git a/media-video/shotcut/Manifest b/media-video/shotcut/Manifest
index 8231a7f13403..8061d50c6014 100644
--- a/media-video/shotcut/Manifest
+++ b/media-video/shotcut/Manifest
@@ -1 +1,2 @@
DIST shotcut-19.12.31.tar.gz 5475620 BLAKE2B 47fd90ddf40da3c08d3dab31b7170b02aab2f3e6b9d3d7446d53192c04b22b7e053cffe21632f1370d699ff00dca0d057f9a49d29ddeb225f039104abbc8ddee SHA512 714d5b3e184e9d0786bc64635e51fd61570e0404c0ebf0fa5c8a12cb85c9091c75ac61e4963bd400b5722f310ae590b2c2d83aa4cd7acbcb53545f224f0ca766
+DIST shotcut-20.06.28.tar.gz 5797885 BLAKE2B 3f241d6bbe4a89410a2e96ec8bde9446ee88c452ee76f77e4d145f44a37c0d5d116f43e4d0e844b5a112998317f3378c84819bd63c9a02a5aff30338859340b6 SHA512 cd9b96ca467c669138902a94975a5f23baa266b1eb92de0b0446e6f6616a9927aac430c6bd41c4f00de4e5b6d99bfbdf074d339f98ef219a38e3572d8670d78b
diff --git a/media-video/shotcut/files/shotcut-20.06.28-desktop-file-validate.patch b/media-video/shotcut/files/shotcut-20.06.28-desktop-file-validate.patch
new file mode 100644
index 000000000000..87dabd5cba3e
--- /dev/null
+++ b/media-video/shotcut/files/shotcut-20.06.28-desktop-file-validate.patch
@@ -0,0 +1,16 @@
+diff --git a/packaging/linux/org.shotcut.Shotcut.desktop b/packaging/linux/org.shotcut.Shotcut.desktop
+index a9cf44d..c5a4eff 100644
+--- a/packaging/linux/org.shotcut.Shotcut.desktop
++++ b/packaging/linux/org.shotcut.Shotcut.desktop
+@@ -5,10 +5,8 @@ GenericName=Video Editor
+ GenericName[de]=Video-Bearbeitungsprogramm
+ GenericName[fr]=Logiciel de montage vidéo
+ GenericName[ru]=Видеоредактор
+-Comment=Video Editor
++Comment=Shotcut is a free, open source, cross-platform video editor.
+ Comment[de]=Programm zum Bearbeiten und Abspielen von Videodateien.
+-Comment[fr]=Logiciel de montage vidéo
+-Comment[ru]=Видеоредактор
+ Exec=shotcut %F
+ Icon=org.shotcut.Shotcut
+ Terminal=false
diff --git a/media-video/shotcut/shotcut-20.06.28.ebuild b/media-video/shotcut/shotcut-20.06.28.ebuild
new file mode 100644
index 000000000000..40181162303e
--- /dev/null
+++ b/media-video/shotcut/shotcut-20.06.28.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic qmake-utils xdg
+
+DESCRIPTION="A free, open source, cross-platform video editor"
+HOMEPAGE="https://www.shotcut.org/ https://github.com/mltframework/shotcut/"
+SRC_URI="https://github.com/mltframework/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+COMMON_DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5[widgets]
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsql:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ >=media-libs/mlt-6.18.0[ffmpeg,frei0r,jack,qt5,sdl,xml]
+ media-libs/webvfx
+ media-video/ffmpeg
+"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/qtconcurrent:5
+ dev-qt/qtx11extras:5
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtquickcontrols:5
+ virtual/jack
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-desktop-file-validate.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i -e '/QT.*private/d' \
+ src/src.pro || die
+}
+
+src_configure() {
+ append-cxxflags -Wno-deprecated-declarations
+
+ eqmake5 \
+ PREFIX="${EPREFIX}/usr" \
+ SHOTCUT_VERSION="${PV}"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}