summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-22 11:35:24 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-22 12:02:34 +0200
commite9f5d7ffc0559b0051a8d0dbd7895a5daa8fc982 (patch)
tree76fa3303e4843da12259ac1100fdc80624b7cec0 /media-video
parentnet-misc/lyricwikia: import from ::guru (diff)
downloadgentoo-e9f5d7ffc0559b0051a8d0dbd7895a5daa8fc982.tar.gz
gentoo-e9f5d7ffc0559b0051a8d0dbd7895a5daa8fc982.tar.bz2
gentoo-e9f5d7ffc0559b0051a8d0dbd7895a5daa8fc982.zip
media-video/vidify: import from ::guru
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vidify/Manifest1
-rw-r--r--media-video/vidify/metadata.xml23
-rw-r--r--media-video/vidify/vidify-2.2.6.ebuild80
3 files changed, 104 insertions, 0 deletions
diff --git a/media-video/vidify/Manifest b/media-video/vidify/Manifest
new file mode 100644
index 000000000000..c352a45f3bff
--- /dev/null
+++ b/media-video/vidify/Manifest
@@ -0,0 +1 @@
+DIST vidify-2.2.6.tar.gz 2906511 BLAKE2B 3df48ca57e102f664852e2fc2abeb3d19427673e1fec5144a8c0afda112a0f3b281b18db43b4326244266d6e9dfbcb2443319ddad3f864098a61bd1e3c966307 SHA512 15487ee9dcbe647b2b287bd2eb3c09962b557320313a9a3885fb3c0d6af945909531111d5297c1a5fb5b451af5df6fd968b3953bbf79af113980ed368a5674b5
diff --git a/media-video/vidify/metadata.xml b/media-video/vidify/metadata.xml
new file mode 100644
index 000000000000..a000e80a0c1f
--- /dev/null
+++ b/media-video/vidify/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <use>
+ <flag name="vlc">Use python-vlc as backend for vidify</flag>
+ <flag name="mpv">Use python-mpv as backend for vidify</flag>
+ <flag name="zeroconf">Use an external network player</flag>
+ <flag name="dbus">Support local MPRIS players</flag>
+ </use>
+ <upstream>
+ <maintainer>
+ <email>marioortizmanero@gmail.com</email>
+ <name>Mario Ortiz Manero</name>
+ </maintainer>
+ <remote-id type="github">vidify/vidify</remote-id>
+ <bugs-to>https://github.com/vidify/vidify/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/vidify/vidify-2.2.6.ebuild b/media-video/vidify/vidify-2.2.6.ebuild
new file mode 100644
index 000000000000..d80a08f97932
--- /dev/null
+++ b/media-video/vidify/vidify-2.2.6.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit xdg distutils-r1 optfeature virtualx
+
+DESCRIPTION="Watch music videos in real time for the songs playing on your device"
+HOMEPAGE="https://vidify.org"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="dbus vlc mpv zeroconf"
+
+REQUIRED_USE="|| ( vlc mpv zeroconf )"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/QtPy[gui,webengine,${PYTHON_USEDEP}]
+ net-misc/lyricwikia[${PYTHON_USEDEP}]
+ net-misc/youtube-dl[${PYTHON_USEDEP}]
+ dbus? ( dev-python/pydbus[${PYTHON_USEDEP}] )
+ !dbus? ( dev-python/tekore[${PYTHON_USEDEP}] )
+ mpv? ( dev-python/python-mpv[${PYTHON_USEDEP}] )
+ vlc? ( dev-python/python-vlc[${PYTHON_USEDEP}] )
+ zeroconf? ( dev-python/zeroconf[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # skip online test
+ rm tests/api/test_spotify_web.py || die
+ rm tests/player/test_external.py || die
+
+ # this needs dbus and a player running
+ rm tests/api/test_mpris.py || die
+
+ # can't parse non-existent config
+ rm tests/test_api_and_player_data.py || die
+
+ # do not hard depend on this
+ sed -i \
+ -e '/qdarkstyle/d' \
+ -e '/python-vlc/d' \
+ -e '/python-mpv/d' \
+ -e '/pydbus/d' \
+ -e '/tekore/d' \
+ -e '/zeroconf/d' \
+ -e '/If PySide2 is installed and PyQt5/,/PyQtWebEngine/d' \
+ setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ virtx "${EPYTHON}" -m unittest discover -v
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "If video playback is not working please check 'vidify --debug' for missing-codec-errors"
+ elof "and recompile media-video/vlc or media-video/mpv with the missing codecs"
+
+ optfeature "using an MPRIS(D-Bus) audio player (e.g spotify)" dev-python/pydbus
+ optfeature "using the Spotify Web API as audio player" dev-python/tekore
+ optfeature "using an external network player" dev-python/zeroconf
+ optfeature "using media-video/mpv for video playback" dev-python/python-mpv
+ optfeature "using media-video/vlc for video playback" dev-python/python-vlc
+ optfeature "'vidify --dark-mode'" dev-python/qdarkstyle
+ optfeature "'vidify --audiosync'" media-video/vidify-audiosync
+}