summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/echoping
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/echoping')
-rw-r--r--net-analyzer/echoping/Manifest2
-rw-r--r--net-analyzer/echoping/echoping-6.0.2-r2.ebuild60
-rw-r--r--net-analyzer/echoping/echoping-6.0.2_p434-r1.ebuild56
-rw-r--r--net-analyzer/echoping/echoping-6.0.2_p434.ebuild50
-rw-r--r--net-analyzer/echoping/files/echoping-6.0.2-fix_implicit_declarations.patch20
-rw-r--r--net-analyzer/echoping/files/echoping-6.0.2-gnutls.patch41
-rw-r--r--net-analyzer/echoping/files/echoping-6.0.2_p434-fix_implicit_declarations.patch20
-rw-r--r--net-analyzer/echoping/metadata.xml15
8 files changed, 264 insertions, 0 deletions
diff --git a/net-analyzer/echoping/Manifest b/net-analyzer/echoping/Manifest
new file mode 100644
index 000000000000..a5a95da72e36
--- /dev/null
+++ b/net-analyzer/echoping/Manifest
@@ -0,0 +1,2 @@
+DIST echoping-6.0.2.tar.gz 1660983 SHA256 1dfa4c45bf461b2379ff91773ed7136176e2abac9e85c26bc9654942b5155eac SHA512 ca9a38c3be9da283e73a7a1b13ab003dca6a2ee317e2961325f3e6803f132ae2f5e4206d946564915c573f21f9c3e9641d61f6b3ae5806bbaa92c2f30f1e5e22 WHIRLPOOL 9140d20d82ed1c38df91d8905fb678c1ca717af518b374c3379db285662d55e70c8da5bb227c4f47a4c34f649c686037636c024a38d1109cd939f6974b274e15
+DIST echoping-6.0.2_p434.tar.gz 74568 SHA256 152a4a9d2a3962fa8cb95eeb29b5d22a7039d4408f5ba22286259856f095baf7 SHA512 1b4f5f1ea6ba000c558cab3b8e86758d6c539d8cd237620000d837b468861a177ac733441c885eb8ec1c35b49baa33a82e34e3f8b14b05429a075b72233d5799 WHIRLPOOL cae10459766311ded4f6459e519461fb91de7dd9429679927c3955a5a9b09b9b9a9706947b3a5c1495805367c91cf2035d3154a3ff180241782deec304eb8aaf
diff --git a/net-analyzer/echoping/echoping-6.0.2-r2.ebuild b/net-analyzer/echoping/echoping-6.0.2-r2.ebuild
new file mode 100644
index 000000000000..58c102110611
--- /dev/null
+++ b/net-analyzer/echoping/echoping-6.0.2-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="Small program to test performances of remote servers"
+HOMEPAGE="http://echoping.sourceforge.net/"
+SRC_URI="mirror://sourceforge/echoping/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 ~hppa x86"
+IUSE="gnutls http icp idn priority smtp ssl tos postgres ldap"
+RESTRICT="test"
+
+RDEPEND="idn? ( net-dns/libidn )
+ postgres? ( dev-db/postgresql )
+ ldap? ( net-nds/openldap )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? ( >=dev-libs/openssl-0.9.7d )
+ )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2"
+
+REQUIRED_USE="gnutls? ( ssl )"
+
+DOCS=( README AUTHORS ChangeLog DETAILS NEWS TODO )
+
+src_prepare() {
+ # bug 279525:
+ epatch "${FILESDIR}/${P}-gnutls.patch"
+
+ epatch "${FILESDIR}/${P}-fix_implicit_declarations.patch"
+
+ rm -f ltmain.sh
+ cp /usr/share/libtool/config/ltmain.sh .
+ local i
+ for i in . plugins/ plugins/*/; do
+ pushd "${i}" > /dev/null
+ eautoreconf
+ popd > /dev/null
+ done
+}
+
+src_configure() {
+ econf \
+ --config-cache \
+ --disable-ttcp \
+ $(use_enable http) \
+ $(use_enable icp) \
+ $(use_with idn libidn) \
+ $(use_enable smtp) \
+ $(use_enable tos) \
+ $(use_enable priority) \
+ $(usex gnutls $(use_with gnutls) $(use_with ssl))
+}
diff --git a/net-analyzer/echoping/echoping-6.0.2_p434-r1.ebuild b/net-analyzer/echoping/echoping-6.0.2_p434-r1.ebuild
new file mode 100644
index 000000000000..b6b1acb9d030
--- /dev/null
+++ b/net-analyzer/echoping/echoping-6.0.2_p434-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Small program to test performances of remote servers"
+HOMEPAGE="http://echoping.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~jer/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="gnutls http icp idn priority smtp ssl tos postgres ldap"
+RESTRICT="test"
+
+RDEPEND="idn? ( net-dns/libidn )
+ postgres? ( dev-db/postgresql )
+ ldap? ( net-nds/openldap )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? ( >=dev-libs/openssl-0.9.7d )
+ )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2"
+
+REQUIRED_USE="gnutls? ( ssl )"
+
+DOCS=( README AUTHORS ChangeLog DETAILS NEWS TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-6.0.2_p434-fix_implicit_declarations.patch
+
+ cp /usr/share/libtool/config/ltmain.sh .
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable http) \
+ $(use_enable icp) \
+ $(use_enable priority) \
+ $(use_enable smtp) \
+ $(use_enable tos) \
+ $(use_with idn libidn) \
+ $(usex gnutls $(use_with gnutls) $(use_with ssl)) \
+ --config-cache \
+ --disable-static \
+ --disable-ttcp
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/net-analyzer/echoping/echoping-6.0.2_p434.ebuild b/net-analyzer/echoping/echoping-6.0.2_p434.ebuild
new file mode 100644
index 000000000000..e34d83b94281
--- /dev/null
+++ b/net-analyzer/echoping/echoping-6.0.2_p434.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Small program to test performances of remote servers"
+HOMEPAGE="http://echoping.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~jer/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 ~hppa x86"
+IUSE="gnutls http icp idn priority smtp ssl tos postgres ldap"
+RESTRICT="test"
+
+RDEPEND="idn? ( net-dns/libidn )
+ postgres? ( dev-db/postgresql )
+ ldap? ( net-nds/openldap )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? ( >=dev-libs/openssl-0.9.7d )
+ )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2"
+
+REQUIRED_USE="gnutls? ( ssl )"
+
+DOCS=( README AUTHORS ChangeLog DETAILS NEWS TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-6.0.2_p434-fix_implicit_declarations.patch
+
+ cp /usr/share/libtool/config/ltmain.sh .
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --config-cache \
+ --disable-ttcp \
+ $(use_enable http) \
+ $(use_enable icp) \
+ $(use_with idn libidn) \
+ $(use_enable smtp) \
+ $(use_enable tos) \
+ $(use_enable priority) \
+ $(usex gnutls $(use_with gnutls) $(use_with ssl))
+}
diff --git a/net-analyzer/echoping/files/echoping-6.0.2-fix_implicit_declarations.patch b/net-analyzer/echoping/files/echoping-6.0.2-fix_implicit_declarations.patch
new file mode 100644
index 000000000000..1b0bce850421
--- /dev/null
+++ b/net-analyzer/echoping/files/echoping-6.0.2-fix_implicit_declarations.patch
@@ -0,0 +1,20 @@
+--- echoping.h
++++ echoping.h 2009-09-15 00:55:43.000000000 +0200
+@@ -198,6 +198,7 @@
+ #endif
+ /* util.c */
+ char *random_string ();
++char *to_upper();
+ void tvsub ();
+ void tvadd ();
+ void tvavg ();
+--- plugins/ldap/ldap.c
++++ plugins/ldap/ldap.c
+@@ -9,6 +9,7 @@
+ #include "../../config.h"
+ #include "config.h"
+ #endif
++#define LDAP_DEPRECATED 1
+ #include <ldap.h>
+
+ const char *request = NULL;
diff --git a/net-analyzer/echoping/files/echoping-6.0.2-gnutls.patch b/net-analyzer/echoping/files/echoping-6.0.2-gnutls.patch
new file mode 100644
index 000000000000..b5be2d989776
--- /dev/null
+++ b/net-analyzer/echoping/files/echoping-6.0.2-gnutls.patch
@@ -0,0 +1,41 @@
+Date: 2009-06-30 14:26
+Sender: bortz
+
+The patch by ametzler seems indeed to work (thanks to him). I've committed
+it (r426) and will make a new release soon.
+
+http://sourceforge.net/tracker/index.php?func=detail&aid=2811861&group_id=4581&atid=104581
+
+
+--- trunk/SRC/configure.ac 2009/06/30 14:18:15 425
++++ trunk/SRC/configure.ac 2009/06/30 14:19:07 426
+@@ -92,14 +92,21 @@
+ AC_ARG_WITH(gnutls,
+ [ --with-gnutls[=DIR] SSL/TLS crypt support (needs GNU TLS), the argument DIR should not be necessary],dnl
+ [if test "$withval" != "no"; then
+- AC_DEFINE(GNUTLS,,[Crypto (TLS) support])
+- GNUTLS=1
+- CPPFLAGS="${CPPFLAGS} `libgnutls-config --cflags`"
+- LDFLAGS="${LDFLAGS} `libgnutls-config --libs`"
+- if test "$withval" != "yes"; then
+- GNUTLSROOT=$withval
+- LDFLAGS="${LDFLAGS} -L$GNUTLSROOT/lib"
+- CPPFLAGS="${CPPFLAGS} -I$GNUTLSROOT/include"
++ if test "$withval" = "yes"; then
++ PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 1.0.0],
++ [
++ echo "GnuTLS found"
++ AC_DEFINE(GNUTLS,,[Crypto (TLS) support])
++ GNUTLS=1
++ CFLAGS="$CFLAGS $LIBGNUTLS_CFLAGS"
++ LIBS="$LIBS $LIBGNUTLS_LIBS"
++ ],)
++ else
++ AC_DEFINE(GNUTLS,,[Crypto (TLS) support])
++ GNUTLS=1
++ GNUTLSROOT=$withval
++ LDFLAGS="${LDFLAGS} -L$GNUTLSROOT/lib -lgnutls"
++ CPPFLAGS="${CPPFLAGS} -I$GNUTLSROOT/include"
+ fi
+ fi],
+ dnl Default: disable it
diff --git a/net-analyzer/echoping/files/echoping-6.0.2_p434-fix_implicit_declarations.patch b/net-analyzer/echoping/files/echoping-6.0.2_p434-fix_implicit_declarations.patch
new file mode 100644
index 000000000000..c2fd2f6886cb
--- /dev/null
+++ b/net-analyzer/echoping/files/echoping-6.0.2_p434-fix_implicit_declarations.patch
@@ -0,0 +1,20 @@
+--- a/echoping.h
++++ b/echoping.h
+@@ -194,6 +194,7 @@
+ #endif
+ /* util.c */
+ char *random_string();
++char *to_upper();
+ void tvsub();
+ void tvadd();
+ void tvavg();
+--- a/plugins/ldap/ldap.c
++++ b/plugins/ldap/ldap.c
+@@ -9,6 +9,7 @@
+ #include "../../config.h"
+ #include "config.h"
+ #endif
++#define LDAP_DEPRECATED 1
+ #include <ldap.h>
+
+ const char *request = NULL;
diff --git a/net-analyzer/echoping/metadata.xml b/net-analyzer/echoping/metadata.xml
new file mode 100644
index 000000000000..59f505d0a953
--- /dev/null
+++ b/net-analyzer/echoping/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <use>
+ <flag name="http">enable support for http protocol.</flag>
+ <flag name="icp">enable support for ICP (used to monitor proxies).</flag>
+ <flag name="priority">enable socket priority support.</flag>
+ <flag name="smtp">enable support for SMTP protocol.</flag>
+ <flag name="tos">enable support for TOS (TYpe Of Service).</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">echoping</remote-id>
+ </upstream>
+</pkgmetadata>