summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-09-18 15:38:08 +0200
committerJeroen Roovers <jer@gentoo.org>2018-09-18 15:38:08 +0200
commit216d72e341996af2e80979550b403bdc46ab02e8 (patch)
treeded413930da8cb7132a8f4f827a4832b900ac6b6 /net-analyzer/fping/fping-4.1.ebuild
parentdev-util/debhelper: Version 11.4. (diff)
downloadgentoo-216d72e341996af2e80979550b403bdc46ab02e8.tar.gz
gentoo-216d72e341996af2e80979550b403bdc46ab02e8.tar.bz2
gentoo-216d72e341996af2e80979550b403bdc46ab02e8.zip
net-analyzer/fping: Version 4.1.
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'net-analyzer/fping/fping-4.1.ebuild')
-rw-r--r--net-analyzer/fping/fping-4.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/fping/fping-4.1.ebuild b/net-analyzer/fping/fping-4.1.ebuild
new file mode 100644
index 000000000000..13dec2b8e680
--- /dev/null
+++ b/net-analyzer/fping/fping-4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A utility to ping multiple hosts at once"
+HOMEPAGE="http://fping.org/"
+SRC_URI="http://fping.org/dist/${P}.tar.gz"
+
+LICENSE="fping"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="ipv6 suid"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.1-ipv6.patch
+)
+
+src_configure() {
+ econf $(use_enable ipv6)
+}
+
+src_install() {
+ default
+
+ if use suid ; then
+ fperms u+s /usr/sbin/fping
+ fi
+}