summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-01-15 12:04:28 +0100
committerJeroen Roovers <jer@gentoo.org>2017-01-15 12:04:28 +0100
commit8fab9ae188879d604935d56ea95594a96df535b5 (patch)
tree7824666d8c173478b3227641d0afa22e6dd00c6c /net-analyzer/mtr
parentnet-analyzer/mtr: Rename patches to match version. (diff)
downloadgentoo-8fab9ae188879d604935d56ea95594a96df535b5.tar.gz
gentoo-8fab9ae188879d604935d56ea95594a96df535b5.tar.bz2
gentoo-8fab9ae188879d604935d56ea95594a96df535b5.zip
net-analyzer/mtr: Fix tinfo patch, add USE=ncurses.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-analyzer/mtr')
-rw-r--r--net-analyzer/mtr/files/mtr-9999-tinfo.patch16
-rw-r--r--net-analyzer/mtr/mtr-9999.ebuild17
2 files changed, 24 insertions, 9 deletions
diff --git a/net-analyzer/mtr/files/mtr-9999-tinfo.patch b/net-analyzer/mtr/files/mtr-9999-tinfo.patch
new file mode 100644
index 000000000000..92e261cd7363
--- /dev/null
+++ b/net-analyzer/mtr/files/mtr-9999-tinfo.patch
@@ -0,0 +1,16 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -101,8 +101,11 @@
+ # (On Solaris 11.3, ncurses builds and links for us, but curses does not.)
+ [AC_SEARCH_LIBS(
+ [initscr], [ncurses curses],
+- [AC_DEFINE([HAVE_CURSES], [1], [Define if a curses library available])],
+- [with_ncurses=no])
++ AC_SEARCH_LIBS(
++ [raw], [ncurses curses cursesX tinfo],
++ [AC_DEFINE([HAVE_CURSES], [1], [Define if a curses library available])],
++ [with_ncurses=no]),
++ [with_ncurses=no])
+ ])
+ AM_CONDITIONAL([WITH_CURSES], [test "x$with_ncurses" = xyes])
+
diff --git a/net-analyzer/mtr/mtr-9999.ebuild b/net-analyzer/mtr/mtr-9999.ebuild
index 0bc99abad64a..797b07c37320 100644
--- a/net-analyzer/mtr/mtr-9999.ebuild
+++ b/net-analyzer/mtr/mtr-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,14 +13,14 @@ SRC_URI="mirror://gentoo/gtk-2.0-for-mtr.m4.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="gtk ipv6"
+IUSE="gtk ipv6 ncurses"
RDEPEND="
- sys-libs/ncurses:0=
gtk? (
dev-libs/glib:2
x11-libs/gtk+:2
)
+ ncurses? ( sys-libs/ncurses:0= )
"
DEPEND="
${RDEPEND}
@@ -31,7 +31,7 @@ DEPEND="
DOCS=( AUTHORS FORMATS NEWS README SECURITY TODO )
FILECAPS=( cap_net_raw /usr/sbin/mtr )
PATCHES=(
- "${FILESDIR}"/${PN}-0.80-impl-dec.patch
+ "${FILESDIR}"/${PN}-9999-tinfo.patch
)
src_unpack() {
@@ -40,22 +40,21 @@ src_unpack() {
}
src_prepare() {
- default
-
# Keep this comment and following mv, even in case ebuild does not need
# it: kept gtk-2.0.m4 in SRC_URI but you'll have to mv it before autoreconf
mv "${WORKDIR}"/gtk-2.0-for-mtr.m4 gtk-2.0.m4 || die #222909
- eapply_user
+ default
AT_M4DIR="." eautoreconf
}
src_configure() {
# In the source's configure script -lresolv is commented out. Apparently it
- # is needed for 64bit macos still.
+ # is still needed for 64-bit MacOS.
[[ ${CHOST} == *-darwin* ]] && append-libs -lresolv
econf \
$(use_enable ipv6) \
- $(use_with gtk)
+ $(use_with gtk) \
+ $(use_with ncurses)
}