summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/netcat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/netcat')
-rw-r--r--net-analyzer/netcat/Manifest3
-rw-r--r--net-analyzer/netcat/metadata.xml12
-rw-r--r--net-analyzer/netcat/netcat-110-r9.ebuild53
3 files changed, 68 insertions, 0 deletions
diff --git a/net-analyzer/netcat/Manifest b/net-analyzer/netcat/Manifest
new file mode 100644
index 000000000000..697b211801d0
--- /dev/null
+++ b/net-analyzer/netcat/Manifest
@@ -0,0 +1,3 @@
+DIST nc-v6-20000918.patch.gz 8740 SHA256 7f0d5d05f4ed98f61f7efb167ef29cb25aa71e0df42c1f0cc8472e1ed660cb9a SHA512 56326fc7c40ea676173f150842367ea1782e700de682d790bb0f2c0df86e72a30f4c3ea0d937deb9d92f5eed47d2d4cb53edaca7dd23eb394a498b2f424bb2fe WHIRLPOOL 15fcbb4797900eab97e49b29a2a7a3e29ae449079a52c8bccf2b515c35fe22247105bbdb935c216925d184523e91b9d4d0c49d25c88a911b22bebdfba51135c7
+DIST nc110.tgz 75267 SHA256 5b3fda14e972d908896a605293f4634a72e2968278117410e12d8b3faf9a3976 SHA512 c9a7f5045f76d9ffef4e83fcc3e82f69ac4eb05e061686db51e9367949bfe0b90226b290a059dc68dcf3bf2040b95b5c78545199674da57a7c73e2f9145cf812 WHIRLPOOL 55c941d5996f3069fb5e76c6abedc9cd361dd44d404ddadf63422d3c5611c3b7e9459c58186a5b69aead7306f0842904005c08d0fb815bfbb452fc0f2c9b2b65
+DIST netcat-110-patches-1.0.tar.bz2 25751 SHA256 809517592616b4ca81c7b49541faa6a252ceb93384886d99b83163e9feeca96c SHA512 b9e7e35aa7e26d30f0115d87aff34fd0cadfad99fdb77cc5aa3ba51bec331f632e180484927c4368172ee9cc6c996b8691bd19bad8806912d8820158a98eab46 WHIRLPOOL 3e86f5bb92a905a1347c8af38db76e9c68d72757488dc153e4d1715cf825c4f1ecb74c67138238de4b31fbfe240511b81e495af3d7059fdf9c93c8ae731f476c
diff --git a/net-analyzer/netcat/metadata.xml b/net-analyzer/netcat/metadata.xml
new file mode 100644
index 000000000000..82bb1b15a784
--- /dev/null
+++ b/net-analyzer/netcat/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <maintainer>
+ <email>vapier@gentoo.org</email>
+ </maintainer>
+ <longdescription>the network swiss army knife</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">nc110</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/netcat/netcat-110-r9.ebuild b/net-analyzer/netcat/netcat-110-r9.ebuild
new file mode 100644
index 000000000000..3e52f24b61d5
--- /dev/null
+++ b/net-analyzer/netcat/netcat-110-r9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs flag-o-matic
+
+PATCH_VER="1.0"
+MY_P=nc${PV}
+DESCRIPTION="the network swiss army knife"
+HOMEPAGE="http://nc110.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nc110/${MY_P}.tgz
+ ftp://sith.mimuw.edu.pl/pub/users/baggins/IPv6/nc-v6-20000918.patch.gz
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
+
+LICENSE="netcat"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris ~x64-solaris"
+IUSE="crypt ipv6 static"
+
+LIB_DEPEND="crypt? ( dev-libs/libmix[static-libs(+)] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${DISTDIR}"/nc-v6-20000918.patch.gz patch
+ sed -i 's:#define HAVE_BIND:#undef HAVE_BIND:' netcat.c
+ sed -i 's:#define FD_SETSIZE 16:#define FD_SETSIZE 1024:' netcat.c #34250
+ [[ ${CHOST} == *-solaris* ]] && \
+ sed -i 's:gethostbyname2(\([^)]\+\)):getipnodebyname(\1, AI_DEFAULT, NULL):' netcat.c
+}
+
+src_compile() {
+ export XLIBS=""
+ export XFLAGS="-DLINUX -DTELNET -DGAPING_SECURITY_HOLE"
+ use ipv6 && XFLAGS="${XFLAGS} -DINET6"
+ use static && export STATIC="-static"
+ use crypt && XFLAGS="${XFLAGS} -DAESCRYPT" && XLIBS="${XLIBS} -lmix"
+ [[ ${CHOST} == *-solaris* ]] && XLIBS="${XLIBS} -lnsl -lsocket"
+ emake -e CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}" nc
+}
+
+src_install() {
+ dobin nc
+ dodoc README* netcat.blurb debian-*
+ doman nc.1
+ docinto scripts
+ dodoc scripts/*
+}