summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-09-09 07:01:49 +0200
committerJeroen Roovers <jer@gentoo.org>2016-09-09 07:02:27 +0200
commit1170d3372281a283d775907df6a40c8e18aa830a (patch)
tree2f66d33b86d3ce5e10eaee7e6d0a3733cab74b5d /net-analyzer/nmap/nmap-9999.ebuild
parentnet-misc/curl: Stable for HPPA (bug #592974). (diff)
downloadgentoo-1170d3372281a283d775907df6a40c8e18aa830a.tar.gz
gentoo-1170d3372281a283d775907df6a40c8e18aa830a.tar.bz2
gentoo-1170d3372281a283d775907df6a40c8e18aa830a.zip
net-analyzer/nmap: Update live ebuild.
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-analyzer/nmap/nmap-9999.ebuild')
-rw-r--r--net-analyzer/nmap/nmap-9999.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/net-analyzer/nmap/nmap-9999.ebuild b/net-analyzer/nmap/nmap-9999.ebuild
index ca472d603cc1..7ed59bdaa4ec 100644
--- a/net-analyzer/nmap/nmap-9999.ebuild
+++ b/net-analyzer/nmap/nmap-9999.ebuild
@@ -20,7 +20,7 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="ipv6 libressl +nse system-lua ncat ndiff nls nmap-update nping ssl zenmap"
-NMAP_LINGUAS=( de fr hr it ja pl pt_BR ru zh )
+NMAP_LINGUAS=( de fr hi hr it ja pl pt_BR ru zh )
IUSE+=" ${NMAP_LINGUAS[@]/#/linguas_}"
REQUIRED_USE="
@@ -66,9 +66,9 @@ src_prepare() {
"${FILESDIR}"/${PN}-6.25-liblua-ar.patch \
"${FILESDIR}"/${PN}-6.46-uninstaller.patch \
"${FILESDIR}"/${PN}-6.47-no-libnl.patch \
- "${FILESDIR}"/${PN}-7.25-no-FORTIFY_SOURCE.patch \
"${FILESDIR}"/${PN}-7.25-CXXFLAGS.patch \
- "${FILESDIR}"/${PN}-7.25-libpcre.patch
+ "${FILESDIR}"/${PN}-7.25-libpcre.patch \
+ "${FILESDIR}"/${PN}-7.25-no-FORTIFY_SOURCE.patch
if use nls; then
local lingua=''
@@ -122,11 +122,13 @@ src_configure() {
}
src_compile() {
- local dep deps="build-dnet build-nbase build-nsock build-netutil"
- use system-lua || deps="build-lua ${deps}"
-
- for dep in ${deps}; do
- emake makefile.dep ${dep}
+ local directory
+ for directory in . libnetutil nsock/src \
+ $(usex ncat ncat '') \
+ $(usex nmap-update nmap-update '') \
+ $(usex nping nping '')
+ do
+ emake -C "${directory}" makefile.dep
done
emake \