summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-11-04 19:30:20 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-11-04 19:37:24 -0400
commit974707d375cc8cb22593224b38c73853e906d157 (patch)
tree20c7680b39de38b7b3445e1e4fdf92166d687c95 /net-analyzer/pnp4nagios
parentnet-analyzer/pnp4nagios: drop USE=icinga2 in a new revision. (diff)
downloadgentoo-974707d375cc8cb22593224b38c73853e906d157.tar.gz
gentoo-974707d375cc8cb22593224b38c73853e906d157.tar.bz2
gentoo-974707d375cc8cb22593224b38c73853e906d157.zip
net-analyzer/pnp4nagios: use group permissions for writable directories.
The past few revisions have made some directories owned by the "nagios user" so that the nagios/icinga daemon can write stuff there. Instead of giving ownership of those directories to the nagios user, it's a little bit more secure to give group-rwx permissions to the "nagios group." This new revision does that instead. Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-analyzer/pnp4nagios')
-rw-r--r--net-analyzer/pnp4nagios/pnp4nagios-0.6.26-r9.ebuild (renamed from net-analyzer/pnp4nagios/pnp4nagios-0.6.26-r8.ebuild)9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-analyzer/pnp4nagios/pnp4nagios-0.6.26-r8.ebuild b/net-analyzer/pnp4nagios/pnp4nagios-0.6.26-r9.ebuild
index 8d5fdbcf842d..ffa296c13489 100644
--- a/net-analyzer/pnp4nagios/pnp4nagios-0.6.26-r8.ebuild
+++ b/net-analyzer/pnp4nagios/pnp4nagios-0.6.26-r9.ebuild
@@ -75,16 +75,19 @@ src_install() {
# perfdata-dir...
local user_group=nagios
use icinga && user_group=icinga
- fowners "${user_group}:${user_group}" /var/lib/pnp/{,perfdata,spool}
+ fowners ":${user_group}" /var/lib/pnp/{,perfdata,spool}
+ fperms g+rwx /var/lib/pnp/{,perfdata,spool}
# and likewise for its logs...
dodir /var/log/pnp
- fowners "${user_group}:${user_group}" /var/log/pnp
+ fowners ":${user_group}" /var/log/pnp
+ fperms g+rwx /var/log/pnp
# and its statistics. This one is arguably the responsibility of the
# build system, since process_perfdata.cfg refers to this location.
dodir /var/lib/pnp/stats
- fowners "${user_group}:${user_group}" /var/lib/pnp/stats
+ fowners ":${user_group}" /var/lib/pnp/stats
+ fperms g+rwx /var/lib/pnp/stats
}
pkg_postinst() {