summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-03-19 00:13:55 +0100
committerJeroen Roovers <jer@gentoo.org>2018-03-19 00:13:55 +0100
commit55faf214ff973fa7cf0e4995c111f435b1fe6167 (patch)
tree6301a902c593c7b64264fb12646556193761c7cc /net-analyzer/rrdtool
parentwww-client/links: stable 2.14-r1 for ppc, bug #642512 (diff)
downloadgentoo-55faf214ff973fa7cf0e4995c111f435b1fe6167.tar.gz
gentoo-55faf214ff973fa7cf0e4995c111f435b1fe6167.tar.bz2
gentoo-55faf214ff973fa7cf0e4995c111f435b1fe6167.zip
net-analyzer/rrdtool: Old.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-analyzer/rrdtool')
-rw-r--r--net-analyzer/rrdtool/Manifest2
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.4.7-configure.ac.patch21
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.5.5-rpn1.output3
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.4.8-r1.ebuild161
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.5.5-r1.ebuild185
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.5.5.ebuild176
6 files changed, 0 insertions, 548 deletions
diff --git a/net-analyzer/rrdtool/Manifest b/net-analyzer/rrdtool/Manifest
index cfe251c3bea..7941d2a78d6 100644
--- a/net-analyzer/rrdtool/Manifest
+++ b/net-analyzer/rrdtool/Manifest
@@ -1,4 +1,2 @@
-DIST rrdtool-1.4.8.tar.gz 1379482 BLAKE2B 32a12ac87dda70a2d4cde97b435f99e4ac930699d8881076adf44ff64f197f1f14f9f7b1839c0894704bb9e518d5eab411a65eb41eda6a4d9e09b55fc6d288c7 SHA512 c525978829508e1db393092c948d8db910554f42e1221acc4064a8f546ceac5d68943f603c6f0ef0e6510bbe5f606cfe6862672145ea1b630cd2b7fd07fa805b
-DIST rrdtool-1.5.5.tar.gz 2187685 BLAKE2B eeb887f705ae1ea84e9f84a46243a66c5d1b8756c2996ca6f34ee954095a26dfa4992aa976be9336d62e22c3ba399d69c59f11eeea3c510ffa9d05e2d5b98b21 SHA512 07fb0edb5fbc0b491f8a40844d4a914f26c6269b2d07ab91f4d54fdcfeb7899348362044ac632223341f30fc10e6748a59863977496801530f5cdd2d61f0e88c
DIST rrdtool-1.6.0.tar.gz 2186538 BLAKE2B b56ef79b9d45a65cacd7c1d8da2158dcaaff3ebc2ffc0640081cdc2fa3ac643be1ce48a2cac60427a836dc3e457ddb042c95533d0ffbcdefa2978f5659150391 SHA512 45a8f16a2bda9d497c5f39de80236adb7a5bd054a14755c4d130f21cd6430bd0a76caef9632994be56fd1ea2364eb218687ea8ebf945a71ca411221c248f3ebd
DIST rrdtool-1.7.0.tar.gz 2849994 BLAKE2B f7a91fa661728850af55356a69b61ea1d4343c79579823e025e0a0757d1dab0d2cda6387197ece20e07f33a657743350cadfaf6504500f13be472d18e8826a3f SHA512 36d979561601135d74622eaf183701de15cba5e25118f7a308926a695ba84ecb33c3d16511bf4bc80cff055853e2eb85065bc4ed8aef19fc0277c6430ecd319f
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.4.7-configure.ac.patch b/net-analyzer/rrdtool/files/rrdtool-1.4.7-configure.ac.patch
deleted file mode 100644
index 668adeee13e..00000000000
--- a/net-analyzer/rrdtool/files/rrdtool-1.4.7-configure.ac.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -148,7 +148,7 @@
- AC_PROG_CPP
- AC_PROG_CC
- AM_PROG_CC_C_O
--AC_PROG_LIBTOOL
-+LT_INIT
-
- dnl Try to detect/use GNU features
- CFLAGS="$CFLAGS -D_GNU_SOURCE"
-@@ -204,9 +204,6 @@
- AC_CHECK_FUNC(acos, , AC_CHECK_LIB(m, acos))
-
-
--dnl add pic flag in any case this makes sure all our code is relocatable
--eval `./libtool --config | grep pic_flag=`
--CFLAGS="$CFLAGS $pic_flag"
-
-
- dnl Checks for library functions.
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.5.5-rpn1.output b/net-analyzer/rrdtool/files/rrdtool-1.5.5-rpn1.output
deleted file mode 100644
index 4a7696dbcf0..00000000000
--- a/net-analyzer/rrdtool/files/rrdtool-1.5.5-rpn1.output
+++ /dev/null
@@ -1,3 +0,0 @@
-print[0] = "30.769231"
-print[1] = "72.000000"
-print[2] = "0.000000"
diff --git a/net-analyzer/rrdtool/rrdtool-1.4.8-r1.ebuild b/net-analyzer/rrdtool/rrdtool-1.4.8-r1.ebuild
deleted file mode 100644
index 0d34b417da7..00000000000
--- a/net-analyzer/rrdtool/rrdtool-1.4.8-r1.ebuild
+++ /dev/null
@@ -1,161 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-DISTUTILS_OPTIONAL="true"
-GENTOO_DEPEND_ON_PERL="no"
-PYTHON_COMPAT=( python2_7 )
-inherit eutils distutils-r1 flag-o-matic multilib perl-module autotools
-
-DESCRIPTION="A system to store and display time-series data"
-HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
-SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
-IUSE="dbi doc +graph lua perl python rrdcgi ruby static-libs tcl tcpd"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-CDEPEND="
- >=dev-libs/glib-2.28.7:2[static-libs(+)?]
- >=dev-libs/libxml2-2.7.8:2[static-libs(+)?]
- dbi? ( dev-db/libdbi[static-libs(+)?] )
- graph? (
- >=media-libs/libpng-1.5.10:0=[static-libs(+)?]
- >=x11-libs/cairo-1.10.2[svg,static-libs(+)?]
- >=x11-libs/pango-1.28
- )
- lua? ( dev-lang/lua:*[deprecated] )
- perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
- tcl? ( dev-lang/tcl:0= )
- tcpd? ( sys-apps/tcp-wrappers )
-"
-
-DEPEND="
- ${CDEPEND}
- sys-apps/groff
- virtual/pkgconfig
- virtual/awk
-"
-RDEPEND="
- ${CDEPEND}
-"
-PDEPEND="
- ruby? ( dev-ruby/rrdtool-bindings )
-"
-
-python_compile() {
- cd bindings/python || die
- distutils-r1_python_compile
-}
-
-python_install() {
- cd bindings/python || die
- distutils-r1_python_install
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.4.7-configure.ac.patch
-
- # bug 456810
- # no time to sleep
- sed -i \
- -e 's|$LUA_CFLAGS|IGNORE_THIS_BAD_TEST|g' \
- -e 's|^sleep 1$||g' \
- configure.ac || die
-
- # Python bindings are built/installed manually
- sed -i \
- -e '/^all-local:/s| @COMP_PYTHON@||' \
- bindings/Makefile.am || die
-
- eautoreconf
-}
-
-src_configure() {
- filter-flags -ffast-math
-
- export RRDDOCDIR=${EPREFIX}/usr/share/doc/${PF}
-
- # to solve bug #260380
- [[ ${CHOST} == *-solaris* ]] && append-flags -D__EXTENSIONS__
-
- # Stub configure.ac
- local myconf=()
- if ! use tcpd; then
- myconf+=( "--disable-libwrap" )
- fi
- if ! use dbi; then
- myconf+=( "--disable-libdbi" )
- fi
-
- econf \
- $(use_enable graph rrd_graph) \
- $(use_enable lua lua-site-install) \
- $(use_enable lua) \
- $(use_enable perl perl-site-install) \
- $(use_enable perl) \
- $(use_enable python) \
- $(use_enable rrdcgi) \
- $(use_enable static-libs static) \
- $(use_enable tcl) \
- $(use_with tcl tcllib "${EPREFIX}"/usr/$(get_libdir)) \
- --with-perl-options=INSTALLDIRS=vendor \
- --disable-ruby-site-install \
- --disable-ruby \
- ${myconf[@]}
-}
-
-src_compile() {
- default
-
- use python && distutils-r1_src_compile
-}
-
-src_install() {
- default
-
- if ! use doc ; then
- rm -rf "${ED}"usr/share/doc/${PF}/{html,txt}
- fi
-
- if use !rrdcgi ; then
- # uses rrdcgi, causes invalid shebang error in Prefix, useless
- # without rrdcgi installed
- rm -f "${ED}"usr/share/${PN}/examples/cgi-demo.cgi
- fi
-
- if use perl ; then
- perl_delete_localpod
- perl_delete_packlist
- fi
-
- dodoc CHANGES CONTRIBUTORS NEWS README THREADS TODO
-
- find "${ED}"usr -name '*.la' -exec rm -f {} +
-
- keepdir /var/lib/rrdcached/journal/
- keepdir /var/lib/rrdcached/db/
-
- newconfd "${FILESDIR}"/rrdcached.confd rrdcached
- newinitd "${FILESDIR}"/rrdcached.init rrdcached
-
- use python && distutils-r1_src_install
-}
-
-pkg_postinst() {
- ewarn "Since version 1.3, rrdtool dump emits completely legal xml. Basically this"
- ewarn "means that it contains an xml header and a DOCTYPE definition. Unfortunately"
- ewarn "this causes older versions of rrdtool restore to be unhappy."
- ewarn
- ewarn "To restore a new dump with an old rrdtool restore version, either remove"
- ewarn "the xml header and the doctype by hand (both on the first line of the dump)"
- ewarn "or use rrdtool dump --no-header."
- ewarn
- ewarn ">=net-analyzer/rrdtool-1.3 does not have any default font bundled. Thus if"
- ewarn ">you've upgraded from rrdtool-1.2.x and don't have any font installed to make"
- ewarn ">lables visible, please, install some font, e.g. media-fonts/dejavu."
-}
diff --git a/net-analyzer/rrdtool/rrdtool-1.5.5-r1.ebuild b/net-analyzer/rrdtool/rrdtool-1.5.5-r1.ebuild
deleted file mode 100644
index 7178baae6cd..00000000000
--- a/net-analyzer/rrdtool/rrdtool-1.5.5-r1.ebuild
+++ /dev/null
@@ -1,185 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-DISTUTILS_OPTIONAL=true
-DISTUTILS_SINGLE_IMPL=true
-GENTOO_DEPEND_ON_PERL=no
-PYTHON_COMPAT=( python2_7 )
-inherit autotools eutils perl-module distutils-r1 flag-o-matic multilib
-
-DESCRIPTION="A system to store and display time-series data"
-HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
-SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${P/_/-}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
-IUSE="dbi doc graph lua perl python rados rrdcgi ruby static-libs tcl tcpd"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-CDEPEND="
- >=dev-libs/glib-2.28.7:2[static-libs(+)?]
- >=dev-libs/libxml2-2.7.8:2[static-libs(+)?]
- dbi? ( dev-db/libdbi[static-libs(+)?] )
- graph? (
- >=media-libs/libpng-1.5.10:0=[static-libs(+)?]
- >=x11-libs/cairo-1.10.2[svg,static-libs(+)?]
- >=x11-libs/pango-1.28
- )
- lua? ( dev-lang/lua:*[deprecated] )
- perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
- rados? ( sys-cluster/ceph )
- tcl? ( dev-lang/tcl:0= )
- tcpd? ( sys-apps/tcp-wrappers )
-"
-
-DEPEND="
- ${CDEPEND}
- sys-apps/groff
- virtual/pkgconfig
- virtual/awk
-"
-RDEPEND="
- ${CDEPEND}
-"
-PDEPEND="
- ruby? ( ~dev-ruby/rrdtool-bindings-${PV} )
-"
-
-S=${WORKDIR}/${P/_/-}
-
-python_compile() {
- cd bindings/python || die
- distutils-r1_python_compile
-}
-
-python_install() {
- cd bindings/python || die
- distutils-r1_python_install
-}
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # At the next version bump, please see if you actually still need this
- # before adding versions
- cp "${FILESDIR}"/${P}-rpn1.output tests/rpn1.output || die
- cp "${FILESDIR}"/${P}-rrdrados.pod doc/rrdrados.pod || die
-
- epatch \
- "${FILESDIR}"/${PN}-1.4.7-configure.ac.patch \
- "${FILESDIR}"/${PN}-1.4.9-disable-rrd_graph-cgi.patch \
- "${FILESDIR}"/${PN}-1.4.9-disable-rrd_graph-perl.patch \
- "${FILESDIR}"/${PN}-1.5.0_rc1-disable-rrd_graph-lua.patch \
- "${FILESDIR}"/${PN}-1.5.0_rc1-disable-rrd_graph-python.patch
-
- # bug 456810
- # no time to sleep
- sed -i \
- -e 's|$LUA_CFLAGS|IGNORE_THIS_BAD_TEST|g' \
- -e 's|^sleep 1$||g' \
- -e '/^dnl.*png/s|^dnl||g' \
- configure.ac || die
-
- # Python bindings are built/installed manually
- sed -i \
- -e '/^all-local:/s| @COMP_PYTHON@||' \
- bindings/Makefile.am || die
-
- if ! use graph; then
- sed -i \
- -e '2s:rpn1::; 2s:rpn2::; 6s:create-with-source-4::;' \
- -e '7s:xport1::; 7s:dcounter1::; 7s:vformatter1::' \
- tests/Makefile.am || die
- fi
-
- echo ${PV/_rc*/} >> VERSION || die
-
- export rd_cv_gcc_flag__Werror=no
-
- eautoreconf
-}
-
-src_configure() {
- filter-flags -ffast-math
-
- export RRDDOCDIR=${EPREFIX}/usr/share/doc/${PF}
-
- # to solve bug #260380
- [[ ${CHOST} == *-solaris* ]] && append-flags -D__EXTENSIONS__
-
- # Stub configure.ac
- local myconf=()
- if ! use tcpd; then
- myconf+=( "--disable-libwrap" )
- fi
- if ! use dbi; then
- myconf+=( "--disable-libdbi" )
- fi
- if ! use rados; then
- myconf+=( "--disable-librados" )
- fi
-
- econf \
- $(use_enable graph rrd_graph) \
- $(use_enable lua lua-site-install) \
- $(use_enable lua) \
- $(use_enable perl perl-site-install) \
- $(use_enable perl) \
- $(use_enable python) \
- $(use_enable rrdcgi) \
- $(use_enable static-libs static) \
- $(use_enable tcl) \
- $(use_with tcl tcllib "${EPREFIX}"/usr/$(get_libdir)) \
- --with-perl-options=INSTALLDIRS=vendor \
- --disable-ruby-site-install \
- --disable-ruby \
- ${myconf[@]}
-}
-
-src_compile() {
- default
-
- use python && distutils-r1_src_compile
-}
-
-src_test() {
- export LC_ALL=C
- default
-}
-
-src_install() {
- default
-
- if ! use doc ; then
- rm -rf "${ED}"usr/share/doc/${PF}/{html,txt}
- fi
-
- if use !rrdcgi ; then
- # uses rrdcgi, causes invalid shebang error in Prefix, useless
- # without rrdcgi installed
- rm -f "${ED}"usr/share/${PN}/examples/cgi-demo.cgi
- fi
-
- if use perl ; then
- perl_delete_localpod
- perl_delete_packlist
- fi
-
- dodoc CHANGES CONTRIBUTORS NEWS THREADS TODO
-
- find "${ED}"usr -name '*.la' -exec rm -f {} +
-
- keepdir /var/lib/rrdcached/journal/
- keepdir /var/lib/rrdcached/db/
-
- newconfd "${FILESDIR}"/rrdcached.confd rrdcached
- newinitd "${FILESDIR}"/rrdcached.init rrdcached
-
- use python && distutils-r1_src_install
-}
diff --git a/net-analyzer/rrdtool/rrdtool-1.5.5.ebuild b/net-analyzer/rrdtool/rrdtool-1.5.5.ebuild
deleted file mode 100644
index bc62b58b7d6..00000000000
--- a/net-analyzer/rrdtool/rrdtool-1.5.5.ebuild
+++ /dev/null
@@ -1,176 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-DISTUTILS_OPTIONAL=true
-DISTUTILS_SINGLE_IMPL=true
-GENTOO_DEPEND_ON_PERL=no
-PYTHON_COMPAT=( python2_7 )
-inherit autotools eutils perl-module distutils-r1 flag-o-matic multilib
-
-DESCRIPTION="A system to store and display time-series data"
-HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
-SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${P/_/-}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm hppa ~mips ~ppc ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
-IUSE="dbi doc graph lua perl python rados rrdcgi ruby static-libs tcl tcpd"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-CDEPEND="
- >=dev-libs/glib-2.28.7:2[static-libs(+)?]
- >=dev-libs/libxml2-2.7.8:2[static-libs(+)?]
- dbi? ( dev-db/libdbi[static-libs(+)?] )
- graph? (
- >=media-libs/libpng-1.5.10:0=[static-libs(+)?]
- >=x11-libs/cairo-1.10.2[svg,static-libs(+)?]
- >=x11-libs/pango-1.28
- )
- lua? ( dev-lang/lua:*[deprecated] )
- perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
- rados? ( sys-cluster/ceph )
- tcl? ( dev-lang/tcl:0= )
- tcpd? ( sys-apps/tcp-wrappers )
-"
-
-DEPEND="
- ${CDEPEND}
- sys-apps/groff
- virtual/pkgconfig
- virtual/awk
-"
-RDEPEND="
- ${CDEPEND}
-"
-PDEPEND="
- ruby? ( ~dev-ruby/rrdtool-bindings-${PV} )
-"
-
-S=${WORKDIR}/${P/_/-}
-
-python_compile() {
- cd bindings/python || die
- distutils-r1_python_compile
-}
-
-python_install() {
- cd bindings/python || die
- distutils-r1_python_install
-}
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # At the next version bump, please see if you actually still need this
- # before adding versions
- cp "${FILESDIR}"/${P}-rrdrados.pod doc/rrdrados.pod || die
-
- epatch \
- "${FILESDIR}"/${PN}-1.4.7-configure.ac.patch \
- "${FILESDIR}"/${PN}-1.4.9-disable-rrd_graph-cgi.patch \
- "${FILESDIR}"/${PN}-1.4.9-disable-rrd_graph-perl.patch \
- "${FILESDIR}"/${PN}-1.5.0_rc1-disable-rrd_graph-lua.patch \
- "${FILESDIR}"/${PN}-1.5.0_rc1-disable-rrd_graph-python.patch
-
- # bug 456810
- # no time to sleep
- sed -i \
- -e 's|$LUA_CFLAGS|IGNORE_THIS_BAD_TEST|g' \
- -e 's|^sleep 1$||g' \
- -e '/^dnl.*png/s|^dnl||g' \
- configure.ac || die
-
- # Python bindings are built/installed manually
- sed -i \
- -e '/^all-local:/s| @COMP_PYTHON@||' \
- bindings/Makefile.am || die
-
- echo ${PV/_rc*/} >> VERSION || die
-
- export rd_cv_gcc_flag__Werror=no
-
- eautoreconf
-}
-
-src_configure() {
- filter-flags -ffast-math
-
- export RRDDOCDIR=${EPREFIX}/usr/share/doc/${PF}
-
- # to solve bug #260380
- [[ ${CHOST} == *-solaris* ]] && append-flags -D__EXTENSIONS__
-
- # Stub configure.ac
- local myconf=()
- if ! use tcpd; then
- myconf+=( "--disable-libwrap" )
- fi
- if ! use dbi; then
- myconf+=( "--disable-libdbi" )
- fi
- if ! use rados; then
- myconf+=( "--disable-librados" )
- fi
-
- econf \
- $(use_enable graph rrd_graph) \
- $(use_enable lua lua-site-install) \
- $(use_enable lua) \
- $(use_enable perl perl-site-install) \
- $(use_enable perl) \
- $(use_enable python) \
- $(use_enable rrdcgi) \
- $(use_enable static-libs static) \
- $(use_enable tcl) \
- $(use_with tcl tcllib "${EPREFIX}"/usr/$(get_libdir)) \
- --with-perl-options=INSTALLDIRS=vendor \
- --disable-ruby-site-install \
- --disable-ruby \
- ${myconf[@]}
-}
-
-src_compile() {
- default
-
- use python && distutils-r1_src_compile
-}
-
-src_test() {
- default
-}
-
-src_install() {
- default
-
- if ! use doc ; then
- rm -rf "${ED}"usr/share/doc/${PF}/{html,txt}
- fi
-
- if use !rrdcgi ; then
- # uses rrdcgi, causes invalid shebang error in Prefix, useless
- # without rrdcgi installed
- rm -f "${ED}"usr/share/${PN}/examples/cgi-demo.cgi
- fi
-
- if use perl ; then
- perl_delete_localpod
- perl_delete_packlist
- fi
-
- dodoc CHANGES CONTRIBUTORS NEWS THREADS TODO
-
- find "${ED}"usr -name '*.la' -exec rm -f {} +
-
- keepdir /var/lib/rrdcached/journal/
- keepdir /var/lib/rrdcached/db/
-
- newconfd "${FILESDIR}"/rrdcached.confd rrdcached
- newinitd "${FILESDIR}"/rrdcached.init rrdcached
-
- use python && distutils-r1_src_install
-}