summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-10-07 07:56:49 +0200
committerJeroen Roovers <jer@gentoo.org>2019-10-07 08:01:16 +0200
commit2d93242a38f1635d7bb42594ad1fa50c3586a06e (patch)
tree2a46790f0b6177ebc0df93e2801f965c6df64896 /net-analyzer
parentdev-ruby/roadie: add 3.5.1 (diff)
downloadgentoo-2d93242a38f1635d7bb42594ad1fa50c3586a06e.tar.gz
gentoo-2d93242a38f1635d7bb42594ad1fa50c3586a06e.tar.bz2
gentoo-2d93242a38f1635d7bb42594ad1fa50c3586a06e.zip
net-analyzer/arpoison: Version 0.7
Apparently the SF page was never updated, but the actual HOMEPAGE was updated. Version 0.7 was released in 2014 as noted in the change between [1] and [2]. [1] https://web.archive.org/web/20140201133522/http://www.arpoison.net:80/ [2] https://web.archive.org/web/20140325065245/http://www.arpoison.net/ Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/arpoison/Manifest1
-rw-r--r--net-analyzer/arpoison/arpoison-0.7.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/arpoison/Manifest b/net-analyzer/arpoison/Manifest
index 70b91d6b6ae6..2520f6df2d53 100644
--- a/net-analyzer/arpoison/Manifest
+++ b/net-analyzer/arpoison/Manifest
@@ -1 +1,2 @@
DIST arpoison-0.6.tar.gz 8646 BLAKE2B 7e9a7aaf9fb184ffed4e69d1d709f3ec242423dd699014e89ce7eaf99cb225299110b3a6fed4059db89c3bbd05b30262d56dec4bf60bed367f01700f40fde883 SHA512 7c14a15b9b85f777e5151fae82dfbdb44dbfc85ce8f632b7d76727bce79ed7f958f725f39348489bc4659cb5e3b7ab5370e88e33c03277e16ab2f9ff00bb4038
+DIST arpoison-0.7.tar.gz 8458 BLAKE2B b0050aa6f3246fec9fb4db8bbb3f9f5f1d52b5b6c37851f0c6bec8b6c89fabd7f1811ae40a4c81af6eae16761f38fb749d0f2a58311645ef360d798b6ccbbb50 SHA512 d5af078c8e2c64eb721da75b5d6659ca017267f146d0dca7e0f1ba77bfd93a0f56363428c198e9c46537768d3568d813c150bfbc091430fc355a269f9327108f
diff --git a/net-analyzer/arpoison/arpoison-0.7.ebuild b/net-analyzer/arpoison/arpoison-0.7.ebuild
new file mode 100644
index 000000000000..1013922ba19e
--- /dev/null
+++ b/net-analyzer/arpoison/arpoison-0.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A utility to poison ARP caches"
+HOMEPAGE="http://arpoison.sourceforge.net/ http://www.arpoison.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+RDEPEND="
+ net-libs/libnet:1.1
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+src_compile() {
+ local compile="$(tc-getCC) ${PN}.c -o ${PN} ${CFLAGS} ${LDFLAGS} $("${BROOT}/usr/bin/libnet-config" --cflags --libs)"
+ echo "${compile}"
+ ${compile} || die
+}
+
+src_install() {
+ dosbin arpoison
+ doman arpoison.8
+ dodoc README
+}