summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHasan ÇALIŞIR <hasan.calisir@psauxit.com>2019-10-29 17:47:29 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-10-29 19:29:31 +0200
commit4c0c5c558ac80025dc8b3f1ae48f67412ab9b203 (patch)
tree19da062b027c935a1488c26d41d700f1f6ea687a /net-analyzer
parentnet-analyzer/hydra: Stable for amd64 x86 too (diff)
downloadgentoo-4c0c5c558ac80025dc8b3f1ae48f67412ab9b203.tar.gz
gentoo-4c0c5c558ac80025dc8b3f1ae48f67412ab9b203.tar.bz2
gentoo-4c0c5c558ac80025dc8b3f1ae48f67412ab9b203.zip
net-analyzer/metasploit: drop openvas-omp support
set slot on dev-ruby/rubyzip. drop openvas-omp support. Closes: https://bugs.gentoo.org/698762 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Closes: https://github.com/gentoo/gentoo/pull/13488 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/metasploit/metasploit-4.17.21-r6.ebuild8
-rw-r--r--net-analyzer/metasploit/metasploit-9999.ebuild8
2 files changed, 14 insertions, 2 deletions
diff --git a/net-analyzer/metasploit/metasploit-4.17.21-r6.ebuild b/net-analyzer/metasploit/metasploit-4.17.21-r6.ebuild
index e24648b0588..db815de8d1d 100644
--- a/net-analyzer/metasploit/metasploit-4.17.21-r6.ebuild
+++ b/net-analyzer/metasploit/metasploit-4.17.21-r6.ebuild
@@ -92,7 +92,7 @@ RUBY_COMMON_DEPEND="virtual/ruby-ssl
dev-ruby/ruby-macho
dev-ruby/rubyntlm
dev-ruby/ruby_smb:*
- dev-ruby/rubyzip
+ dev-ruby/rubyzip:*
dev-ruby/sqlite3
dev-ruby/sshkey
dev-ruby/tzinfo:*
@@ -215,6 +215,12 @@ all_ruby_prepare() {
#if ! use nessus; then
sed -i -e "/nessus/d" metasploit-framework.gemspec || die
#fi
+
+ #OpenVAS support dropped on net-analyzer/metasploit. Bug:692076
+ #openvas-omp is deprecated and masked for removal. Bug:692076
+ #Remove openvas-omp in gemspec. Bug:698762
+ sed -i -e "/openvas-omp/d" metasploit-framework.gemspec || die
+
#even if we pass --without=blah bundler still calculates the deps and messes us up
if ! use development; then
sed -i -e "/^group :development do/,/^end$/d" Gemfile || die
diff --git a/net-analyzer/metasploit/metasploit-9999.ebuild b/net-analyzer/metasploit/metasploit-9999.ebuild
index 08d45194b38..42bf6440d53 100644
--- a/net-analyzer/metasploit/metasploit-9999.ebuild
+++ b/net-analyzer/metasploit/metasploit-9999.ebuild
@@ -91,7 +91,7 @@ RUBY_COMMON_DEPEND="virtual/ruby-ssl
dev-ruby/ruby-macho
dev-ruby/rubyntlm
dev-ruby/ruby_smb:*
- dev-ruby/rubyzip
+ dev-ruby/rubyzip:*
dev-ruby/sqlite3
dev-ruby/sshkey
dev-ruby/tzinfo:*
@@ -214,6 +214,12 @@ all_ruby_prepare() {
#if ! use nessus; then
sed -i -e "/nessus/d" metasploit-framework.gemspec || die
#fi
+
+ #OpenVAS support dropped on net-analyzer/metasploit. Bug:692076
+ #openvas-omp is deprecated and masked for removal. Bug:692076
+ #Remove openvas-omp in gemspec. Bug:698762
+ sed -i -e "/openvas-omp/d" metasploit-framework.gemspec || die
+
#even if we pass --without=blah bundler still calculates the deps and messes us up
if ! use development; then
sed -i -e "/^group :development do/,/^end$/d" Gemfile || die