summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-10-26 11:03:25 +0200
committerJeroen Roovers <jer@gentoo.org>2016-10-26 11:04:14 +0200
commit83bd7933e60753ca2d20f7a3c098e81451b10775 (patch)
treebb7c16a03603a55010d2222a3b13b7cb63effa7e /net-analyzer
parentnet-libs/libpcap: Drop libusb dependency, mgmt.h include. (diff)
downloadgentoo-83bd7933e60753ca2d20f7a3c098e81451b10775.tar.gz
gentoo-83bd7933e60753ca2d20f7a3c098e81451b10775.tar.bz2
gentoo-83bd7933e60753ca2d20f7a3c098e81451b10775.zip
net-analyzer/tcpdump: Version bump.
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcpdump/Manifest1
-rw-r--r--net-analyzer/tcpdump/tcpdump-4.8.1.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/net-analyzer/tcpdump/Manifest b/net-analyzer/tcpdump/Manifest
index d3b9358f8a3c..fe4a513849fd 100644
--- a/net-analyzer/tcpdump/Manifest
+++ b/net-analyzer/tcpdump/Manifest
@@ -1,2 +1,3 @@
DIST tcpdump-4.7.4.tar.gz 1153657 SHA256 6be520269a89036f99c0b2126713a60965953eab921002b07608ccfc0c47d9af SHA512 5660d82abdf7327c3e1717db519b2c98cd217fff17440019f3ccf166b3cb28ab1c1850b7c42f8c6ee38110838bb8a4a10cd394f25123783bb3d58e1f350ef326 WHIRLPOOL 7c320adf64bf5ff57af7f98fec9919ba3c07056fbbbe1c8a87ac73ecb767ce245c4963e69e24ff71704be7b42dc604992f261173a34b12a87cd0eab153762816
DIST tcpdump-4.8.0.tar.gz 1149698 SHA256 6d80fe345d0f5ee42fd273bfafe076231ad700c2daaf56805d17dc8159a6d1a7 SHA512 c35b26bd170706116a5274846f967893c2d6f1f67082c0aa264d0811b6bdd2d7bd9dcde3f725179b0916c0160088bc87298af061179d2f1ca47a0f3e2cd870ab WHIRLPOOL 43129349417cb68b2076efb2d01683f122d998d98e625e39edc25c336d06fc714ccb06beb85e8ce4bcbe12f185cff9865c27583e242420dd3b44b7b26dd3ca90
+DIST tcpdump-4.8.1.tar.gz 1156643 SHA256 3cdfd4ef11ae751fd6ac2622148d93784b3ef8385b671d61f56c3b38c432a69b SHA512 b7d4afbaf30389954d3ca6e91db5d3351aa229a48a330eec89602e8650d16ba3284de51f66b2e365f064b8c2b906b67b469d0a00e603e0518ec22e5215724466 WHIRLPOOL 76f5f51f482f0834899a5f07ab6b6ab14688f8527810e2065c425356c1b08a0013b932017d95fdf140cb38d80db4d7df735cc815c0ffb418560c8ea4113eb98b
diff --git a/net-analyzer/tcpdump/tcpdump-4.8.1.ebuild b/net-analyzer/tcpdump/tcpdump-4.8.1.ebuild
new file mode 100644
index 000000000000..edeef25e777c
--- /dev/null
+++ b/net-analyzer/tcpdump/tcpdump-4.8.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit flag-o-matic toolchain-funcs user
+
+DESCRIPTION="A Tool for network monitoring and data acquisition"
+HOMEPAGE="
+ http://www.tcpdump.org/
+ https://github.com/the-tcpdump-group/tcpdump
+"
+SRC_URI="
+ https://github.com/the-${PN}-group/${PN}/archive/${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="+drop-root libressl smi ssl samba suid test"
+
+RDEPEND="
+ drop-root? ( sys-libs/libcap-ng )
+ net-libs/libpcap
+ smi? ( net-libs/libsmi )
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6m:0 )
+ libressl? ( dev-libs/libressl )
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ drop-root? ( virtual/pkgconfig )
+ test? (
+ || ( app-arch/sharutils sys-freebsd/freebsd-ubin )
+ dev-lang/perl
+ )
+"
+
+S=${WORKDIR}/${PN}-${P}
+
+pkg_setup() {
+ if use drop-root || use suid; then
+ enewgroup tcpdump
+ enewuser tcpdump -1 -1 -1 tcpdump
+ fi
+}
+
+src_configure() {
+ if use drop-root; then
+ append-cppflags -DHAVE_CAP_NG_H
+ export LIBS=$( $(tc-getPKG_CONFIG) --libs libcap-ng )
+ fi
+
+ econf \
+ $(use_enable samba smb) \
+ $(use_with drop-root chroot '') \
+ $(use_with smi) \
+ $(use_with ssl crypto "${EPREFIX}/usr") \
+ $(usex drop-root "--with-user=tcpdump" "")
+}
+
+src_test() {
+ if [[ ${EUID} -ne 0 ]] || ! use drop-root; then
+ sed -i -e '/^\(espudp1\|eapon1\)/d;' tests/TESTLIST || die
+ emake check
+ else
+ ewarn "If you want to run the test suite, make sure you either"
+ ewarn "set FEATURES=userpriv or set USE=-drop-root"
+ fi
+}
+
+src_install() {
+ dosbin tcpdump
+ doman tcpdump.1
+ dodoc *.awk
+ dodoc CHANGES CREDITS README.md
+
+ if use suid; then
+ fowners root:tcpdump /usr/sbin/tcpdump
+ fperms 4110 /usr/sbin/tcpdump
+ fi
+}
+
+pkg_preinst() {
+ if use drop-root || use suid; then
+ enewgroup tcpdump
+ enewuser tcpdump -1 -1 -1 tcpdump
+ fi
+}
+
+pkg_postinst() {
+ use suid && elog "To let normal users run tcpdump add them into tcpdump group."
+}