summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Quinn <code@danielquinn.org>2015-12-16 15:37:08 +0000
committerDaniel Quinn <code@danielquinn.org>2015-12-17 01:11:35 +0000
commit9f6c17070484a72f17b2bed39dec36c06c0e918c (patch)
treec3d06aa9b2c3a2883c27d5c141df8b2be2618ce4 /net-analyzer
parentsys-kernel/hardened-sources: version bump to 4.3.3 (diff)
downloadgentoo-9f6c17070484a72f17b2bed39dec36c06c0e918c.tar.gz
gentoo-9f6c17070484a72f17b2bed39dec36c06c0e918c.tar.bz2
gentoo-9f6c17070484a72f17b2bed39dec36c06c0e918c.zip
net-analyzer/ripe-atlas-tools: Initial commit
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ripe-atlas-tools/Manifest2
-rw-r--r--net-analyzer/ripe-atlas-tools/metadata.xml10
-rw-r--r--net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.1.ebuild47
3 files changed, 59 insertions, 0 deletions
diff --git a/net-analyzer/ripe-atlas-tools/Manifest b/net-analyzer/ripe-atlas-tools/Manifest
new file mode 100644
index 000000000000..b8599760fc7e
--- /dev/null
+++ b/net-analyzer/ripe-atlas-tools/Manifest
@@ -0,0 +1,2 @@
+DIST ripe.atlas.tools-1.2.1.tar.gz 83916 SHA256 3f4d385ffa9bfb9cc04121dc109807f85d1291db4705529ff83da44847856665 SHA512 4c91d14f15e80e7e0ce4d6973e497bb48561314434d1521437311fb813197da7ba0a3e27f14cebe5a71d75baba37d2e5045b94d9e39699ef4a4e57aafb063ea7 WHIRLPOOL 7e5c2d30407191b18c7e4d4418fcb64c386ca9525a2b8224d5290c4fab1e458686d86a00cac7b7bbd70d1d0688e44e76bd563e2589c8aba204ac8165ef10fc0c
+EBUILD ripe-atlas-tools-1.2.1.ebuild 1277 SHA256 4734ec06ada6c5605dce4366129f29a647d53332d606da4e5883b11a93aeb270 SHA512 b24356a67c1aadb40e2b25f94ced2858b4b6a0f7896dbf411cb85bdb6ee11aba365ede9e2cc64c4c6c4a4631906307c99ed106302439640b01882840bab8cb61 WHIRLPOOL 9c159873251231b480de54b1356216cec6aaac560e1abf301c99c56f22a645c835c8735455da7cd94224298a6a8c221fb10ba6938850f3d6a79766d84c402f00
diff --git a/net-analyzer/ripe-atlas-tools/metadata.xml b/net-analyzer/ripe-atlas-tools/metadata.xml
new file mode 100644
index 000000000000..46c572635b0b
--- /dev/null
+++ b/net-analyzer/ripe-atlas-tools/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>gentoo@danielquinn.org</email>
+ <name>Daniel Quinn</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.1.ebuild b/net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.1.ebuild
new file mode 100644
index 000000000000..de5991c67a3f
--- /dev/null
+++ b/net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+MY_PN=${PN//-/.}
+DESCRIPTION="The official command-line client for RIPE Atlas"
+HOMEPAGE="https://atlas.ripe.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/ripe.atlas.tools/ripe.atlas.tools-${PVR}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S="${WORKDIR}/${MY_PN}-${PVR}"
+
+RDEPEND="
+ >=net-libs/ripe-atlas-sagan-1.1.8[${PYTHON_USEDEP}]
+ >=www-client/ripe-atlas-cousteau-1.0.6[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ "${RDEPEND}"
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
+
+python_test() {
+ nosetests --verbose || die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+ echo "RIPE Atlas Tools (Magellan) [Gentoo Linux] ${PVR}" > \
+ ${D}$(python_get_sitedir)/ripe/atlas/tools/user-agent
+} \ No newline at end of file