summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-06-23 19:13:21 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-06-23 19:15:08 -0500
commiteff2131ce92483e3e3367ac2bdafc390334664ca (patch)
tree9e035a8aa99be74f0c03ff86238b5ff6ac248e50 /net-analyzer
parentdev-python/cachetools: 3.1.0 stable amd64/x86 with cleanup (diff)
downloadgentoo-eff2131ce92483e3e3367ac2bdafc390334664ca.tar.gz
gentoo-eff2131ce92483e3e3367ac2bdafc390334664ca.tar.bz2
gentoo-eff2131ce92483e3e3367ac2bdafc390334664ca.zip
net-analyzer/icinga2: 2.10.5 stable with cleanup
Package-Manager: Portage-2.3.66, Repoman-2.3.15 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/icinga2/Manifest2
-rw-r--r--net-analyzer/icinga2/icinga2-2.10.4.ebuild172
-rw-r--r--net-analyzer/icinga2/icinga2-2.10.5.ebuild2
-rw-r--r--net-analyzer/icinga2/icinga2-2.8.4.ebuild176
-rw-r--r--net-analyzer/icinga2/metadata.xml1
5 files changed, 1 insertions, 352 deletions
diff --git a/net-analyzer/icinga2/Manifest b/net-analyzer/icinga2/Manifest
index c9cf2e377c6d..180268e443c9 100644
--- a/net-analyzer/icinga2/Manifest
+++ b/net-analyzer/icinga2/Manifest
@@ -1,3 +1 @@
-DIST icinga2-2.10.4.tar.gz 5129248 BLAKE2B 420330cfdbecce98e9b825527c38d4606c0f3e3a74c6798b7012dae2c4ebc583317e60a91c7966d68de17359b6af676f5accd71d0fece505a17a3ca92f00e05e SHA512 7277dd315541341ee68f2e83035210c233d6556d36c26d3211b85e2d43759627c73e881edac8e5e1d266c6b1eef19c5e1eeb8e5a77a237e688039ba88a58438c
DIST icinga2-2.10.5.tar.gz 5141193 BLAKE2B 7262e9f0ccb2180faba51b2e04b58964fe6c72782ab61488925c0f6528a80fc1f58afab5f3858f6f696fdca7c8d5546beb8fd374f7f72e452ffd7cd1f1e3ff4a SHA512 c43443d0bbb4ec997d3c5405ef3019ae3b09131bcce2e9d7c7b0e187768335a2f1347fdd382655f12a28b3a29ec8bf644c1b610ea5157f3ee40ae5e0e9253d38
-DIST icinga2-2.8.4.tar.gz 2510333 BLAKE2B f551a5eadc93d8455612af40e34a0922bc75f41b8064f9989c8f0c28dc2c3fb18963cf9b3272efa29f03973e7cf5824762bebff1bfa1a23c4ba39c93fc29c8e5 SHA512 b2cb5989962ac65da927cbdbac1b3345c913321d507b5113f32dd90bf969b2513478e68d52b9cd4cf255057d74428f9e42067288b7ddc59ad060ca7b84f4f114
diff --git a/net-analyzer/icinga2/icinga2-2.10.4.ebuild b/net-analyzer/icinga2/icinga2-2.10.4.ebuild
deleted file mode 100644
index 45914f5d789b..000000000000
--- a/net-analyzer/icinga2/icinga2-2.10.4.ebuild
+++ /dev/null
@@ -1,172 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-if [[ ${PV} != 9999 ]]; then
- inherit cmake-utils depend.apache eutils systemd toolchain-funcs user wxwidgets
- SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
-else
- inherit cmake-utils depend.apache eutils git-r3 systemd toolchain-funcs user wxwidgets
- EGIT_REPO_URI="https://github.com/Icinga/icinga2.git"
- EGIT_BRANCH="master"
- KEYWORDS=""
-fi
-
-DESCRIPTION="Distributed, general purpose, network monitoring engine"
-HOMEPAGE="http://icinga.org/icinga2"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="classicui console libressl lto mail mariadb minimal +mysql nano-syntax +plugins postgres systemd +vim-syntax"
-WX_GTK_VER="3.0"
-
-CDEPEND="
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- >=dev-libs/boost-1.58-r1
- console? ( dev-libs/libedit )
- mariadb? ( dev-db/mariadb-connector-c:= )
- mysql? ( dev-db/mysql-connector-c:= )
- postgres? ( dev-db/postgresql:= )
- dev-libs/yajl"
-
-DEPEND="
- ${CDEPEND}
- sys-devel/bison
- >=sys-devel/flex-2.5.35"
-
-RDEPEND="
- ${CDEPEND}
- plugins? ( || (
- net-analyzer/monitoring-plugins
- net-analyzer/nagios-plugins
- ) )
- mail? ( virtual/mailx )
- classicui? ( net-analyzer/icinga[web] )"
-
-REQUIRED_USE="!minimal? ( || ( mariadb mysql postgres ) )"
-
-want_apache2
-
-pkg_setup() {
- depend.apache_pkg_setup
- enewgroup icinga
- enewgroup icingacmd
- enewgroup nagios # for plugins
- enewuser icinga -1 -1 /var/lib/icinga2 "icinga,icingacmd,nagios"
-}
-
-src_configure() {
- sed -i 's/FLAGS\}\ \-g/FLAGS\}\ \-lpthread\ /g' CMakeLists.txt || die
- local mycmakeargs=(
- -DICINGA2_UNITY_BUILD=FALSE
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DCMAKE_BUILD_TYPE=None
- -DCMAKE_INSTALL_PREFIX=/usr
- -DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_LOCALSTATEDIR=/var
- -DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
- -DICINGA2_PLUGINDIR="/usr/$(get_libdir)/nagios/plugins"
- -DICINGA2_USER=icinga
- -DICINGA2_GROUP=icingacmd
- -DICINGA2_COMMAND_GROUP=icingacmd
- -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
- -DUSE_SYSTEMD=$(usex systemd ON OFF)
- -DLOGROTATE_HAS_SU=ON
- )
- # default to off if minimal, allow the flags to be set otherwise
- if use minimal; then
- mycmakeargs+=(
- -DICINGA2_WITH_MYSQL=OFF
- -DICINGA2_WITH_PGSQL=OFF
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_PGSQL=$(usex postgres ON OFF)
- -DICINGA2_WITH_MYSQL=$(usex mysql ON OFF)
- )
- fi
- # LTO
- if use lto; then
- mycmakeargs+=(
- -DICINGA2_LTO_BUILD=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_LTO_BUILD=OFF
- )
- fi
-
- cmake-utils_src_configure
-}
-
-src_install() {
- BUILDDIR="${WORKDIR}"/icinga2-${PV}_build
- cd "${BUILDDIR}" || die
-
- emake DESTDIR="${D}" install
-
- einstalldocs
-
- newinitd "${FILESDIR}"/icinga2.initd-3 icinga2
-
- if use mysql ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
- docinto schema/upgrade
- dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/upgrade/*
- fi
- if use mariadb ; then # same as mysql
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
- docinto schema/upgrade
- dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/upgrade/*
- fi
- if use postgres ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
- docinto schema/upgrade
- dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/upgrade/*
- fi
-
- keepdir /etc/icinga2
- keepdir /var/lib/icinga2/api/zones
- keepdir /var/lib/icinga2/api/repository
- keepdir /var/lib/icinga2/api/log
- keepdir /var/spool/icinga2/perfdata
-
- rm -r "${D}/var/run" || die "failed to remove /var/run"
- rm -r "${D}/var/cache" || die "failed to remove /var/cache"
-
- fowners root:icinga /etc/icinga2
- fperms 0750 /etc/icinga2
- fowners icinga:icinga /var/lib/icinga2
- fowners icinga:icinga /var/spool/icinga2
- fowners -R icinga:icingacmd /var/lib/icinga2/api
- fowners icinga:icinga /var/spool/icinga2/perfdata
- fowners icinga:icingacmd /var/log/icinga2
-
- fperms ug+rwX,o-rwx /etc/icinga2
- fperms ug+rwX,o-rwx /var/lib/icinga2
- fperms ug+rwX,o-rwx /var/spool/icinga2
- fperms ug+rwX,o-rwx /var/log/icinga2
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/ftdetect
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/syntax
- fi
-
- if use nano-syntax; then
- insinto /usr/share/nano
- doins "${WORKDIR}"/${P}/tools/syntax/nano/icinga2.nanorc
- fi
-}
-
-pkg_postinst() {
- if [[ ${PV} != 9999 && -n ${REPLACING_VERSIONS} && ${REPLACING_VERSIONS} != ${PV} ]]; then
- elog "DB IDO schema upgrade may be required required.
- https://www.icinga.com/docs/icinga2/latest/doc/16-upgrading-icinga-2/"
- fi
-}
diff --git a/net-analyzer/icinga2/icinga2-2.10.5.ebuild b/net-analyzer/icinga2/icinga2-2.10.5.ebuild
index 8a9695a5e27b..45914f5d789b 100644
--- a/net-analyzer/icinga2/icinga2-2.10.5.ebuild
+++ b/net-analyzer/icinga2/icinga2-2.10.5.ebuild
@@ -5,7 +5,7 @@ EAPI=6
if [[ ${PV} != 9999 ]]; then
inherit cmake-utils depend.apache eutils systemd toolchain-funcs user wxwidgets
SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
else
inherit cmake-utils depend.apache eutils git-r3 systemd toolchain-funcs user wxwidgets
EGIT_REPO_URI="https://github.com/Icinga/icinga2.git"
diff --git a/net-analyzer/icinga2/icinga2-2.8.4.ebuild b/net-analyzer/icinga2/icinga2-2.8.4.ebuild
deleted file mode 100644
index 525aa185b124..000000000000
--- a/net-analyzer/icinga2/icinga2-2.8.4.ebuild
+++ /dev/null
@@ -1,176 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-if [[ ${PV} != 9999 ]]; then
- inherit cmake-utils depend.apache eutils systemd toolchain-funcs user wxwidgets
- SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 x86"
-else
- inherit cmake-utils depend.apache eutils git-r3 systemd toolchain-funcs user wxwidgets
- EGIT_REPO_URI="https://github.com/Icinga/icinga2.git"
- EGIT_BRANCH="master"
- KEYWORDS=""
-fi
-
-DESCRIPTION="Distributed, general purpose, network monitoring engine"
-HOMEPAGE="http://icinga.org/icinga2"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+mysql postgres classicui console libressl lto mail minimal nano-syntax +plugins studio +vim-syntax"
-WX_GTK_VER="3.0"
-
-CDEPEND="
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- >=dev-libs/boost-1.58-r1
- console? ( dev-libs/libedit )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql:= )"
-
-DEPEND="
- ${CDEPEND}
- sys-devel/bison
- >=sys-devel/flex-2.5.35"
-
-RDEPEND="
- ${CDEPEND}
- plugins? ( || (
- net-analyzer/monitoring-plugins
- net-analyzer/nagios-plugins
- ) )
- mail? ( virtual/mailx )
- classicui? ( net-analyzer/icinga[web] )
- studio? ( x11-libs/wxGTK:3.0 )"
-
-REQUIRED_USE="!minimal? ( || ( mysql postgres ) )"
-
-want_apache2
-
-pkg_setup() {
- depend.apache_pkg_setup
- if use studio ; then
- setup-wxwidgets
- fi
- enewgroup icinga
- enewgroup icingacmd
- enewgroup nagios # for plugins
- enewuser icinga -1 -1 /var/lib/icinga2 "icinga,icingacmd,nagios"
-}
-
-src_configure() {
- sed -i 's/FLAGS\}\ \-g/FLAGS\}\ \-lpthread\ /g' CMakeLists.txt || die
- local mycmakeargs=(
- -DICINGA2_UNITY_BUILD=FALSE
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DCMAKE_BUILD_TYPE=None
- -DCMAKE_INSTALL_PREFIX=/usr
- -DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_LOCALSTATEDIR=/var
- -DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
- -DICINGA2_PLUGINDIR="/usr/$(get_libdir)/nagios/plugins"
- -DICINGA2_USER=icinga
- -DICINGA2_GROUP=icingacmd
- -DICINGA2_COMMAND_GROUP=icingacmd
- -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
- -DLOGROTATE_HAS_SU=ON
- )
- # default to off if minimal, allow the flags to be set otherwise
- if use minimal; then
- mycmakeargs+=(
- -DICINGA2_WITH_MYSQL=OFF
- -DICINGA2_WITH_PGSQL=OFF
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_PGSQL=$(usex postgres ON OFF)
- -DICINGA2_WITH_MYSQL=$(usex mysql ON OFF)
- )
- fi
- # LTO
- if use lto; then
- mycmakeargs+=(
- -DICINGA2_LTO_BUILD=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_LTO_BUILD=OFF
- )
- fi
- # STUDIO
- if use studio; then
- mycmakeargs+=(
- -DICINGA2_WITH_STUDIO=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_STUDIO=OFF
- )
- fi
-
- cmake-utils_src_configure
-}
-
-src_install() {
- BUILDDIR="${WORKDIR}"/icinga2-${PV}_build
- cd "${BUILDDIR}" || die
-
- emake DESTDIR="${D}" install
-
- einstalldocs
-
- newinitd "${FILESDIR}"/icinga2.initd icinga2
-
- if use mysql ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
- docinto schema/upgrade
- dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/upgrade/*
- elif use postgres ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
- docinto schema/upgrade
- dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/upgrade/*
- fi
-
- keepdir /etc/icinga2
- keepdir /var/lib/icinga2/api/zones
- keepdir /var/lib/icinga2/api/repository
- keepdir /var/lib/icinga2/api/log
- keepdir /var/spool/icinga2/perfdata
-
- rm -r "${D}/var/run" || die "failed to remove /var/run"
- rm -r "${D}/var/cache" || die "failed to remove /var/cache"
-
- fowners root:icinga /etc/icinga2
- fperms 0750 /etc/icinga2
- fowners icinga:icinga /var/lib/icinga2
- fowners icinga:icinga /var/spool/icinga2
- fowners -R icinga:icingacmd /var/lib/icinga2/api
- fowners icinga:icinga /var/spool/icinga2/perfdata
- fowners icinga:icingacmd /var/log/icinga2
-
- fperms ug+rwX,o-rwx /etc/icinga2
- fperms ug+rwX,o-rwx /var/lib/icinga2
- fperms ug+rwX,o-rwx /var/spool/icinga2
- fperms ug+rwX,o-rwx /var/log/icinga2
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/ftdetect
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/syntax
- fi
-
- if use nano-syntax; then
- insinto /usr/share/nano
- doins "${WORKDIR}"/${P}/tools/syntax/nano/icinga2.nanorc
- fi
-}
-
-pkg_postinst() {
- if [[ ${PV} != 9999 && -n ${REPLACING_VERSIONS} && ${REPLACING_VERSIONS} != ${PV} ]]; then
- elog "DB IDO schema upgrade may be required required.
- http://docs.icinga.org/icinga2/snapshot/doc/module/icinga2/chapter/upgrading-icinga-2"
- fi
-}
diff --git a/net-analyzer/icinga2/metadata.xml b/net-analyzer/icinga2/metadata.xml
index 73dade688729..6c4dccde701d 100644
--- a/net-analyzer/icinga2/metadata.xml
+++ b/net-analyzer/icinga2/metadata.xml
@@ -11,7 +11,6 @@
<flag name="lto">Adds support for link time optimization</flag>
<flag name="mail">Allows for mailing of alerts</flag>
<flag name="mariadb">Enable support for the mariadb database backend</flag>
- <flag name="studio">Adds support for Icinga-studio</flag>
<flag name="nano-syntax">Adds support for syntax used in the nano editor</flag>
<flag name="plugins">Adds support for nagios plugins</flag>
</use>