summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dialup/cistronradius
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dialup/cistronradius')
-rw-r--r--net-dialup/cistronradius/Manifest1
-rw-r--r--net-dialup/cistronradius/cistronradius-1.6.8-r1.ebuild49
-rw-r--r--net-dialup/cistronradius/files/cistronradius-1.6.8-gcc41.patch11
-rw-r--r--net-dialup/cistronradius/files/cistronradius.rc35
-rw-r--r--net-dialup/cistronradius/metadata.xml8
5 files changed, 104 insertions, 0 deletions
diff --git a/net-dialup/cistronradius/Manifest b/net-dialup/cistronradius/Manifest
new file mode 100644
index 000000000000..4938a6e55d69
--- /dev/null
+++ b/net-dialup/cistronradius/Manifest
@@ -0,0 +1 @@
+DIST radiusd-cistron-1.6.8.tar.gz 199459 SHA256 ed08ff8fb3f49ac5a921c2e23b639e9b87db85e3e6105953c5a921b9a2cc6150
diff --git a/net-dialup/cistronradius/cistronradius-1.6.8-r1.ebuild b/net-dialup/cistronradius/cistronradius-1.6.8-r1.ebuild
new file mode 100644
index 000000000000..01de59512f8f
--- /dev/null
+++ b/net-dialup/cistronradius/cistronradius-1.6.8-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Authentication and accounting server for terminal servers that speak the RADIUS protocol"
+HOMEPAGE="http://www.radius.cistron.nl/"
+SRC_URI="ftp://ftp.radius.cistron.nl/pub/radius/radiusd-cistron-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86"
+
+DEPEND="
+ !net-dialup/freeradius
+ !net-dialup/gnuradius"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/radiusd-cistron-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc41.patch"
+ sed -i -e "s:SHAREDIR/::g" raddb/dictionary || die
+ mv src/checkrad.pl src/checkrad || die
+
+ epatch_user
+}
+
+src_compile() {
+ emake -C src \
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ BINDIR=/usr/bin SBINDIR=/usr/sbin \
+ MANDIR=/usr/share/man SHAREDIR=/usr/share/radius
+}
+
+src_install() {
+ insinto /etc/raddb
+ doins raddb/*
+ dodoc README doc/{ChangeLog,FAQ.txt,README*}
+ doman doc/{*.1,*.8,*.5rad,*.8rad}
+
+ dosbin src/{checkrad,radiusd,radrelay}
+ dobin src/{radclient,radlast,radtest,radwho,radzap}
+
+ newinitd "${FILESDIR}/cistronradius.rc" cistronradius
+}
diff --git a/net-dialup/cistronradius/files/cistronradius-1.6.8-gcc41.patch b/net-dialup/cistronradius/files/cistronradius-1.6.8-gcc41.patch
new file mode 100644
index 000000000000..7600df739c7b
--- /dev/null
+++ b/net-dialup/cistronradius/files/cistronradius-1.6.8-gcc41.patch
@@ -0,0 +1,11 @@
+diff -Nru radiusd-cistron-1.6.8.orig/src/radiusd.h radiusd-cistron-1.6.8/src/radiusd.h
+--- radiusd-cistron-1.6.8.orig/src/radiusd.h 2003-12-08 18:12:22.000000000 +0200
++++ radiusd-cistron-1.6.8/src/radiusd.h 2006-09-21 15:33:05.000000000 +0300
+@@ -204,7 +204,6 @@
+ extern char *radwtmp_path;
+ extern UINT4 expiration_seconds;
+ extern UINT4 warning_seconds;
+-extern int radius_pid;
+ extern int use_dbm;
+ extern int use_dns;
+ extern int use_wtmp;
diff --git a/net-dialup/cistronradius/files/cistronradius.rc b/net-dialup/cistronradius/files/cistronradius.rc
new file mode 100644
index 000000000000..cc4b7d3deb9e
--- /dev/null
+++ b/net-dialup/cistronradius/files/cistronradius.rc
@@ -0,0 +1,35 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -x /usr/sbin/radiusd ] ; then
+ eerror "The radius daemon was not found."
+ eerror "Please (re)emerge cistronradius."
+ return 1
+ fi
+
+ if [ ! -e /etc/raddb/clients ] ; then
+ eerror "No /etc/raddb/clients file found."
+ eerror "Please create the file and retry."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting Cistron Radius"
+ start-stop-daemon --start --quiet --exec /usr/sbin/radiusd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Cistron Radius"
+ start-stop-daemon --stop --quiet --pidfile /var/run/radiusd.pid
+ eend $?
+}
diff --git a/net-dialup/cistronradius/metadata.xml b/net-dialup/cistronradius/metadata.xml
new file mode 100644
index 000000000000..1930bc3c4e14
--- /dev/null
+++ b/net-dialup/cistronradius/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-dialup</herd>
+<longdescription>
+An authentication and accounting server for terminal servers that speak the RADIUS protocol.
+</longdescription>
+</pkgmetadata>