summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-28 16:19:33 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-28 16:59:32 -0500
commit15b2f7e60003b468a57af486278c7a396b9ca4a2 (patch)
tree377a6c37101b6efd5c227a6f1b4c8c87ca6435e2 /net-dialup
parentnet-dialup/diald: use #!/sbin/openrc-run instead of #!/sbin/runscript (diff)
downloadgentoo-15b2f7e60003b468a57af486278c7a396b9ca4a2.tar.gz
gentoo-15b2f7e60003b468a57af486278c7a396b9ca4a2.tar.bz2
gentoo-15b2f7e60003b468a57af486278c7a396b9ca4a2.zip
net-dialup/dwun: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/dwun/dwun-0.96e-r4.ebuild46
-rw-r--r--net-dialup/dwun/files/dwun4
2 files changed, 48 insertions, 2 deletions
diff --git a/net-dialup/dwun/dwun-0.96e-r4.ebuild b/net-dialup/dwun/dwun-0.96e-r4.ebuild
new file mode 100644
index 000000000000..60b23b928e59
--- /dev/null
+++ b/net-dialup/dwun/dwun-0.96e-r4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Dialer Without a Useful Name (DWUN)"
+HOMEPAGE="http://dwun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT GPL-2" # GPL-2 only for init script
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( AUTHORS ChangeLog QUICKSTART README TODO UPGRADING )
+
+src_prepare() {
+ sed -i -e "s:TODO QUICKSTART README UPGRADING ChangeLog COPYING AUTHORS::" Makefile.in || die
+ tc-export CC
+
+ eapply_user
+}
+
+src_configure() {
+ econf --with-docdir="share/doc/${PF}"
+}
+
+src_install() {
+ default
+
+ insinto /etc
+ newins doc/examples/complete-rcfile dwunrc
+ newins debian/dwunauth dwunauth
+ newinitd "${FILESDIR}/dwun" dwun
+}
+
+pkg_postinst() {
+ elog
+ elog 'Make sure you have "net-dialup/ppp" merged if you intend to use dwun'
+ elog "to control a standard PPP network link."
+ elog "See /usr/share/doc/${P}/QUICKSTART for instructions on"
+ elog "configuring dwun."
+ elog
+}
diff --git a/net-dialup/dwun/files/dwun b/net-dialup/dwun/files/dwun
index a645220c7e1d..d076f9e80a1a 100644
--- a/net-dialup/dwun/files/dwun
+++ b/net-dialup/dwun/files/dwun
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2014 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$