summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-06-13 10:48:11 -0500
committerBen Kohler <bkohler@gentoo.org>2020-06-13 10:49:10 -0500
commit9ec59139b0c16f9fa85fdfcfcb59b41514182066 (patch)
treee663f318b56d9e088a055f29f4c42a6234f5f155 /net-dialup
parentsys-kernel/zen-sources: Version bump 5.6.15 (diff)
downloadgentoo-9ec59139b0c16f9fa85fdfcfcb59b41514182066.tar.gz
gentoo-9ec59139b0c16f9fa85fdfcfcb59b41514182066.tar.bz2
gentoo-9ec59139b0c16f9fa85fdfcfcb59b41514182066.zip
net-dialup/cutecom: revbump for qt-5.15.0 fix, xdg icon fix
Closes: https://bugs.gentoo.org/727614 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/cutecom/cutecom-0.51.0-r1.ebuild42
-rw-r--r--net-dialup/cutecom/files/cutecom-0.51.0-fix-for-qt-5.15.0.patch24
2 files changed, 66 insertions, 0 deletions
diff --git a/net-dialup/cutecom/cutecom-0.51.0-r1.ebuild b/net-dialup/cutecom/cutecom-0.51.0-r1.ebuild
new file mode 100644
index 000000000000..96ceaa41d2cb
--- /dev/null
+++ b/net-dialup/cutecom/cutecom-0.51.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eutils xdg
+
+DESCRIPTION="CuteCom is a serial terminal, like minicom, written in qt"
+HOMEPAGE="https://gitlab.com/cutecom/cutecom"
+SRC_URI="https://gitlab.com/cutecom/cutecom/-/archive/v${PV}/cutecom-v${PV}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtserialport:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${DEPEND}
+ net-dialup/lrzsz"
+
+S="${WORKDIR}/cutecom-v${PV}"
+
+PATCHES=( "${FILESDIR}"/cutecom-0.51.0-fix-for-qt-5.15.0.patch )
+
+src_prepare() {
+ sed -i \
+ -e '/Path/d' \
+ -e '/Terminal/s/0/false/' \
+ "${PN}.desktop" || die 'sed on desktop file failed'
+
+ cmake-utils_src_prepare
+}
+
+src_install() {
+ cmake-utils_src_install
+ domenu "${PN}.desktop"
+ doicon "distribution/${PN}.png"
+}
diff --git a/net-dialup/cutecom/files/cutecom-0.51.0-fix-for-qt-5.15.0.patch b/net-dialup/cutecom/files/cutecom-0.51.0-fix-for-qt-5.15.0.patch
new file mode 100644
index 000000000000..c06ae9a9eebb
--- /dev/null
+++ b/net-dialup/cutecom/files/cutecom-0.51.0-fix-for-qt-5.15.0.patch
@@ -0,0 +1,24 @@
+From 70d0c497acf8f298374052b2956bcf142ed5f6ca Mon Sep 17 00:00:00 2001
+From: Meinhard R <cyc1ingsir@gmail.com>
+Date: Thu, 11 Jun 2020 18:33:10 +0000
+Subject: [PATCH] Fix-build-with-Qt-5.15 (hopefully)
+
+---
+ ctrlcharacterspopup.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/ctrlcharacterspopup.cpp b/ctrlcharacterspopup.cpp
+index 632ae32..f37a8d4 100644
+--- a/ctrlcharacterspopup.cpp
++++ b/ctrlcharacterspopup.cpp
+@@ -23,6 +23,7 @@
+ #include <QApplication>
+ #include <QKeyEvent>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QPoint>
+ #include <QPushButton>
+ #include <QSignalMapper>
+--
+GitLab
+