summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2020-07-01 21:44:31 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2020-07-01 21:45:21 +0200
commit0279498e10fabd402b4d3944e4847ace595de0b5 (patch)
tree51a409fd9160164fc38652c33823fede233dfb63 /net-dns/maradns
parentacct-user/duende: added (diff)
downloadgentoo-0279498e10fabd402b4d3944e4847ace595de0b5.tar.gz
gentoo-0279498e10fabd402b4d3944e4847ace595de0b5.tar.bz2
gentoo-0279498e10fabd402b4d3944e4847ace595de0b5.zip
net-dns/maradns: 3.5.0005 version bump
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'net-dns/maradns')
-rw-r--r--net-dns/maradns/Manifest1
-rw-r--r--net-dns/maradns/maradns-3.5.0005.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/net-dns/maradns/Manifest b/net-dns/maradns/Manifest
index b99875ce9713..26b66e10cf27 100644
--- a/net-dns/maradns/Manifest
+++ b/net-dns/maradns/Manifest
@@ -1,3 +1,4 @@
DIST maradns-2.0.09.tar.bz2 1139409 BLAKE2B 8c3709241b85f9069eb4e18098f7753b19bcc87d32bbb36aef42cb8ec123dc73b8e29e79b5efe1083035b2378a484e2c00038700647d5e75f469589b37b351e2 SHA512 42bfcafaf4e465d8d566b4d9ea8383b5d0f553486b86dd807b35a07358987227e5dc8187de0e8192fba5b53098d61f91091cec112ef7cc80c5d5e73d8acff3bf
DIST maradns-2.0.14.tar.bz2 1156272 BLAKE2B 7e96d0769dd1df70316cc1bd79fb7e902c723f78db035fe721aaab0d6902958a40c2743374824ae024759164ad9cbda9a3c6ecaec7cc6bf3c5fa7b384101c16f SHA512 57527bba2f9801904f59cc7d9e56cbd7124635841ad8c91cbd3d1b8d58e7fe38d509e19f6ea53e2790777e054b68bb8df02bfa820ba7c9dbe65262e1993a2aa4
DIST maradns-2.0.16.tar.bz2 1127504 BLAKE2B 142166370efed2d52c0a1e659bf0056f8d13cc5eca3c1d30c0278b81047aa58ce6c6f3f8496e982841b9dcd541ffd2c24467b8062aa5a7ffb1f31ef6cf841a15 SHA512 9959a7b6724aff5561fa9303b3d7c967e298fd63d95ef7e34d80514dde8871c19887c184a6466779f2833c295233dd1d54a7c06928ac58dcbb374281deb13f17
+DIST maradns-3.5.0005.tar.xz 5351412 BLAKE2B c6b1c4fb93cb507045b3c09574d7ce30b0af92301e157216b4a5bbd2ed74ceb829ef4d11cd08048c7a685a09cdd4178cf3fc4e7b2465820d26d3a5c1b96f4a5e SHA512 2e7008ff6217929008292dde60d96eb2ec0499a170e1b5bda5fcfb27300d2ce6cecd8b3e2a2d4b09ff32b803f9f435230378e6b2e41e7b63c42653d8c931151d
diff --git a/net-dns/maradns/maradns-3.5.0005.ebuild b/net-dns/maradns/maradns-3.5.0005.ebuild
new file mode 100644
index 000000000000..049cb0ac80e3
--- /dev/null
+++ b/net-dns/maradns/maradns-3.5.0005.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit systemd toolchain-funcs python-any-r1
+
+DESCRIPTION="A security-aware DNS server"
+HOMEPAGE="http://www.maradns.org/"
+SRC_URI="https://maradns.samiam.org/download/${PV%.*}/${PV}/${P}.tar.xz"
+
+# The GPL-2 covers the init script, bug 426018.
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE="examples ipv6"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ acct-user/maradns
+ acct-group/maradns
+ acct-user/duende
+ dev-lang/perl"
+
+src_prepare() {
+ default
+
+ # replace "make" by "$(MAKE)" to avoid GNU Make warning
+ sed -i 's/\ make\ /\ \$\(MAKE\)\ /g' build/Makefile.linux \
+ || die "can't patch build/Makefile.linux"
+
+ python_fix_shebang tools/bind2csv2.py
+}
+
+src_configure() {
+ tc-export CC
+ ./configure $(use ipv6 && echo "--ipv6") || die "Failed to configure ${PN}"
+}
+
+src_install() {
+ # Install the MaraDNS and Deadwood binaries
+ dosbin server/maradns
+ dosbin tcp/zoneserver
+ dosbin deadwood-${PV}/src/Deadwood
+ dobin tcp/{getzone,fetchzone}
+ dobin tools/{askmara,askmara-tcp,duende,bind2csv2.py,csv1tocsv2.pl}
+
+ # MaraDNS docs, manpages, misc
+ dodoc doc/en/{QuickStart,README,*.txt,*.html}
+ dodoc -r doc/en/{text,webpage,tutorial}
+ dodoc maradns.gpg.key
+ docinto deadwood
+ dodoc deadwood-${PV}/doc/{*.txt,*.html,CHANGELOG,Deadwood-HOWTO}
+ dodoc -r deadwood-${PV}/doc/internals
+
+ # Install examples (optional)
+ if use examples ; then
+ docinto examples
+ dodoc doc/en/examples/example_*
+ fi
+
+ # Install manpages
+ doman doc/en/man/*.[1-9]
+ doman deadwood-${PV}/doc/{Deadwood,Duende}.1
+
+ # Example configurations.
+ insinto /etc/maradns
+ newins doc/en/examples/example_full_mararc mararc_full.dist
+ newins doc/en/examples/example_csv2 example_csv2.dist
+ newins deadwood-${PV}/doc/dwood3rc-all dwood3rc_all.dist
+ keepdir /etc/maradns/logger
+
+ # Init scripts.
+ newinitd "${FILESDIR}"/maradns2 maradns
+ newinitd "${FILESDIR}"/zoneserver2 zoneserver
+ newinitd "${FILESDIR}"/deadwood deadwood
+
+ # systemd unit
+ # please keep paths in sync!
+ sed -e "s^@bindir@^${EPREFIX}/usr/sbin^" \
+ -e "s^@sysconfdir@^${EPREFIX}/etc/maradns^" \
+ "${FILESDIR}"/maradns.service.in > "${T}"/maradns.service \
+ || die "failed to create the maradns.service file (sed)"
+
+ systemd_dounit "${T}"/maradns.service
+}