summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dns/namecoind/files/namecoind-0.3.72-makefile.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dns/namecoind/files/namecoind-0.3.72-makefile.patch')
-rw-r--r--net-dns/namecoind/files/namecoind-0.3.72-makefile.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-dns/namecoind/files/namecoind-0.3.72-makefile.patch b/net-dns/namecoind/files/namecoind-0.3.72-makefile.patch
new file mode 100644
index 000000000000..f8996944e13c
--- /dev/null
+++ b/net-dns/namecoind/files/namecoind-0.3.72-makefile.patch
@@ -0,0 +1,52 @@
+diff -Naur namecoinq-vQ.3.72.orig/src/Makefile namecoinq-vQ.3.72/src/Makefile
+--- namecoinq-vQ.3.72.orig/src/Makefile 2013-10-29 09:38:10.000000000 -0400
++++ namecoinq-vQ.3.72/src/Makefile 2013-11-30 18:43:25.016028725 -0500
+@@ -1,6 +1,6 @@
+-CXX=g++
++CXX?=g++
+
+-DEFS=-D_MT -DNOPCH -DFOURWAYSSE2 -DUSE_SSL
++DEFS=-D_MT -DNOPCH -DFOURWAYSSE2 -DUSE_SSL
+
+ # Detect MinGW
+ MINGW=$(shell uname -s|grep -i mingw32)
+@@ -8,20 +8,10 @@
+ # Link boost statically
+ DEFS += -DBOOST_THREAD_USE_LIB
+
+-INCLUDEPATHS= \
+- -I../libs/openssl-1.0.1e/include \
+- -I../libs/db-4.7.25.NC/build_unix \
+- -I../libs/boost_1_50_0
+-
+-LIBPATHS= \
+- -L../libs/openssl-1.0.1e \
+- -L../libs/db-4.7.25.NC/build_unix \
+- -L../libs/boost_1_50_0/stage/lib
+-
+ LIBBOOST_SUFFIX=
+
+ LIBS= \
+- -Wl,-Bstatic \
++ -Wl,-Bdynamic \
+ -l boost_system$(LIBBOOST_SUFFIX) \
+ -l boost_filesystem$(LIBBOOST_SUFFIX) \
+ -l boost_program_options$(LIBBOOST_SUFFIX) \
+@@ -70,7 +60,7 @@
+ -l pthread
+ endif
+
+-CXXFLAGS=-O2 -Wno-invalid-offsetof -Wformat $(DEFS) $(INCLUDEPATHS)
++#CXXFLAGS=-O2 -Wno-invalid-offsetof -Wformat $(DEFS) $(INCLUDEPATHS)
+ HEADERS=headers.h strlcpy.h serialize.h uint256.h util.h key.h bignum.h base58.h \
+ script.h allocators.h db.h walletdb.h crypter.h net.h irc.h keystore.h main.h wallet.h bitcoinrpc.h uibase.h ui.h noui.h init.h auxpow.h
+
+@@ -110,7 +100,7 @@
+ obj/nogui/namecoin.o: namecoin.h
+
+ namecoind: $(OBJS:obj/%=obj/nogui/%) obj/nogui/namecoin.o
+- $(CXX) $(CXXFLAGS) -o $@ $(LIBPATHS) $^ $(LIBS)
++ $(CXX) $(CXXFLAGS) -o $@ $^ $(LDFLAGS) $(LIBS)
+
+ clean:
+ -rm -f namecoin namecoind