summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dns/totd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dns/totd')
-rw-r--r--net-dns/totd/Manifest1
-rwxr-xr-xnet-dns/totd/files/totd39
-rw-r--r--net-dns/totd/files/totd-1.5.1-no_werror.patch11
-rw-r--r--net-dns/totd/metadata.xml13
-rw-r--r--net-dns/totd/totd-1.5.1.ebuild46
5 files changed, 110 insertions, 0 deletions
diff --git a/net-dns/totd/Manifest b/net-dns/totd/Manifest
new file mode 100644
index 000000000000..69a16babd201
--- /dev/null
+++ b/net-dns/totd/Manifest
@@ -0,0 +1 @@
+DIST totd-1.5.1.tar.gz 235809 SHA256 1a09ef6dcf382beea3546eec3138eadfbaeec198a6f921c96e8937e91a1e06fa
diff --git a/net-dns/totd/files/totd b/net-dns/totd/files/totd
new file mode 100755
index 000000000000..b2ffcaa10007
--- /dev/null
+++ b/net-dns/totd/files/totd
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -f /etc/totd.conf ]
+ then
+ eerror "The config file /etc/totd.conf does not exist."
+ return 1
+ else
+ return 0
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting totd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/totd
+ eend $?
+}
+
+stop() {
+ local pid_file
+ pid_file="`grep ^pidfile /etc/totd.conf | cut -f2 -d ' '`"
+ ebegin "Stopping totd"
+ if [ -n "$pid_file" ]
+ then
+ start-stop-daemon --stop --quiet --pidfile $pid_file
+ else
+ start-stop-daemon --stop --quiet --pidfile /var/run/totd.pid
+ fi
+ eend $?
+}
diff --git a/net-dns/totd/files/totd-1.5.1-no_werror.patch b/net-dns/totd/files/totd-1.5.1-no_werror.patch
new file mode 100644
index 000000000000..246e709d5109
--- /dev/null
+++ b/net-dns/totd/files/totd-1.5.1-no_werror.patch
@@ -0,0 +1,11 @@
+--- totd-1.5.1/Makefile.in 2005-01-31 12:55:14.000000000 +0100
++++ totd-1.5.1_new/Makefile.in 2007-06-30 22:51:07.000000000 +0200
+@@ -19,7 +19,7 @@
+
+ INSTALL = /usr/bin/install
+
+-CFLAGS = @CFLAGS@ @DEFS@ -Werror -Wall -DTOTCONF=\"$(TOT_CONFIG_FILE)\" @OPTFLAGS@ $(INCLUDEPATH)
++CFLAGS = @CFLAGS@ @DEFS@ -Wall -DTOTCONF=\"$(TOT_CONFIG_FILE)\" @OPTFLAGS@ $(INCLUDEPATH)
+
+ # When debugging is enabled by --enable-malloc-debug flag to the configure
+ # script, the @DBMALLOC@ substitution will contain the empty string, thus
diff --git a/net-dns/totd/metadata.xml b/net-dns/totd/metadata.xml
new file mode 100644
index 000000000000..9ae02f6ed318
--- /dev/null
+++ b/net-dns/totd/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <longdescription lang="en">
+ Totd ( Trick Or Treat Daemon ) is a small DNS proxy nameserver that
+ supports IPv6 only hosts/networks that communicate with the IPv4 world
+ using some translation mechanism.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-dns/totd/totd-1.5.1.ebuild b/net-dns/totd/totd-1.5.1.ebuild
new file mode 100644
index 000000000000..e0ee9fea7fb9
--- /dev/null
+++ b/net-dns/totd/totd-1.5.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Trick Or Treat Daemon, a DNS proxy for 6to4"
+HOMEPAGE="http://www.dillema.net/software/totd.html"
+SRC_URI="http://www.dillema.net/software/${PN}/${P}.tar.gz"
+
+LICENSE="totd BSD BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no_werror.patch
+}
+
+src_configure() {
+ econf \
+ --enable-ipv4 \
+ --enable-ipv6 \
+ --enable-stf \
+ --enable-scoped-rewrite \
+ --disable-http-server
+}
+
+src_install() {
+ dosbin totd
+ doman totd.8
+ dodoc totd.conf.sample README INSTALL
+
+ doinitd "${FILESDIR}"/totd
+}
+
+pkg_postinst() {
+ elog "The totd.conf.sample file in /usr/share/doc/${P}/ contains"
+ elog "a sample config file for totd. Make sure you create"
+ elog "/etc/totd.conf with the necessary configurations"
+}