summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-01-07 15:20:43 +0100
committerUlrich Müller <ulm@gentoo.org>2018-01-07 15:33:08 +0100
commit7d223f93fd4194cee5ce05fbb0e556b1710c1073 (patch)
treee5bf64602f122c311da134eef83f451fbc4bf16e /net-dns
parentprofiles/package.mask: drop obsolete mask on net-im (aol) messagers (diff)
downloadgentoo-7d223f93fd4194cee5ce05fbb0e556b1710c1073.tar.gz
gentoo-7d223f93fd4194cee5ce05fbb0e556b1710c1073.tar.bz2
gentoo-7d223f93fd4194cee5ce05fbb0e556b1710c1073.zip
net-dns/dnsmasq: Test LINGUAS rather than linguas_* USE flags.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.76-r1.ebuild8
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.76.ebuild8
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.77-r1.ebuild9
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.77.ebuild9
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.78.ebuild9
5 files changed, 15 insertions, 28 deletions
diff --git a/net-dns/dnsmasq/dnsmasq-2.76-r1.ebuild b/net-dns/dnsmasq/dnsmasq-2.76-r1.ebuild
index 27f157cd660e..95de5790dac2 100644
--- a/net-dns/dnsmasq/dnsmasq-2.76-r1.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.76-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,9 +14,6 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE="auth-dns conntrack dbus +dhcp dhcp-tools dnssec idn +inotify ipv6 lua nls script selinux static tftp"
DM_LINGUAS="de es fi fr id it no pl pt_BR ro"
-for dm_lingua in ${DM_LINGUAS}; do
- IUSE+=" linguas_${dm_lingua}"
-done
CDEPEND="dbus? ( sys-apps/dbus )
idn? ( net-dns/libidn )
@@ -141,7 +138,8 @@ src_install() {
install$(use nls && echo "-i18n")
for lingua in ${DM_LINGUAS}; do
- use linguas_${lingua} || rm -rf "${D}"/usr/share/locale/${lingua}
+ has ${lingua} ${LINGUAS-${lingua}} \
+ || rm -rf "${D}"/usr/share/locale/${lingua}
done
[[ -d "${D}"/usr/share/locale/ ]] && rmdir --ignore-fail-on-non-empty "${D}"/usr/share/locale/
diff --git a/net-dns/dnsmasq/dnsmasq-2.76.ebuild b/net-dns/dnsmasq/dnsmasq-2.76.ebuild
index 3b3d54b64eb9..77842fc8f919 100644
--- a/net-dns/dnsmasq/dnsmasq-2.76.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.76.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,9 +14,6 @@ SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE="auth-dns conntrack dbus +dhcp dhcp-tools dnssec idn +inotify ipv6 lua nls script selinux static tftp"
DM_LINGUAS="de es fi fr id it no pl pt_BR ro"
-for dm_lingua in ${DM_LINGUAS}; do
- IUSE+=" linguas_${dm_lingua}"
-done
CDEPEND="dbus? ( sys-apps/dbus )
idn? ( net-dns/libidn )
@@ -141,7 +138,8 @@ src_install() {
install$(use nls && echo "-i18n")
for lingua in ${DM_LINGUAS}; do
- use linguas_${lingua} || rm -rf "${D}"/usr/share/locale/${lingua}
+ has ${lingua} ${LINGUAS-${lingua}} \
+ || rm -rf "${D}"/usr/share/locale/${lingua}
done
[[ -d "${D}"/usr/share/locale/ ]] && rmdir --ignore-fail-on-non-empty "${D}"/usr/share/locale/
diff --git a/net-dns/dnsmasq/dnsmasq-2.77-r1.ebuild b/net-dns/dnsmasq/dnsmasq-2.77-r1.ebuild
index 754968a7d317..17fb4b4ab3a6 100644
--- a/net-dns/dnsmasq/dnsmasq-2.77-r1.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.77-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,10 +18,6 @@ IUSE+=" ipv6 lua nls script selinux static tftp"
DM_LINGUAS=(de es fi fr id it no pl pt_BR ro)
-for dm_lingua in "${DM_LINGUAS[@]}"; do
- IUSE+=" linguas_${dm_lingua}"
-done
-
CDEPEND="dbus? ( sys-apps/dbus )
idn? (
!libidn2? ( net-dns/libidn )
@@ -147,7 +143,8 @@ src_install() {
install$(use nls && echo "-i18n")
for lingua in "${DM_LINGUAS[@]}"; do
- use linguas_${lingua} || rm -rf "${D}"/usr/share/locale/${lingua}
+ has ${lingua} ${LINGUAS-${lingua}} \
+ || rm -rf "${D}"/usr/share/locale/${lingua}
done
[[ -d "${D}"/usr/share/locale/ ]] && rmdir --ignore-fail-on-non-empty "${D}"/usr/share/locale/
diff --git a/net-dns/dnsmasq/dnsmasq-2.77.ebuild b/net-dns/dnsmasq/dnsmasq-2.77.ebuild
index 3b26668c2df5..3c45c1db5b18 100644
--- a/net-dns/dnsmasq/dnsmasq-2.77.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.77.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,10 +18,6 @@ IUSE+=" ipv6 lua nls script selinux static tftp"
DM_LINGUAS=(de es fi fr id it no pl pt_BR ro)
-for dm_lingua in "${DM_LINGUAS[@]}"; do
- IUSE+=" linguas_${dm_lingua}"
-done
-
CDEPEND="dbus? ( sys-apps/dbus )
idn? ( net-dns/libidn )
libidn2? ( >=net-dns/libidn2-2.0 )
@@ -145,7 +141,8 @@ src_install() {
install$(use nls && echo "-i18n")
for lingua in "${DM_LINGUAS[@]}"; do
- use linguas_${lingua} || rm -rf "${D}"/usr/share/locale/${lingua}
+ has ${lingua} ${LINGUAS-${lingua}} \
+ || rm -rf "${D}"/usr/share/locale/${lingua}
done
[[ -d "${D}"/usr/share/locale/ ]] && rmdir --ignore-fail-on-non-empty "${D}"/usr/share/locale/
diff --git a/net-dns/dnsmasq/dnsmasq-2.78.ebuild b/net-dns/dnsmasq/dnsmasq-2.78.ebuild
index f01b5ac6f7b2..ee66cd35d3b7 100644
--- a/net-dns/dnsmasq/dnsmasq-2.78.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.78.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,10 +18,6 @@ IUSE+=" ipv6 lua nls script selinux static tftp"
DM_LINGUAS=(de es fi fr id it no pl pt_BR ro)
-for dm_lingua in "${DM_LINGUAS[@]}"; do
- IUSE+=" linguas_${dm_lingua}"
-done
-
CDEPEND="dbus? ( sys-apps/dbus )
idn? (
!libidn2? ( net-dns/libidn )
@@ -147,7 +143,8 @@ src_install() {
install$(use nls && echo "-i18n")
for lingua in "${DM_LINGUAS[@]}"; do
- use linguas_${lingua} || rm -rf "${D}"/usr/share/locale/${lingua}
+ has ${lingua} ${LINGUAS-${lingua}} \
+ || rm -rf "${D}"/usr/share/locale/${lingua}
done
[[ -d "${D}"/usr/share/locale/ ]] && rmdir --ignore-fail-on-non-empty "${D}"/usr/share/locale/