summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-15 07:22:04 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-15 07:23:03 +0200
commit89350d2d9b48085c8de3ee42fabc960c59873231 (patch)
tree7d28fe3769afea80e59f3a779261b34c7b1ce6b0 /net-dns
parentdev-ruby/pkg-config: cleanup (diff)
downloadgentoo-89350d2d9b48085c8de3ee42fabc960c59873231.tar.gz
gentoo-89350d2d9b48085c8de3ee42fabc960c59873231.tar.bz2
gentoo-89350d2d9b48085c8de3ee42fabc960c59873231.zip
net-dns/nsd: Bump to version 4.1.21
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/nsd/Manifest1
-rw-r--r--net-dns/nsd/nsd-4.1.21.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/net-dns/nsd/Manifest b/net-dns/nsd/Manifest
index a9648c6caa48..8d96cd35f715 100644
--- a/net-dns/nsd/Manifest
+++ b/net-dns/nsd/Manifest
@@ -1 +1,2 @@
DIST nsd-4.1.20.tar.gz 1096797 BLAKE2B aa1415933f8d1d1415349407c54cfdec581304ca27733110b45bc109288506ad2a92c110565695ac7cb4afae3b955fe09fe740196f268c810e0be992e4f55353 SHA512 4e646303d9da920a9ad567ea3e04a06d8b66bc0d84117908ae69126c131321d660548f32e7bb54e248dae4f48d5152c0a204bf8bf9262ac4394371c05305b21e
+DIST nsd-4.1.21.tar.gz 1099021 BLAKE2B 129fd3145308c108ef2bd06b854aaf7cdb7ae7cce7a635c2028d210f87bc9591c89d8724b4d7a23d72e06e2ed73287c1379573f8cb3571cc63a47987db4f6b65 SHA512 1e37f433ff5cd4869145a575a89d6eaca6b17c0e029302e233277b400c5f0f0b76ea018d48178d6b8a75b72328f0ded9e885be836c0bb32367d6861ff11c7150
diff --git a/net-dns/nsd/nsd-4.1.21.ebuild b/net-dns/nsd/nsd-4.1.21.ebuild
new file mode 100644
index 000000000000..6e71f765df89
--- /dev/null
+++ b/net-dns/nsd/nsd-4.1.21.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user systemd
+
+# version voodoo needed only for non-release tarballs: 4.0.0_rc1 => 4.0.0rc1
+MY_PV="${PV/_rc/rc}"
+MY_PV="${MY_PV/_beta/b}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An authoritative only, high performance, open source name server"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/nsd"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bind8-stats ipv6 libevent minimal-responses mmap munin +nsec3 ratelimit root-server runtime-checks ssl libressl"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ virtual/yacc
+ libevent? ( dev-libs/libevent )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ munin? ( net-analyzer/munin )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
+"
+
+src_prepare() {
+ # Fix the paths in the munin plugin to match our install
+ eapply "${FILESDIR}"/nsd_munin_.patch
+ eapply_user
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-pie
+ --enable-relro-now
+ --enable-largefile
+ --with-logfile="${EPREFIX}"/var/log/nsd.log
+ --with-pidfile="${EPREFIX}"/run/nsd/nsd.pid
+ --with-dbfile="${EPREFIX}"/var/db/nsd/nsd.db
+ --with-xfrdir="${EPREFIX}"/var/db/nsd
+ --with-xfrdfile="${EPREFIX}"/var/db/nsd/xfrd.state
+ --with-zonelistfile="${EPREFIX}"/var/db/nsd/zone.list
+ --with-zonesdir="${EPREFIX}"/var/lib/nsd
+ $(use_enable bind8-stats)
+ $(use_enable bind8-stats zone-stats)
+ $(use_enable ipv6)
+ $(use_enable minimal-responses)
+ $(use_enable mmap)
+ $(use_enable nsec3)
+ $(use_enable ratelimit)
+ $(use_enable root-server)
+ $(use_enable runtime-checks checking)
+ $(use_with libevent)
+ $(use_with ssl)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc doc/{ChangeLog,CREDITS,NSD-4-features,NSD-FOR-BIND-USERS,README,RELNOTES,REQUIREMENTS}
+
+ newinitd "${FILESDIR}"/nsd.initd-r1 nsd
+
+ # install munin plugin and config
+ if use munin ; then
+ exeinto /usr/libexec/munin/plugins
+ doexe contrib/nsd_munin_
+ insinto /etc/munin/plugin-conf.d
+ newins "${FILESDIR}"/nsd.munin-conf nsd_munin
+ fi
+
+ systemd_dounit "${FILESDIR}"/nsd.service
+
+ # remove the /run directory that usually resides on tmpfs and is
+ # being taken care of by the nsd init script anyway (checkpath)
+ rm -r "${ED%/}"/run || die "Failed to remove /run"
+
+ keepdir /var/db/${PN}
+}
+
+pkg_postinst() {
+ # Do this in postinst to ensure the uid/gid is consistent for binpkgs
+ enewgroup nsd
+ enewuser nsd -1 -1 -1 nsd
+
+ # database directory, writable by nsd for database updates and zone transfers
+ install -d -m 750 -o nsd -g nsd "${EROOT%/}"/var/db/nsd
+
+ # zones directory, writable by nsd for zone file updates (nsd-control write)
+ install -d -m 750 -o nsd -g nsd "${EROOT%/}"/var/lib/nsd
+}