summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-firewall/arptables
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-firewall/arptables')
-rw-r--r--net-firewall/arptables/Manifest1
-rw-r--r--net-firewall/arptables/arptables-0.0.3.4-r2.ebuild39
-rw-r--r--net-firewall/arptables/files/arptables-0.0.3.4-arptables_save.patch24
-rw-r--r--net-firewall/arptables/files/arptables-0.0.3.4-ldflags.patch13
-rw-r--r--net-firewall/arptables/files/arptables-0.0.3.4-manpage.patch12
-rw-r--r--net-firewall/arptables/files/arptables-0.0.3.4-type.patch17
-rw-r--r--net-firewall/arptables/metadata.xml8
7 files changed, 114 insertions, 0 deletions
diff --git a/net-firewall/arptables/Manifest b/net-firewall/arptables/Manifest
new file mode 100644
index 000000000000..9f893d711cfa
--- /dev/null
+++ b/net-firewall/arptables/Manifest
@@ -0,0 +1 @@
+DIST arptables-v0.0.3-4.tar.gz 44335 SHA256 e529fd465c67d69ad335299a043516e6b38cdcd337a5ed21718413e96073f928
diff --git a/net-firewall/arptables/arptables-0.0.3.4-r2.ebuild b/net-firewall/arptables/arptables-0.0.3.4-r2.ebuild
new file mode 100644
index 000000000000..fa5e7726722d
--- /dev/null
+++ b/net-firewall/arptables/arptables-0.0.3.4-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+inherit versionator eutils
+
+MY_P=${PN}-v$(replace_version_separator 3 - )
+
+DESCRIPTION="set up, maintain, and inspect the tables of ARP rules in the Linux kernel"
+HOMEPAGE="http://ebtables.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ebtables/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+ epatch "${FILESDIR}/${P}-arptables_save.patch"
+ epatch "${FILESDIR}/${P}-manpage.patch"
+ epatch "${FILESDIR}/${P}-type.patch"
+}
+
+src_compile() {
+ # -O0 does not work and at least -O2 is required, bug #240752
+ emake CC="$(tc-getCC)" COPT_FLAGS="-O2 ${CFLAGS//-O0/-O2}" || die "make failed"
+ sed -ie 's:__EXEC_PATH__:/sbin:g' arptables-save arptables-restore \
+ || die "sed failed"
+}
+
+src_install() {
+ into /
+ dosbin arptables arptables-restore arptables-save || die
+ doman arptables.8 || die
+}
diff --git a/net-firewall/arptables/files/arptables-0.0.3.4-arptables_save.patch b/net-firewall/arptables/files/arptables-0.0.3.4-arptables_save.patch
new file mode 100644
index 000000000000..a1b60b24ea10
--- /dev/null
+++ b/net-firewall/arptables/files/arptables-0.0.3.4-arptables_save.patch
@@ -0,0 +1,24 @@
+# Don't resolve host names and don't convert '*' interface names to any.
+# Remove '*' interface names.
+
+diff -urNad arptables-0.0.3.3~/arptables-save arptables-0.0.3.3/arptables-save
+--- arptables-0.0.3.3~/arptables-save 2009-08-19 14:17:17.000000000 +0200
++++ arptables-0.0.3.3/arptables-save 2009-08-19 14:19:58.000000000 +0200
+@@ -35,6 +35,8 @@
+ # Due to arptables "issues" with displaying device names
+ # we need to use -v and then do some processing
+ $line =~ s/\s,\s.*//;
++ $line =~ s/-i\s\*//;
++ $line =~ s/-o\s\*//;
+ $rules = $rules . "-A $chain $line\n";
+ }
+
+@@ -47,7 +49,7 @@
+ # ========================================================
+
+ unless (-x "$tool") { print "ERROR: Tool $tool isn't executable"; exit -1; };
+-$table =`$tool -t filter -L -v`;
++$table =`$tool -t filter -L -v -n`;
+ unless ($? == 0) { print $table; exit -1 };
+ &process_table($table);
+
diff --git a/net-firewall/arptables/files/arptables-0.0.3.4-ldflags.patch b/net-firewall/arptables/files/arptables-0.0.3.4-ldflags.patch
new file mode 100644
index 000000000000..b5ced69c504b
--- /dev/null
+++ b/net-firewall/arptables/files/arptables-0.0.3.4-ldflags.patch
@@ -0,0 +1,13 @@
+=== modified file 'Makefile'
+--- Makefile 2010-09-15 11:51:49 +0000
++++ Makefile 2010-09-15 11:52:56 +0000
+@@ -31,7 +31,7 @@
+ $(CC) $(CFLAGS) -c -o $@ $<
+
+ arptables: arptables-standalone.o arptables.o libarptc/libarptc.o $(EXT_OBJS)
+- $(CC) $(CFLAGS) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+ $(DESTDIR)$(MANDIR)/man8/arptables.8: arptables.8
+ mkdir -p $(@D)
+
diff --git a/net-firewall/arptables/files/arptables-0.0.3.4-manpage.patch b/net-firewall/arptables/files/arptables-0.0.3.4-manpage.patch
new file mode 100644
index 000000000000..76295b6d9b5c
--- /dev/null
+++ b/net-firewall/arptables/files/arptables-0.0.3.4-manpage.patch
@@ -0,0 +1,12 @@
+diff -urNad arptables-0.0.3.3~/arptables.8 arptables-0.0.3.3/arptables.8
+--- arptables-0.0.3.3~/arptables.8 2007-08-19 15:04:51.000000000 +0200
++++ arptables-0.0.3.3/arptables.8 2008-05-08 18:56:35.000000000 +0200
+@@ -22,7 +22,7 @@
+ .\"
+ .\"
+ .SH NAME
+-arptables (v.0.0.3-3) \- ARP table administration
++arptables \- ARP table administration
+ .SH SYNOPSIS
+ .BR "arptables " [ "-t table" ] " -" [ AD ] " chain rule-specification " [ options ]
+ .br
diff --git a/net-firewall/arptables/files/arptables-0.0.3.4-type.patch b/net-firewall/arptables/files/arptables-0.0.3.4-type.patch
new file mode 100644
index 000000000000..851bf0ee247f
--- /dev/null
+++ b/net-firewall/arptables/files/arptables-0.0.3.4-type.patch
@@ -0,0 +1,17 @@
+# Patch from Jeroen van Wolffelaar <jeroen@wolffelaar.nl> to make
+# arptables --proto-type also accept hexadecimal inputs (ethernet protocol
+# numbers are often specfied in hex, not decimal), using standard strtol()
+# behaviour (hex iff starts with 0x).
+
+diff -urNad arptables-0.0.3.3~/arptables.c arptables-0.0.3.3/arptables.c
+--- arptables-0.0.3.3~/arptables.c 2007-08-19 15:04:51.000000000 +0200
++++ arptables-0.0.3.3/arptables.c 2008-05-08 19:16:43.000000000 +0200
+@@ -2039,7 +2039,7 @@
+ check_inverse(optarg, &invert, &optind, argc);
+ set_option(&options, OPT_P_TYPE, &fw.arp.invflags,
+ invert);
+- if (get16_and_mask(argv[optind - 1], &fw.arp.arpro, &fw.arp.arpro_mask, 10)) {
++ if (get16_and_mask(argv[optind - 1], &fw.arp.arpro, &fw.arp.arpro_mask, 0)) {
+ if (strcasecmp(argv[optind-1], "ipv4"))
+ exit_error(PARAMETER_PROBLEM, "Problem with specified protocol type");
+ fw.arp.arpro = htons(0x800);
diff --git a/net-firewall/arptables/metadata.xml b/net-firewall/arptables/metadata.xml
new file mode 100644
index 000000000000..23b2d799bbe8
--- /dev/null
+++ b/net-firewall/arptables/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <upstream>
+ <remote-id type="sourceforge">ebtables</remote-id>
+ </upstream>
+</pkgmetadata>