summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-09-12 17:22:48 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-09-12 17:23:13 -0400
commit946887fa830c1a83c9543dd86976b168526aa506 (patch)
tree749ee63d25308d0fe8d4f288c048260e99a9a522 /net-firewall/xtables-addons
parentapp-office/libreoffice: Raise dev-libs/liborcus min version to 0.14.0 (diff)
downloadgentoo-946887fa830c1a83c9543dd86976b168526aa506.tar.gz
gentoo-946887fa830c1a83c9543dd86976b168526aa506.tar.bz2
gentoo-946887fa830c1a83c9543dd86976b168526aa506.zip
net-firewall/xtables-addons: version bump to 3.1 and 3.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-firewall/xtables-addons')
-rw-r--r--net-firewall/xtables-addons/Manifest2
-rw-r--r--net-firewall/xtables-addons/xtables-addons-3.1.ebuild187
-rw-r--r--net-firewall/xtables-addons/xtables-addons-3.2.ebuild187
3 files changed, 376 insertions, 0 deletions
diff --git a/net-firewall/xtables-addons/Manifest b/net-firewall/xtables-addons/Manifest
index 6c922aa722f8..99495a00e941 100644
--- a/net-firewall/xtables-addons/Manifest
+++ b/net-firewall/xtables-addons/Manifest
@@ -1,3 +1,5 @@
DIST xtables-addons-2.13.tar.xz 322116 BLAKE2B 31d12adcfdf2043b44b5789f3ba3215197ff48d378b20fd6406f6afd22739e04069f08f32214a2230ec797469b236788dbebef079855539994db69be358ec421 SHA512 51cfa963d6f2f931b0361746e0b48f5ecf43a14e9e8d5297ef55faf0e9f8d1deb4641e88e3fea2afdbb3e39dd06d414de6057fb4a21e5184d4ea3d21b8028497
DIST xtables-addons-2.14.tar.xz 322296 BLAKE2B f739951ff535f73be8c96b271f929821fd708cb4615a3e6c2528d9bd2574c8d801c6ac6b59f23f5054b29c31a94f90c7d3f7628b09fb78dc2e7f7da87e5af0a1 SHA512 f3d49c53aa01fadc334906e580f16605849fe7be83637fa73d51b48ded0e77c368c544ad69fa97b53a6688eaa3ba63bab489c150a9e02205e8044cdd521f4752
DIST xtables-addons-3.0.tar.xz 321960 BLAKE2B ce6e034ab42fda319217b464a2c3c639787a696d58739cc7ba8e1c699894c46590c34490c8ccc41c29b8dbfb4ad01859050bdeccbac08d09f297a49cdc920c6e SHA512 164b43ff23f33187b5f557bedf765fbad21721b236ac5f5e982c5fdf88cdcbf8ca106810d2df31d9ab79e9c518f7fec3d7dae297540d0b00326a0dfffd04cfec
+DIST xtables-addons-3.1.tar.xz 323684 BLAKE2B eb75bf41c7ca2f1b1dc41bb7c602de8856e86db244a4e247e3089037e176d5f84e472719e7fc31836e898b615f8b6630ddeacf0754807e6684a22aa593550b1a SHA512 d9cbd3278ac156b3edb024bad98dab2bb1f83546aacf038b85b9203064e301de17c638dae4e05ea907b00b4038377e9aefebb65367ffc335b149f7e17596d931
+DIST xtables-addons-3.2.tar.xz 323608 BLAKE2B a23ae7d779d7cb2f77f2c0cceae54c1b73fa9dcb9dab22a83c2af22562d2c1b1d0a6df7eef7809961d1cb0484793a65a57259af4934b3e7fe624c20c397ce215 SHA512 57b02aec83765ad407a813cc8bb5ba471739da09ee8177094592833d1eaa54300ce06b326e9897cb80f563bdaec24b33d42c2cdb72f8a0ec8f86b085fcc6494d
diff --git a/net-firewall/xtables-addons/xtables-addons-3.1.ebuild b/net-firewall/xtables-addons/xtables-addons-3.1.ebuild
new file mode 100644
index 000000000000..7a72a0a86734
--- /dev/null
+++ b/net-firewall/xtables-addons/xtables-addons-3.1.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils linux-info linux-mod multilib
+
+DESCRIPTION="iptables extensions not yet accepted in the main kernel"
+HOMEPAGE="http://xtables-addons.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xtables-addons/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="modules"
+
+MODULES="quota2 psd pknock lscan length2 ipv4options ipp2p iface gradm geoip fuzzy condition tarpit sysrq logmark ipmark echo dnetmap dhcpmac delude chaos account"
+
+for mod in ${MODULES}; do
+ IUSE="${IUSE} xtables_addons_${mod}"
+done
+
+DEPEND=">=net-firewall/iptables-1.6.0"
+
+RDEPEND="${DEPEND}
+ xtables_addons_geoip? (
+ app-arch/unzip
+ dev-perl/Text-CSV_XS
+ virtual/perl-Getopt-Long
+ )
+"
+
+DEPEND="${DEPEND}
+ virtual/linux-sources"
+
+SKIP_MODULES=""
+
+XA_check4internal_module() {
+ local mod=${1}
+ local version=${3}
+ local kconfigname=${3}
+
+ if use xtables_addons_${mod} && kernel_is -gt ${version}; then
+ ewarn "${kconfigname} should be provided by the kernel. Skipping its build..."
+ if ! linux_chkconfig_present ${kconfigname}; then
+ ewarn "Please enable ${kconfigname} target in your kernel
+ configuration or disable checksum module in ${PN}."
+ fi
+ # SKIP_MODULES in case we need to disable building of everything
+ # like having this USE disabled
+ SKIP_MODULES+=" ${mod}"
+ fi
+}
+
+pkg_setup() {
+ if use modules; then
+ get_version
+ check_modules_supported
+ CONFIG_CHECK="NF_CONNTRACK NF_CONNTRACK_MARK ~CONNECTOR"
+ ERROR_CONNECTOR="Please, enable CONFIG_CONNECTOR if you wish to receive userspace notifications from pknock through netlink/connector"
+ linux-mod_pkg_setup
+
+ if ! linux_chkconfig_present IPV6; then
+ SKIP_IPV6_MODULES="ip6table_rawpost"
+ ewarn "No IPV6 support in kernel. Disabling: ${SKIP_IPV6_MODULES}"
+ fi
+ kernel_is -lt 4 18 && die "${P} requires kernel version >= 4.18"
+ fi
+}
+
+# Helper for maintainer: cheks if all possible MODULES are listed.
+XA_qa_check() {
+ local all_modules
+ all_modules=$(sed -n '/^build_/{s/build_\(.*\)=.*/\L\1/;G;s/\n/ /;s/ $//;h}; ${x;p}' "${S}/mconfig")
+ if [[ ${all_modules} != ${MODULES} ]]; then
+ ewarn "QA: Modules in mconfig differ from \$MODULES in ebuild."
+ ewarn "Please, update MODULES in ebuild."
+ ewarn "'${all_modules}'"
+ fi
+}
+
+# Is there any use flag set?
+XA_has_something_to_build() {
+ local mod
+ for mod in ${MODULES}; do
+ use xtables_addons_${mod} && return
+ done
+
+ eerror "All modules are disabled. What do you want me to build?"
+ eerror "Please, set XTABLES_ADDONS to any combination of"
+ eerror "${MODULES}"
+ die "All modules are disabled."
+}
+
+# Parse Kbuid files and generates list of sources
+XA_get_module_name() {
+ [[ $# != 1 ]] && die "XA_get_sources_for_mod: needs exactly one argument."
+ local mod objdir build_mod sources_list
+ mod=${1}
+ objdir=${S}/extensions
+ # Take modules name from mconfig
+ build_mod=$(sed -n "s/\(build_${mod}\)=.*/\1/Ip" "${S}/mconfig")
+ # strip .o, = and everything before = and print
+ sources_list=$(sed -n "/^obj-[$][{]${build_mod}[}]/\
+ {s:obj-[^+]\+ [+]=[[:space:]]*::;s:[.]o::g;p}" \
+ "${objdir}/Kbuild")
+
+ if [[ -d ${S}/extensions/${sources_list} ]]; then
+ objdir=${S}/extensions/${sources_list}
+ sources_list=$(sed -n "/^obj-m/\
+ {s:obj-[^+]\+ [+]=[[:space:]]*::;s:[.]o::g;p}" \
+ "${objdir}/Kbuild")
+ fi
+ for mod_src in ${sources_list}; do
+ has ${mod_src} ${SKIP_IPV6_MODULES} || \
+ echo " ${mod_src}(xtables_addons:${S}/extensions:${objdir})"
+ done
+}
+
+# Die on modules known to fail on certain kernel version.
+XA_known_failure() {
+ local module_name=$1
+ local KV_max=$2
+
+ if use xtables_addons_${module_name} && kernel_is ge ${KV_max//./ }; then
+ eerror
+ eerror "XTABLES_ADDONS=${module_name} fails to build on linux ${KV_max} or above."
+ eerror "Either remove XTABLES_ADDONS=${module_name} or use an earlier version of the kernel."
+ eerror
+ die
+ fi
+}
+
+src_prepare() {
+ XA_qa_check
+ XA_has_something_to_build
+
+ # Bug #553630#c2. echo fails on linux-4 and above.
+ # This appears to be fixed, at least as of linux-4.2
+ # XA_known_failure "echo" 4
+
+ local mod module_name
+ if use modules; then
+ MODULE_NAMES="compat_xtables(xtables_addons:${S}/extensions:)"
+ fi
+ for mod in ${MODULES}; do
+ if ! has ${mod} ${SKIP_MODULES} && use xtables_addons_${mod}; then
+ sed "s/\(build_${mod}=\).*/\1m/I" -i mconfig || die
+ if use modules; then
+ for module_name in $(XA_get_module_name ${mod}); do
+ MODULE_NAMES+=" ${module_name}"
+ done
+ fi
+ else
+ sed "s/\(build_${mod}=\).*/\1n/I" -i mconfig || die
+ fi
+ done
+ einfo "${MODULE_NAMES}" # for debugging
+
+ sed -e 's/depmod -a/true/' -i Makefile.in || die
+ sed -e '/^all-local:/{s: modules::}' \
+ -e '/^install-exec-local:/{s: modules_install::}' \
+ -i extensions/Makefile.in || die
+
+ use xtables_addons_geoip || sed -e '/^SUBDIRS/{s/geoip//}' -i Makefile.in
+
+ eapply_user
+}
+
+src_configure() {
+ set_arch_to_kernel # .. or it'll look for /arch/amd64/Makefile
+ econf --prefix="${EPREFIX}/" \
+ --libexecdir="${EPREFIX}/$(get_libdir)/" \
+ --with-kbuild="${KV_OUT_DIR}"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" V=1
+ use modules && BUILD_PARAMS="V=1" BUILD_TARGETS="modules" linux-mod_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use modules && linux-mod_src_install
+ dodoc -r README doc/*
+ find "${ED}" -type f -name '*.la' -exec rm -rf '{}' '+'
+}
diff --git a/net-firewall/xtables-addons/xtables-addons-3.2.ebuild b/net-firewall/xtables-addons/xtables-addons-3.2.ebuild
new file mode 100644
index 000000000000..7a72a0a86734
--- /dev/null
+++ b/net-firewall/xtables-addons/xtables-addons-3.2.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils linux-info linux-mod multilib
+
+DESCRIPTION="iptables extensions not yet accepted in the main kernel"
+HOMEPAGE="http://xtables-addons.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xtables-addons/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="modules"
+
+MODULES="quota2 psd pknock lscan length2 ipv4options ipp2p iface gradm geoip fuzzy condition tarpit sysrq logmark ipmark echo dnetmap dhcpmac delude chaos account"
+
+for mod in ${MODULES}; do
+ IUSE="${IUSE} xtables_addons_${mod}"
+done
+
+DEPEND=">=net-firewall/iptables-1.6.0"
+
+RDEPEND="${DEPEND}
+ xtables_addons_geoip? (
+ app-arch/unzip
+ dev-perl/Text-CSV_XS
+ virtual/perl-Getopt-Long
+ )
+"
+
+DEPEND="${DEPEND}
+ virtual/linux-sources"
+
+SKIP_MODULES=""
+
+XA_check4internal_module() {
+ local mod=${1}
+ local version=${3}
+ local kconfigname=${3}
+
+ if use xtables_addons_${mod} && kernel_is -gt ${version}; then
+ ewarn "${kconfigname} should be provided by the kernel. Skipping its build..."
+ if ! linux_chkconfig_present ${kconfigname}; then
+ ewarn "Please enable ${kconfigname} target in your kernel
+ configuration or disable checksum module in ${PN}."
+ fi
+ # SKIP_MODULES in case we need to disable building of everything
+ # like having this USE disabled
+ SKIP_MODULES+=" ${mod}"
+ fi
+}
+
+pkg_setup() {
+ if use modules; then
+ get_version
+ check_modules_supported
+ CONFIG_CHECK="NF_CONNTRACK NF_CONNTRACK_MARK ~CONNECTOR"
+ ERROR_CONNECTOR="Please, enable CONFIG_CONNECTOR if you wish to receive userspace notifications from pknock through netlink/connector"
+ linux-mod_pkg_setup
+
+ if ! linux_chkconfig_present IPV6; then
+ SKIP_IPV6_MODULES="ip6table_rawpost"
+ ewarn "No IPV6 support in kernel. Disabling: ${SKIP_IPV6_MODULES}"
+ fi
+ kernel_is -lt 4 18 && die "${P} requires kernel version >= 4.18"
+ fi
+}
+
+# Helper for maintainer: cheks if all possible MODULES are listed.
+XA_qa_check() {
+ local all_modules
+ all_modules=$(sed -n '/^build_/{s/build_\(.*\)=.*/\L\1/;G;s/\n/ /;s/ $//;h}; ${x;p}' "${S}/mconfig")
+ if [[ ${all_modules} != ${MODULES} ]]; then
+ ewarn "QA: Modules in mconfig differ from \$MODULES in ebuild."
+ ewarn "Please, update MODULES in ebuild."
+ ewarn "'${all_modules}'"
+ fi
+}
+
+# Is there any use flag set?
+XA_has_something_to_build() {
+ local mod
+ for mod in ${MODULES}; do
+ use xtables_addons_${mod} && return
+ done
+
+ eerror "All modules are disabled. What do you want me to build?"
+ eerror "Please, set XTABLES_ADDONS to any combination of"
+ eerror "${MODULES}"
+ die "All modules are disabled."
+}
+
+# Parse Kbuid files and generates list of sources
+XA_get_module_name() {
+ [[ $# != 1 ]] && die "XA_get_sources_for_mod: needs exactly one argument."
+ local mod objdir build_mod sources_list
+ mod=${1}
+ objdir=${S}/extensions
+ # Take modules name from mconfig
+ build_mod=$(sed -n "s/\(build_${mod}\)=.*/\1/Ip" "${S}/mconfig")
+ # strip .o, = and everything before = and print
+ sources_list=$(sed -n "/^obj-[$][{]${build_mod}[}]/\
+ {s:obj-[^+]\+ [+]=[[:space:]]*::;s:[.]o::g;p}" \
+ "${objdir}/Kbuild")
+
+ if [[ -d ${S}/extensions/${sources_list} ]]; then
+ objdir=${S}/extensions/${sources_list}
+ sources_list=$(sed -n "/^obj-m/\
+ {s:obj-[^+]\+ [+]=[[:space:]]*::;s:[.]o::g;p}" \
+ "${objdir}/Kbuild")
+ fi
+ for mod_src in ${sources_list}; do
+ has ${mod_src} ${SKIP_IPV6_MODULES} || \
+ echo " ${mod_src}(xtables_addons:${S}/extensions:${objdir})"
+ done
+}
+
+# Die on modules known to fail on certain kernel version.
+XA_known_failure() {
+ local module_name=$1
+ local KV_max=$2
+
+ if use xtables_addons_${module_name} && kernel_is ge ${KV_max//./ }; then
+ eerror
+ eerror "XTABLES_ADDONS=${module_name} fails to build on linux ${KV_max} or above."
+ eerror "Either remove XTABLES_ADDONS=${module_name} or use an earlier version of the kernel."
+ eerror
+ die
+ fi
+}
+
+src_prepare() {
+ XA_qa_check
+ XA_has_something_to_build
+
+ # Bug #553630#c2. echo fails on linux-4 and above.
+ # This appears to be fixed, at least as of linux-4.2
+ # XA_known_failure "echo" 4
+
+ local mod module_name
+ if use modules; then
+ MODULE_NAMES="compat_xtables(xtables_addons:${S}/extensions:)"
+ fi
+ for mod in ${MODULES}; do
+ if ! has ${mod} ${SKIP_MODULES} && use xtables_addons_${mod}; then
+ sed "s/\(build_${mod}=\).*/\1m/I" -i mconfig || die
+ if use modules; then
+ for module_name in $(XA_get_module_name ${mod}); do
+ MODULE_NAMES+=" ${module_name}"
+ done
+ fi
+ else
+ sed "s/\(build_${mod}=\).*/\1n/I" -i mconfig || die
+ fi
+ done
+ einfo "${MODULE_NAMES}" # for debugging
+
+ sed -e 's/depmod -a/true/' -i Makefile.in || die
+ sed -e '/^all-local:/{s: modules::}' \
+ -e '/^install-exec-local:/{s: modules_install::}' \
+ -i extensions/Makefile.in || die
+
+ use xtables_addons_geoip || sed -e '/^SUBDIRS/{s/geoip//}' -i Makefile.in
+
+ eapply_user
+}
+
+src_configure() {
+ set_arch_to_kernel # .. or it'll look for /arch/amd64/Makefile
+ econf --prefix="${EPREFIX}/" \
+ --libexecdir="${EPREFIX}/$(get_libdir)/" \
+ --with-kbuild="${KV_OUT_DIR}"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" V=1
+ use modules && BUILD_PARAMS="V=1" BUILD_TARGETS="modules" linux-mod_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use modules && linux-mod_src_install
+ dodoc -r README doc/*
+ find "${ED}" -type f -name '*.la' -exec rm -rf '{}' '+'
+}