summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-08-11 15:05:52 -0700
committerMatt Turner <mattst88@gentoo.org>2019-08-11 15:09:38 -0700
commitb4ff413bd4b91cd387a6087519527476d64aa90b (patch)
tree525e79c5f272a39d1d35e1fe6add6c266e4d76fb /net-fs
parentmedia-libs/openjpeg: drop vulnerable wrt bug #646774 (diff)
downloadgentoo-b4ff413bd4b91cd387a6087519527476d64aa90b.tar.gz
gentoo-b4ff413bd4b91cd387a6087519527476d64aa90b.tar.bz2
gentoo-b4ff413bd4b91cd387a6087519527476d64aa90b.zip
net-fs/nfs-utils: Look in lib32 for krb5 libs
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/nfs-utils/files/nfs-utils-2.4.1-gssd-Look-in-lib32-for-gss-libs-aswell.patch39
-rw-r--r--net-fs/nfs-utils/nfs-utils-2.4.1.ebuild1
2 files changed, 40 insertions, 0 deletions
diff --git a/net-fs/nfs-utils/files/nfs-utils-2.4.1-gssd-Look-in-lib32-for-gss-libs-aswell.patch b/net-fs/nfs-utils/files/nfs-utils-2.4.1-gssd-Look-in-lib32-for-gss-libs-aswell.patch
new file mode 100644
index 00000000000..8e340656b3e
--- /dev/null
+++ b/net-fs/nfs-utils/files/nfs-utils-2.4.1-gssd-Look-in-lib32-for-gss-libs-aswell.patch
@@ -0,0 +1,39 @@
+From e2244412ae8b0b04446063ff6e8a1d0ebebe55a8 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Sun, 11 Aug 2019 14:50:01 -0700
+Subject: [PATCH] gssd: Look in lib32 for gss libs aswell.
+
+Akin to commit da999b81b058 ("Look in lib64 for gss libs aswell.")
+
+mips/n32 systems have libraries in lib32 (but not lib or lib64). Without
+checking lib32, configure fails with
+
+checking for Kerberos v5... configure: error: Kerberos v5 with GSS
+ support not found: consider --disable-gss or --with-krb5=
+
+Signed-off-by: Matt Turner <mattst88@gmail.com>
+---
+ aclocal/kerberos5.m4 | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/aclocal/kerberos5.m4 b/aclocal/kerberos5.m4
+index 8a0f3e4c..faa58049 100644
+--- a/aclocal/kerberos5.m4
++++ b/aclocal/kerberos5.m4
+@@ -38,9 +38,11 @@ AC_DEFUN([AC_KERBEROS_V5],[
+ AC_DEFINE_UNQUOTED(KRB5_VERSION, $K5VERS, [Define this as the Kerberos version number])
+ if test -f $dir/include/gssapi/gssapi_krb5.h -a \
+ \( -f $dir/lib/libgssapi_krb5.a -o \
++ -f $dir/lib/libgssapi_krb5.so -o \
++ -f $dir/lib32/libgssapi_krb5.a -o \
++ -f $dir/lib32/libgssapi_krb5.so -o \
+ -f $dir/lib64/libgssapi_krb5.a -o \
+- -f $dir/lib64/libgssapi_krb5.so -o \
+- -f $dir/lib/libgssapi_krb5.so \) ; then
++ -f $dir/lib64/libgssapi_krb5.so \) ; then
+ AC_DEFINE(HAVE_KRB5, 1, [Define this if you have MIT Kerberos libraries])
+ KRBDIR="$dir"
+ gssapi_lib=gssapi_krb5
+--
+2.21.0
+
diff --git a/net-fs/nfs-utils/nfs-utils-2.4.1.ebuild b/net-fs/nfs-utils/nfs-utils-2.4.1.ebuild
index 2691baaa27f..c579954763a 100644
--- a/net-fs/nfs-utils/nfs-utils-2.4.1.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-2.4.1.ebuild
@@ -67,6 +67,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.1.4-mtab-sym.patch
"${FILESDIR}"/${PN}-1.2.8-cross-build.patch
"${FILESDIR}"/${PN}-2.3.4-no-werror.patch
+ "${FILESDIR}"/${P}-gssd-Look-in-lib32-for-gss-libs-aswell.patch
)
src_prepare() {