summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2018-01-02 10:07:02 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2018-01-02 10:07:13 +0100
commitfa55ec80af6d90d93960b4bc32e4c4005870c716 (patch)
tree7a923b5525fe7b93deb8057956d17e59ba6c799b /net-ftp/filezilla
parentnet-libs/libssh: Use https in live ebuild where appropriate. (diff)
downloadgentoo-fa55ec80af6d90d93960b4bc32e4c4005870c716.tar.gz
gentoo-fa55ec80af6d90d93960b4bc32e4c4005870c716.tar.bz2
gentoo-fa55ec80af6d90d93960b4bc32e4c4005870c716.zip
net-ftp/filezilla: add gnome2_icon_cache_update()
Closes: https://bugs.gentoo.org/641018 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-ftp/filezilla')
-rw-r--r--net-ftp/filezilla/filezilla-3.25.2-r1.ebuild12
-rw-r--r--net-ftp/filezilla/filezilla-3.25.2.ebuild12
2 files changed, 20 insertions, 4 deletions
diff --git a/net-ftp/filezilla/filezilla-3.25.2-r1.ebuild b/net-ftp/filezilla/filezilla-3.25.2-r1.ebuild
index 27a892849dad..a39e198691d0 100644
--- a/net-ftp/filezilla/filezilla-3.25.2-r1.ebuild
+++ b/net-ftp/filezilla/filezilla-3.25.2-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
WX_GTK_VER="3.0-gtk3"
-inherit autotools eutils flag-o-matic multilib wxwidgets
+inherit autotools eutils flag-o-matic gnome2-utils multilib wxwidgets
MY_PV=${PV/_/-}
MY_P="FileZilla_${MY_PV}"
@@ -66,3 +66,11 @@ src_configure() {
--with-pugixml=system \
--disable-autoupdatecheck
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/net-ftp/filezilla/filezilla-3.25.2.ebuild b/net-ftp/filezilla/filezilla-3.25.2.ebuild
index 9273ca52e53c..61eb63e204bc 100644
--- a/net-ftp/filezilla/filezilla-3.25.2.ebuild
+++ b/net-ftp/filezilla/filezilla-3.25.2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
WX_GTK_VER="3.0"
-inherit autotools eutils flag-o-matic multilib wxwidgets
+inherit autotools eutils flag-o-matic gnome2-utils multilib wxwidgets
MY_PV=${PV/_/-}
MY_P="FileZilla_${MY_PV}"
@@ -66,3 +66,11 @@ src_configure() {
--with-pugixml=system \
--disable-autoupdatecheck
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}