summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-12-06 09:36:32 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-12-06 09:49:00 +0100
commita28e7899bd1c8e68645b96e5d31a2ff37bc98d43 (patch)
tree74af4b2f8acab374b546d1df0511a5486dff7bc2 /net-ftp
parentdev-libs/libfilezilla: Removed old. (diff)
downloadgentoo-a28e7899bd1c8e68645b96e5d31a2ff37bc98d43.tar.gz
gentoo-a28e7899bd1c8e68645b96e5d31a2ff37bc98d43.tar.bz2
gentoo-a28e7899bd1c8e68645b96e5d31a2ff37bc98d43.zip
net-ftp/filezilla: Bump to version 3.23.0.1
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/Manifest1
-rw-r--r--net-ftp/filezilla/filezilla-3.23.0.1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
index e3a90ebada2..973cf767086 100644
--- a/net-ftp/filezilla/Manifest
+++ b/net-ftp/filezilla/Manifest
@@ -2,3 +2,4 @@ DIST FileZilla_3.12.0.2_src.tar.bz2 4440836 SHA256 7a296fc2cd94d00d3a14ad29b84ff
DIST FileZilla_3.14.1_src.tar.bz2 4411187 SHA256 b10871b6ced5f52062b44deda037edb8a38090b226a018b9b64b1a1feb59d46c SHA512 c97767ed01f4538a2f4b8760601778ca7f9aa99b5b928cb86c9508eba0490bbc1f31921d098e0ccd30712ff06dc9f21d323201fb8bee80b9fb7a6528fbb03368 WHIRLPOOL 1fbccfbb0de5111fad14eb0b38ee190aefc4c80777c3611189c74412dfefdf2fd96d4a42c917791d3a3318b6ae22f01a7d24a4a0904386b22a98693151b5a822
DIST FileZilla_3.22.1_src.tar.bz2 4446400 SHA256 2ea8a0d613e062c34c01b0a1c0860e1328bb8247eb02aa73ef4597d984e4285f SHA512 c03435e56279d384f1b0716e61082553a6f8157b305bc200d4666a27543094d3403d471153c7ceb8a2e9af00516186663e8b8840350930938a25b456e72c5c4a WHIRLPOOL 4ab2f77a4b89b0078e944a192fecf9ae955dee133afb8f3f6bc46d6ddc8b0c66eddc0009a1c395c4426aa4d2bd377bad45d83d6b5c1af8aa9b28b4f3c5d16109
DIST FileZilla_3.22.2.2_src.tar.bz2 4448800 SHA256 bb7117e587ff05544c24eb7925e89c27afdd43ef6c0ce2e623c021d4479802c0 SHA512 7ae3b172d053dcbae10daebe6338aac860d11600fb16b2d0e65f6a7f46b9dc242b8dd3378e5adf5e76c7fd853e7762ec22768cdaf67f5c04911f620116174fc6 WHIRLPOOL e85d68cd13601ff280f57fe897a0ca1273a7418254e43b22fed90326fba01cdc304290a36cfbfb69604563488cf64299b1d9832ba763bd648ee891afd18534e5
+DIST FileZilla_3.23.0.1_src.tar.bz2 4662488 SHA256 3450fb0c0cc1b8b169dde68b405a65cdc28cabe729de52b199a101d0e8e52f5b SHA512 62337bb92a50b29a5fc5c6bfa920ba1229535b56f85c536056e9fe99e8e1483077b2227485e3d3b7a8ff49519e5d0213e2248b15ab4b73d958ec601cd2bbf32c WHIRLPOOL 039565c222e50b70c070d6430903952d8346ccfbff0384261bbbb8e47d5982c572075d7766c3fafdeae87f111c253c1737852e5f2faadcfd032260c1690dc5da
diff --git a/net-ftp/filezilla/filezilla-3.23.0.1.ebuild b/net-ftp/filezilla/filezilla-3.23.0.1.ebuild
new file mode 100644
index 00000000000..2cb99635b7d
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.23.0.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+
+inherit autotools eutils flag-o-matic multilib wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="dbus nls test"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
+ >=dev-libs/nettle-3.1:=
+ >=dev-db/sqlite-3.7
+ >=dev-libs/libfilezilla-0.9.0
+ >=dev-libs/pugixml-1.7
+ net-dns/libidn
+ >=net-libs/gnutls-3.4.0
+ >=x11-libs/wxGTK-3.0.2.0-r1:3.0[X] x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( dev-util/cppunit )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.22.1-debug.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with dbus) $(use_enable nls locales) \
+ --with-pugixml=system \
+ --disable-autoupdatecheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ doicon src/interface/resources/48x48/${PN}.png
+
+ dodoc AUTHORS ChangeLog NEWS
+}