summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-17 22:14:50 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-17 22:15:52 -0400
commitb5bf85e9ba537b25c10253cb007e7fc45c570eba (patch)
treea37e7652ef3cce7caf478a60984cf71b07671a88 /net-im/bitlbee-steam/bitlbee-steam-9999.ebuild
parentapp-admin/augeas: 1.8.1 bup (diff)
downloadgentoo-b5bf85e9ba537b25c10253cb007e7fc45c570eba.tar.gz
gentoo-b5bf85e9ba537b25c10253cb007e7fc45c570eba.tar.bz2
gentoo-b5bf85e9ba537b25c10253cb007e7fc45c570eba.zip
net-im/bitlbee-steam: version bump to 1.4.2
Bug #580786 by Alex Xu.
Diffstat (limited to 'net-im/bitlbee-steam/bitlbee-steam-9999.ebuild')
-rw-r--r--net-im/bitlbee-steam/bitlbee-steam-9999.ebuild34
1 files changed, 17 insertions, 17 deletions
diff --git a/net-im/bitlbee-steam/bitlbee-steam-9999.ebuild b/net-im/bitlbee-steam/bitlbee-steam-9999.ebuild
index 680b1000596a..c0ec7c0ca9c8 100644
--- a/net-im/bitlbee-steam/bitlbee-steam-9999.ebuild
+++ b/net-im/bitlbee-steam/bitlbee-steam-9999.ebuild
@@ -1,37 +1,37 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit eutils autotools git-2
+inherit ltprune autotools
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/bitlbee/bitlbee-steam.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/bitlbee/bitlbee-steam/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="Steam protocol plugin for BitlBee"
-HOMEPAGE="https://github.com/jgeboski/bitlbee-steam"
-EGIT_REPO_URI="https://github.com/jgeboski/bitlbee-steam.git"
+HOMEPAGE="https://github.com/bitlbee/bitlbee-steam"
-LICENSE="GPL-2 LGPL-2.1 BSD-2"
+LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS=""
-IUSE="debug"
RDEPEND="
dev-libs/glib:2
- dev-libs/libgpg-error
- >=net-im/bitlbee-3.2.1[plugins]"
+ dev-libs/libgcrypt:0=
+ >=net-im/bitlbee-3.4[plugins]"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
+ default
eautoreconf
}
-src_configure() {
- econf \
- $(use_enable debug) \
- --enable-minimal-flags
-}
-
src_install() {
default
- prune_libtool_files
+ prune_libtool_files --modules
}