summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2016-03-02 14:00:48 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2016-03-02 14:01:36 +0100
commitbac4d6e0819038d116bd8c69d4f6d8092e687363 (patch)
treef59ff98830ac2d641bdf0567479f6c439dcced7a /net-im/bitlbee
parentdev-util/shellcheck: version bump (diff)
downloadgentoo-bac4d6e0819038d116bd8c69d4f6d8092e687363.tar.gz
gentoo-bac4d6e0819038d116bd8c69d4f6d8092e687363.tar.bz2
gentoo-bac4d6e0819038d116bd8c69d4f6d8092e687363.zip
Add libressl support to many packages
Package maintainers will likely want to cleanup various things for this experimental USE flag.
Diffstat (limited to 'net-im/bitlbee')
-rw-r--r--net-im/bitlbee/bitlbee-3.4.1.ebuild4
-rw-r--r--net-im/bitlbee/bitlbee-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/net-im/bitlbee/bitlbee-3.4.1.ebuild b/net-im/bitlbee/bitlbee-3.4.1.ebuild
index 4c281c91486..2390ec6e512 100644
--- a/net-im/bitlbee/bitlbee-3.4.1.ebuild
+++ b/net-im/bitlbee/bitlbee-3.4.1.ebuild
@@ -15,7 +15,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="debug gnutls ipv6 +xmpp libevent msn nss +oscar otr +plugins purple selinux
- skype ssl test twitter +yahoo xinetd"
+ skype ssl test twitter +yahoo xinetd libressl"
COMMON_DEPEND="
>=dev-libs/glib-2.16
@@ -25,7 +25,7 @@ COMMON_DEPEND="
gnutls? ( net-libs/gnutls )
!gnutls? (
nss? ( dev-libs/nss )
- !nss? ( ssl? ( dev-libs/openssl:0 ) )
+ !nss? ( ssl? ( !libressl? ( dev-libs/openssl:0 ) libressl? ( dev-libs/libressl:= ) ) )
)
"
DEPEND="${COMMON_DEPEND}
diff --git a/net-im/bitlbee/bitlbee-9999.ebuild b/net-im/bitlbee/bitlbee-9999.ebuild
index fb77fd840e3..181f31968bc 100644
--- a/net-im/bitlbee/bitlbee-9999.ebuild
+++ b/net-im/bitlbee/bitlbee-9999.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="http://www.bitlbee.org/"
LICENSE="GPL-2"
SLOT="0"
IUSE="debug gnutls ipv6 +xmpp libevent msn nss +oscar otr +plugins purple selinux
- skype ssl test twitter +yahoo xinetd"
+ skype ssl test twitter +yahoo xinetd libressl"
COMMON_DEPEND="
>=dev-libs/glib-2.16
@@ -31,7 +31,7 @@ COMMON_DEPEND="
gnutls? ( net-libs/gnutls )
!gnutls? (
nss? ( dev-libs/nss )
- !nss? ( ssl? ( dev-libs/openssl:0 ) )
+ !nss? ( ssl? ( !libressl? ( dev-libs/openssl:0 ) libressl? ( dev-libs/libressl:= ) ) )
)
"
DEPEND="${COMMON_DEPEND}