summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2017-06-08 04:19:46 +0300
committerSergey Popov <pinkbyte@gentoo.org>2017-06-08 04:21:43 +0300
commit1783fcaae0c9670e4c23a01979b0d32bc945dcd7 (patch)
treead80bfef2016923fabc5bf6e381e4cbaece599f6 /net-im/err
parentapp-officeext/ooofbtools: version bump, drop old (diff)
downloadgentoo-1783fcaae0c9670e4c23a01979b0d32bc945dcd7.tar.gz
gentoo-1783fcaae0c9670e4c23a01979b0d32bc945dcd7.tar.bz2
gentoo-1783fcaae0c9670e4c23a01979b0d32bc945dcd7.zip
net-im/err: remove support for GUI console, which relies on ancient qtwebkit
Add missing USE-flag dependency for specific Python version on dev-python/xmpppy Gentoo-Bug: 620832 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'net-im/err')
-rw-r--r--net-im/err/err-1.7.1-r1.ebuild23
1 files changed, 5 insertions, 18 deletions
diff --git a/net-im/err/err-1.7.1-r1.ebuild b/net-im/err/err-1.7.1-r1.ebuild
index 898cbf41ee5..ebb93789254 100644
--- a/net-im/err/err-1.7.1-r1.ebuild
+++ b/net-im/err/err-1.7.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
LICENSE="GPL-3"
SLOT="0"
-IUSE="irc qt4 +plugins"
+IUSE="irc +plugins"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="
@@ -22,7 +22,7 @@ RDEPEND="
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/pyfire[${PYTHON_USEDEP}]
dev-python/python-daemon[${PYTHON_USEDEP}]
- dev-python/xmpppy
+ dev-python/xmpppy[${PYTHON_USEDEP}]
dev-python/yapsy[${PYTHON_USEDEP}]
virtual/python-dnspython[${PYTHON_USEDEP}]
irc? (
@@ -30,7 +30,6 @@ RDEPEND="
dev-python/twisted-core[${PYTHON_USEDEP}]
dev-python/twisted-words[${PYTHON_USEDEP}]
)
- qt4? ( dev-python/pyside[${PYTHON_USEDEP},X,webkit] )
plugins? ( dev-vcs/git )"
# Testsuite is broken since 1.6.3
@@ -38,10 +37,9 @@ RESTRICT="test"
# NOTES:
# 1. It has bundled libs - for example exrex(see 'errbot/bundled' subfolder)
-# 2. Need to add PYTHON_USEDEP to remaining dev-python/ deps
-# 3. Support for BOT_SENTRY option is missing, cause
+# 2. Support for BOT_SENTRY option is missing, cause
# we do not have apropriate packages in portage yet
-# 4. Internal web server is broken(dunno why :-()
+# 3. Internal web server is broken(dunno why :-()
pkg_setup() {
ebegin "Creating err group and user"
@@ -78,14 +76,3 @@ python_install_all() {
insinto /etc/${PN}
newins errbot/config-template.py config.py
}
-
-python_install() {
- distutils-r1_python_install
-
- # Upstream requires images to be in site-packages directory,
- # but does not install them at all!
- if use qt4; then
- python_moduleinto errbot
- python_domodule errbot/*.svg
- fi
-}