summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2018-08-16 13:18:31 +0300
committerSergey Popov <pinkbyte@gentoo.org>2018-08-16 13:18:31 +0300
commit42ad98d5336e170edcc9667f08b5925ee5d06dcf (patch)
tree711e139fccf4963a001410b8ece224e2c8e3b7a0 /net-im/err
parentnet-analyzer/graphite-web: add stronger hint about wsgi install (diff)
downloadgentoo-42ad98d5336e170edcc9667f08b5925ee5d06dcf.tar.gz
gentoo-42ad98d5336e170edcc9667f08b5925ee5d06dcf.tar.bz2
gentoo-42ad98d5336e170edcc9667f08b5925ee5d06dcf.zip
net-im/err: drop old version
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-im/err')
-rw-r--r--net-im/err/Manifest1
-rw-r--r--net-im/err/err-1.7.1-r2.ebuild77
-rw-r--r--net-im/err/files/errd.initd27
-rw-r--r--[-rwxr-xr-x]net-im/err/files/errd.initd.20
-rw-r--r--net-im/err/metadata.xml1
5 files changed, 0 insertions, 106 deletions
diff --git a/net-im/err/Manifest b/net-im/err/Manifest
index 958feac807e..62697aaabee 100644
--- a/net-im/err/Manifest
+++ b/net-im/err/Manifest
@@ -1,2 +1 @@
-DIST err-1.7.1.tar.gz 100716 BLAKE2B 6d47ec4e632210ed313342075f87e1857460b57dc9b32d4487b2980c9c99e2a852d27ae7a5c87ee6d8bc4bcd15577ca11934111f27c81979f8aca9d14223212d SHA512 5be7f6ede6694877e73226de4da58bc47e1230032bc9be8dd3e8fd1448afd1e3ae4c02ecbdb30343b98466bb0d3a8fbfbcb6609c5c50768a9be70b9d22f675a4
DIST errbot-5.2.0.tar.gz 189305 BLAKE2B 96e275ee2a70fcab217f4a91c855192d8536cc177e0cafe08c8f55e17a09c06913c07e50473f87ea29e4537cd6389907615eba86d44756962ed59a87498be398 SHA512 d879e9da6647d697ead0a5f72fe83cf33614201863a9a62bc62c90d7ac0478e1e0902438c6f053d2ea56c940d68b136bbfa497175fb11647913bd7f139220aec
diff --git a/net-im/err/err-1.7.1-r2.ebuild b/net-im/err/err-1.7.1-r2.ebuild
deleted file mode 100644
index 6ed14b926ae..00000000000
--- a/net-im/err/err-1.7.1-r2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils user
-
-DESCRIPTION="Plugin based chatbot designed to be easily deployable, extensible and maintainable"
-HOMEPAGE="https://errbot.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="irc +plugins"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyfire[${PYTHON_USEDEP}]
- dev-python/python-daemon[${PYTHON_USEDEP}]
- dev-python/xmpppy[${PYTHON_USEDEP}]
- dev-python/yapsy[${PYTHON_USEDEP}]
- virtual/python-dnspython[${PYTHON_USEDEP}]
- irc? (
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
- )
- plugins? ( dev-vcs/git )"
-
-# Testsuite is broken since 1.6.3
-RESTRICT="test"
-
-# NOTES:
-# 1. It has bundled libs - for example exrex(see 'errbot/bundled' subfolder)
-# 2. Support for BOT_SENTRY option is missing, cause
-# we do not have apropriate packages in portage yet
-# 3. Internal web server is broken(dunno why :-()
-
-pkg_setup() {
- ebegin "Creating err group and user"
- enewgroup 'err'
- enewuser 'err' -1 -1 -1 'err'
- eend ${?}
-}
-
-python_prepare_all() {
- # Remove configparser and config from requirements as they are NOT needed
- sed -i \
- -e "/install_requires/s/'configparser', //" \
- -e "/install_requires/s/, 'config'//" \
- setup.py || die
-
- # Tests are broken and should not be installed
- rm -r tests || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- newinitd "${FILESDIR}"/errd.initd errd
- newconfd "${FILESDIR}"/errd.confd errd
-
- dodir /etc/${PN}
- keepdir /var/lib/${PN}
- keepdir /var/log/${PN}
- fowners -R err:err /var/lib/${PN}
- fowners -R err:err /var/log/${PN}
-
- insinto /etc/${PN}
- newins errbot/config-template.py config.py
-}
diff --git a/net-im/err/files/errd.initd b/net-im/err/files/errd.initd
deleted file mode 100644
index 438d3dcc450..00000000000
--- a/net-im/err/files/errd.initd
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need net
-}
-
-start() {
- # create piddir if necessary, bug #448498
- local piddir=$(dirname ${ERR_PID_FILE})
- checkpath -q -d -o err:err -m 0770 "${piddir}" || {
- eend 1
- return 1
- }
-
- ebegin "Starting errd"
- start-stop-daemon --start --make-pidfile --pidfile ${ERR_PID_FILE} --background --quiet -u ${ERR_USER}:${ERR_GROUP} \
- --exec /usr/bin/python2 -- /usr/bin/err.py -c ${ERR_CONFIG_PATH}
- eend $?
-}
-
-stop() {
- ebegin "Stopping errd"
- start-stop-daemon --stop --pidfile ${ERR_PID_FILE}
- eend $?
-}
diff --git a/net-im/err/files/errd.initd.2 b/net-im/err/files/errd.initd.2
index 460cd070f54..460cd070f54 100755..100644
--- a/net-im/err/files/errd.initd.2
+++ b/net-im/err/files/errd.initd.2
diff --git a/net-im/err/metadata.xml b/net-im/err/metadata.xml
index 93446d15f5a..21914ed5cfe 100644
--- a/net-im/err/metadata.xml
+++ b/net-im/err/metadata.xml
@@ -7,7 +7,6 @@
</maintainer>
<use>
<flag name="irc">Pull optional dependencies, needed for IRC backend</flag>
- <flag name="plugins">Enable support for installing plugins with <pkg>dev-vcs/git</pkg></flag>
</use>
<upstream>
<remote-id type="github">gbin/err</remote-id>