summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-10-10 17:57:13 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-10-10 17:57:24 +0200
commitb157445544afceac7905ee55300b3b02735523e1 (patch)
treeaafb7b079525b1991ecfe2bca7f838c25216cc81 /net-im/prosody
parentnet-im/prosody: switch to bit32, update init scripts (diff)
downloadgentoo-b157445544afceac7905ee55300b3b02735523e1.tar.gz
gentoo-b157445544afceac7905ee55300b3b02735523e1.tar.bz2
gentoo-b157445544afceac7905ee55300b3b02735523e1.zip
net-im/prosody: drop old version
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-im/prosody')
-rw-r--r--net-im/prosody/files/prosody.initd-r346
-rw-r--r--net-im/prosody/prosody-0.11.7.ebuild79
2 files changed, 0 insertions, 125 deletions
diff --git a/net-im/prosody/files/prosody.initd-r3 b/net-im/prosody/files/prosody.initd-r3
deleted file mode 100644
index 3126cc8e1e20..000000000000
--- a/net-im/prosody/files/prosody.initd-r3
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-description="Prosody is a server for Jabber/XMPP written in Lua."
-description_reload="Reload configuration and reopen log files."
-extra_started_commands="reload"
-pidfile="/var/run/jabber/prosody.pid"
-
-depend() {
- need net
- provide jabber-server
- use dns postgresql
-}
-
-checkconfig() {
- if [ ! -e /etc/jabber/prosody.cfg.lua ] ; then
- eerror "You need a /etc/jabber/prosody.cfg.lua file to run prosody"
- return 1
- fi
- luac -p /etc/jabber/prosody.cfg.lua
- return $?
-}
-
-start() {
- checkconfig || return 1
- checkpath -q -d -m 0770 -o jabber:jabber "$(dirname ${pidfile})"
- checkpath -q -f -m 0770 -o jabber:jabber "${pidfile}"
- checkpath -q -d -m 0750 -o jabber:jabber /var/log/jabber
- ebegin "Starting Prosody XMPP Server"
- prosodyctl start
- eend $?
-}
-
-stop() {
- ebegin "Stopping Prosody XMPP Server"
- prosodyctl stop
- eend $?
-}
-
-reload() {
- checkconfig || return 1
- ebegin "Reloading configuration of Prosody XMPP Server"
- prosodyctl reload
- eend $?
-}
diff --git a/net-im/prosody/prosody-0.11.7.ebuild b/net-im/prosody/prosody-0.11.7.ebuild
deleted file mode 100644
index 041e5c27e526..000000000000
--- a/net-im/prosody/prosody-0.11.7.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd toolchain-funcs
-
-DESCRIPTION="Prosody is a flexible communications server for Jabber/XMPP written in Lua"
-HOMEPAGE="https://prosody.im/"
-SRC_URI="https://prosody.im/downloads/source/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="libevent libressl luajit mysql postgres sqlite ssl test zlib"
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="
- dev-lua/LuaBitOp
- net-dns/libidn
- net-im/jabber-base
- libressl? ( dev-libs/libressl:= )
- !libressl? ( dev-libs/openssl:0= )
- luajit? ( dev-lang/luajit:2 )
- !luajit? ( dev-lang/lua:0 )
-"
-
-DEPEND="
- ${COMMON_DEPEND}
- test? ( dev-lua/busted )
-"
-
-RDEPEND="
- ${COMMON_DEPEND}
- ~dev-lua/luaexpat-1.3.0
- dev-lua/luafilesystem
- dev-lua/luasocket
- libevent? ( dev-lua/luaevent )
- mysql? ( dev-lua/luadbi[mysql] )
- postgres? ( dev-lua/luadbi[postgres] )
- sqlite? ( dev-lua/luadbi[sqlite] )
- ssl? ( dev-lua/luasec )
- zlib? ( dev-lua/lua-zlib )
-"
-
-PATCHES=( "${FILESDIR}/${PN}-0.11.2-r1-gentoo.patch" )
-
-src_configure() {
- local myeconfargs=(
- --c-compiler="$(tc-getCC)"
- --datadir="${EPREFIX}/var/spool/jabber"
- --libdir="${EPREFIX}/usr/$(get_libdir)"
- --linker="$(tc-getCC)"
- --ostype="linux"
- --prefix="${EPREFIX}/usr"
- --runwith="$(usex luajit luajit lua)"
- --sysconfdir="${EPREFIX}/etc/jabber"
- --with-lua-include="${EPREFIX}/usr/include"
- --with-lua-lib="${EPREFIX}/usr/$(get_libdir)/lua"
- )
-
- # Since the configure script is handcrafted,
- # and yells at unknown options, do not use 'econf'.
- ./configure ${myeconfargs[@]} --cflags="${CFLAGS} -Wall -fPIC" --ldflags="${LDFLAGS} -shared" || die
-
- rm makefile || die
- mv GNUmakefile Makefile || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- keepdir /var/spool/jabber
-
- newinitd "${FILESDIR}"/prosody.initd-r3 prosody
-
- systemd_dounit "${FILESDIR}"/prosody.service
- systemd_newtmpfilesd "${FILESDIR}"/prosody.tmpfilesd prosody.conf
-}