summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZetok Zalbavar <zetok@openmailbox.org>2016-07-10 01:56:52 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-07-14 04:22:14 +1000
commit4fd3a7a20573fefa208ebfe0599620c42eef51d8 (patch)
tree0a98cd9516579071b708e009a95ada2852012a4e /net-im/qtox
parentkde-base/legacy-icons: Add missing slot 5 blockers (diff)
downloadgentoo-4fd3a7a20573fefa208ebfe0599620c42eef51d8.tar.gz
gentoo-4fd3a7a20573fefa208ebfe0599620c42eef51d8.tar.bz2
gentoo-4fd3a7a20573fefa208ebfe0599620c42eef51d8.zip
net-im/qtox: properly detect whether GCC is used for compiling
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-im/qtox')
-rw-r--r--net-im/qtox/qtox-1.3.0.ebuild2
-rw-r--r--net-im/qtox/qtox-1.4.0.ebuild2
-rw-r--r--net-im/qtox/qtox-9999.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/net-im/qtox/qtox-1.3.0.ebuild b/net-im/qtox/qtox-1.3.0.ebuild
index 5c25a9ff2cb..8c6a71430d2 100644
--- a/net-im/qtox/qtox-1.3.0.ebuild
+++ b/net-im/qtox/qtox-1.3.0.ebuild
@@ -47,7 +47,7 @@ DEPEND="${RDEPEND}
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
- if [[ $(tc-getCXX) == *g++ ]] ; then
+ if tc-is-gcc ; then
if [[ $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 8 || $(gcc-major-version) -lt 4 ]] ; then
eerror "You need at least sys-devel/gcc-4.8.3"
die "You need at least sys-devel/gcc-4.8.3"
diff --git a/net-im/qtox/qtox-1.4.0.ebuild b/net-im/qtox/qtox-1.4.0.ebuild
index ec6d329a938..eabc0c9e640 100644
--- a/net-im/qtox/qtox-1.4.0.ebuild
+++ b/net-im/qtox/qtox-1.4.0.ebuild
@@ -48,7 +48,7 @@ DEPEND="${RDEPEND}
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
- if [[ $(tc-getCXX) == *g++ ]] ; then
+ if tc-is-gcc ; then
if [[ $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 8 || $(gcc-major-version) -lt 4 ]] ; then
eerror "You need at least sys-devel/gcc-4.8.3"
die "You need at least sys-devel/gcc-4.8.3"
diff --git a/net-im/qtox/qtox-9999.ebuild b/net-im/qtox/qtox-9999.ebuild
index 0c69c91103c..281c524e45b 100644
--- a/net-im/qtox/qtox-9999.ebuild
+++ b/net-im/qtox/qtox-9999.ebuild
@@ -47,7 +47,7 @@ DEPEND="${RDEPEND}
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
- if [[ $(tc-getCXX) == *g++ ]] ; then
+ if tc-is-gcc ; then
if [[ $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 8 || $(gcc-major-version) -lt 4 ]] ; then
eerror "You need at least sys-devel/gcc-4.8.3"
die "You need at least sys-devel/gcc-4.8.3"