summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZetok Zalbavar <zetok@openmailbox.org>2017-08-17 18:07:07 +0100
committerMichał Górny <mgorny@gentoo.org>2017-08-18 21:24:35 +0200
commit922597bc7e6b2d6470fbf3c74d7184265126fc3d (patch)
treec9b86dd1782f5db94ae215504eece74e1ce5e1af /net-im/qtox
parentnet-im/qtox: remove no longer needed pkg_pretend and cleanup live ebuild (diff)
downloadgentoo-922597bc7e6b2d6470fbf3c74d7184265126fc3d.tar.gz
gentoo-922597bc7e6b2d6470fbf3c74d7184265126fc3d.tar.bz2
gentoo-922597bc7e6b2d6470fbf3c74d7184265126fc3d.zip
net-im/qtox: remove old ebuilds
Closes: https://github.com/gentoo/gentoo/pull/4616 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'net-im/qtox')
-rw-r--r--net-im/qtox/Manifest2
-rw-r--r--net-im/qtox/qtox-1.6.0.ebuild70
-rw-r--r--net-im/qtox/qtox-1.7.0.ebuild69
3 files changed, 0 insertions, 141 deletions
diff --git a/net-im/qtox/Manifest b/net-im/qtox/Manifest
index 271d4702db9..d259286e356 100644
--- a/net-im/qtox/Manifest
+++ b/net-im/qtox/Manifest
@@ -1,4 +1,2 @@
DIST qtox-1.11.0.tar.lz 2860849 SHA256 c4d3ac9d263fd4e603867fe0ae263bff4f810593cc518858bc1d0c274883652f SHA512 3117b5ec9d88f58023f6c2f5e7c37c547ab920588d385e3abe062fb22ad79c49a9b6eb9ca31c6d56f9d03cfea55ef56ddc7e2e53bd43629825ea7b460b31f505 WHIRLPOOL 26da6d3e330b05e97b75c1046ee3bd818694a60dfa637317333f5e8bf85de5f4c7aed3f9bc2f13f53e13dda1690bc705d776a38e5cf5080fa095dc006cab2c3f
-DIST qtox-1.6.0.tar.gz 3481328 SHA256 7450e751da5cc6dce00b58df6d06a309e2674c7bd9311de6af21e53c36c3f155 SHA512 6ccf2c17c25ea30899356518b8f8849ed53404a8ac81180e2719c979dab1f411a93aa08ad759b3e8defea994d3baaf538ed354b733a321de3615521dcf6c8192 WHIRLPOOL 999aacf9724697526f925721e7202168076bcaac9fb5a733ef6374518f3ab86c9a3ded9d0911e2a2d677c0af0c474054d7f6c2cc06fd430c98366d9fa48f19ab
-DIST qtox-1.7.0.tar.gz 3563009 SHA256 b33916b64f3992a46c1b1da8ce124e41048b76a780732c9c73e3645706334ec9 SHA512 f7a49f00e222f49653388ddca973a2c49ca84b7dd1625997bb3fe819332bee252b59e5478437569d7e6ab6ce501eb2c909d22cec64349e94ddcdd7458143386f WHIRLPOOL 253402b69941e434ad6ac2411faf0a9aa5ed70045631c0522f57ff971ef90c8efa91be92ab012edff49451802058835b1d4e90bd3150151afe0a8c5453c60db2
DIST qtox-1.8.1.tar.gz 3594727 SHA256 32837b5f824b6987a68f9211f93a7ec32b892be895605012d35784d702f13d6c SHA512 9ba32ce43f2d335fe9e07bcca651e0e18ae2f3247e52364918148e400e51f6e2364d1596c7c882674c190bf5438e69cd13e77512eeeec7cba212195e9559a5ae WHIRLPOOL a6bd845a3c8d31ea1c8aa3bee360c46c562aaff0ad35c9d92bdd8167c550904428936edb0e88c0b72362704d2e5b844ea16afcc57704d442cdd6558344572557
diff --git a/net-im/qtox/qtox-1.6.0.ebuild b/net-im/qtox/qtox-1.6.0.ebuild
deleted file mode 100644
index 8293b4ea676..00000000000
--- a/net-im/qtox/qtox-1.6.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils qmake-utils
-
-DESCRIPTION="Most feature-rich GUI for net-libs/tox using Qt5"
-HOMEPAGE="https://github.com/qTox/qTox"
-SRC_URI="https://github.com/qTox/qTox/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gtk X"
-
-# needed, since tarball provided by github extracts to `qTox`
-S="${WORKDIR}/qTox-${PV}"
-
-RDEPEND="
- dev-db/sqlcipher
- dev-libs/libsodium
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5[gif,jpeg,png,xcb]
- dev-qt/qtnetwork:5
- dev-qt/qtopengl:5
- dev-qt/qtsql:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- media-gfx/qrencode
- media-libs/openal
- >=media-video/ffmpeg-2.6.3[webp,v4l]
- gtk? ( dev-libs/atk
- dev-libs/glib:2
- x11-libs/gdk-pixbuf[X]
- x11-libs/gtk+:2
- x11-libs/cairo[X]
- x11-libs/pango[X] )
- net-libs/tox:0/0.0[av]
- X? ( x11-libs/libX11
- x11-libs/libXScrnSaver )
-"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
- virtual/pkgconfig
-"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if tc-is-gcc ; then
- if [[ $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 8 || $(gcc-major-version) -lt 4 ]] ; then
- eerror "You need at least sys-devel/gcc-4.8.3"
- die "You need at least sys-devel/gcc-4.8.3"
- fi
- fi
- fi
-}
-
-src_configure() {
- use gtk || local NO_GTK_SUPPORT="ENABLE_SYSTRAY_STATUSNOTIFIER_BACKEND=NO ENABLE_SYSTRAY_GTK_BACKEND=NO"
- use X || local NO_X_SUPPORT="DISABLE_PLATFORM_EXT=YES"
-
- eqmake5 \
- PREFIX="${D}/usr" \
- GIT_DESCRIBE="${PV}" \
- ${NO_GTK_SUPPORT} \
- ${NO_X_SUPPORT}
-}
diff --git a/net-im/qtox/qtox-1.7.0.ebuild b/net-im/qtox/qtox-1.7.0.ebuild
deleted file mode 100644
index 488f2eda6c2..00000000000
--- a/net-im/qtox/qtox-1.7.0.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit qmake-utils toolchain-funcs
-
-DESCRIPTION="Most feature-rich GUI for net-libs/tox using Qt5"
-HOMEPAGE="https://github.com/qTox/qTox"
-SRC_URI="https://github.com/qTox/qTox/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gtk X"
-
-# needed, since tarball provided by github extracts to `qTox`
-S="${WORKDIR}/qTox-${PV}"
-
-RDEPEND="
- dev-db/sqlcipher
- dev-libs/libsodium
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5[gif,jpeg,png,xcb]
- dev-qt/qtnetwork:5
- dev-qt/qtopengl:5
- dev-qt/qtsql:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- media-gfx/qrencode
- media-libs/openal
- >=media-video/ffmpeg-2.6.3[webp,v4l]
- gtk? ( dev-libs/atk
- dev-libs/glib:2
- x11-libs/gdk-pixbuf[X]
- x11-libs/gtk+:2
- x11-libs/cairo[X]
- x11-libs/pango[X] )
- net-libs/tox:0/0.1[av]
- X? ( x11-libs/libX11
- x11-libs/libXScrnSaver )
-"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
- virtual/pkgconfig
-"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if tc-is-gcc ; then
- if [[ $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 8 || $(gcc-major-version) -lt 4 ]] ; then
- eerror "You need at least sys-devel/gcc-4.8.3"
- die "You need at least sys-devel/gcc-4.8.3"
- fi
- fi
- fi
-}
-
-src_configure() {
- use gtk || local NO_GTK_SUPPORT="ENABLE_SYSTRAY_STATUSNOTIFIER_BACKEND=NO ENABLE_SYSTRAY_GTK_BACKEND=NO"
- use X || local NO_X_SUPPORT="DISABLE_PLATFORM_EXT=YES"
- eqmake5 \
- PREFIX="${D}/usr" \
- GIT_DESCRIBE="${PV}" \
- ${NO_GTK_SUPPORT} \
- ${NO_X_SUPPORT}
-}