summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRobert Siebeck <gentoo.bugzilla.2012@r123.de>2018-05-15 17:36:02 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-15 20:14:33 +0200
commit219064dfb5d8ac9fdc5b174ecf661cb46bf2bf0b (patch)
tree8875fc0c3758e944a7d147c03788ede35672ca76 /net-im
parentnet-irc/znc: update HOMEPAGE to use https (diff)
downloadgentoo-219064dfb5d8ac9fdc5b174ecf661cb46bf2bf0b.tar.gz
gentoo-219064dfb5d8ac9fdc5b174ecf661cb46bf2bf0b.tar.bz2
gentoo-219064dfb5d8ac9fdc5b174ecf661cb46bf2bf0b.zip
net-im/signal-desktop-bin: add version 1.11.0
Diffstat (limited to 'net-im')
-rw-r--r--net-im/signal-desktop-bin/Manifest1
-rw-r--r--net-im/signal-desktop-bin/signal-desktop-bin-1.11.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-im/signal-desktop-bin/Manifest b/net-im/signal-desktop-bin/Manifest
index f91aa9a0463a..f6c3ff7eac50 100644
--- a/net-im/signal-desktop-bin/Manifest
+++ b/net-im/signal-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST signal-desktop_1.10.1_amd64.deb 64234894 BLAKE2B 2f793979c25ebf38235d58a7f656f763e5d0a753acce7850a98716b2396c24ea0c0b5f89573b91cc7468330c0c7cf99fd5b0324046e1f8fad052d2e292111ea4 SHA512 7c41129a3e5653401b5bcaa71996f2248d682159cc877d00935411586259a7d53d29186d05df34f454fc834d3e7974c76a3a033ba1f1870ae55053aca58fcf8f
+DIST signal-desktop_1.11.0_amd64.deb 64041386 BLAKE2B e2a059873afa9223267ac1cd5560f1b8fbcf16935561c67e18c670fd02bc48d63cab89ceecf74c26ac8e5d9cea702757ee4d2516a3a545efcc56fb4362ae37f1 SHA512 776f3e75ef304af5da72cc6e67b3cf541183bc461cffa38e575a4f9019a088553983c2ed7b5381de85f68f2228cc3505384337e6cf621019ef0cd3f83b60aeac
diff --git a/net-im/signal-desktop-bin/signal-desktop-bin-1.11.0.ebuild b/net-im/signal-desktop-bin/signal-desktop-bin-1.11.0.ebuild
new file mode 100644
index 000000000000..1c8881910bea
--- /dev/null
+++ b/net-im/signal-desktop-bin/signal-desktop-bin-1.11.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-bin/}"
+
+inherit gnome2-utils pax-utils unpacker xdg-utils
+DESCRIPTION="Allows you to send and receive messages of Signal Messenger on your computer"
+HOMEPAGE="https://signal.org/
+ https://github.com/WhisperSystems/Signal-Desktop"
+SRC_URI="https://updates.signal.org/desktop/apt/pool/main/s/${MY_PN}/${MY_PN}_${PV}_amd64.deb"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ gnome-base/gconf:2
+ dev-libs/nss
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ net-print/cups
+ "
+
+QA_PREBUILT="opt/Signal/signal-desktop
+ opt/Signal/libnode.so
+ opt/Signal/libffmpeg.so"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /
+ dodoc -r usr/share/doc/signal-desktop/.
+ doins -r opt
+ insinto /usr/share
+ doins -r usr/share/applications
+ doins -r usr/share/icons
+ fperms +x /opt/Signal/signal-desktop
+ pax-mark m opt/Signal/signal-desktop
+
+ dosym ../../opt/Signal/${MY_PN} /usr/bin/${MY_PN}
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}